]> git.pld-linux.org Git - packages/avidemux.git/blob - avidemux.spec
- rel 3
[packages/avidemux.git] / avidemux.spec
1 # TODO:
2 #       - create aften.spec (aften.sf.net) and use it
3 #
4 # Conditional build:
5 %bcond_without  esd     # disable EsounD sound support
6 %bcond_without  arts    # without arts audio output
7 %bcond_with     amr     # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
8 %bcond_with     qt      # build qt4-base interface
9 %bcond_with     ssse3   # use SSSE3 instructions
10 #
11 %ifarch pentium4 %{x8664}
12 %define         with_sse3       1
13 %endif
14
15 Summary:        A small audio/video editing software for Linux
16 Summary(pl.UTF-8):      Mały edytor audio/wideo dla Linuksa
17 Name:           avidemux
18 Version:        2.4.3
19 Release:        3
20 License:        GPL v2+
21 Group:          X11/Applications/Multimedia
22 Source0:        http://download2.berlios.de/avidemux/%{name}_%{version}.tar.gz
23 # Source0-md5:  ff8e6ac186321e7e8bec9f8177df3724
24 Source1:        %{name}.desktop
25 Patch0:         %{name}-autoconf.patch
26 Patch1:         %{name}-dts_internal.patch
27 Patch2:         %{name}-sparc64.patch
28 URL:            http://fixounet.free.fr/avidemux/
29 BuildRequires:  SDL-devel
30 BuildRequires:  a52dec-libs-devel
31 BuildRequires:  alsa-lib-devel >= 1.0
32 %{?with_amr:BuildRequires:      amrnb-devel}
33 %{?with_arts:BuildRequires:     artsc-devel}
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 %{?with_esd:BuildRequires:      esound-devel}
37 BuildRequires:  faad2-devel
38 BuildRequires:  ffmpeg-devel
39 BuildRequires:  freetype-devel >= 2.0.0
40 BuildRequires:  gettext-devel
41 BuildRequires:  gtk+2-devel >= 1:2.6.0
42 BuildRequires:  js-devel(threads)
43 BuildRequires:  lame-libs-devel
44 BuildRequires:  libdts-devel
45 BuildRequires:  libmad-devel
46 BuildRequires:  libmpeg3-devel
47 BuildRequires:  libsamplerate-devel
48 BuildRequires:  libstdc++-devel
49 BuildRequires:  libtool
50 BuildRequires:  libvorbis-devel
51 BuildRequires:  libx264-devel
52 BuildRequires:  libxml2-devel
53 BuildRequires:  pkgconfig
54 %{?with_qt:BuildRequires:       QtGui-devel}
55 %{?with_qt:BuildRequires:       qt4-build}
56 BuildRequires:  sed >= 4.0
57 BuildRequires:  xorg-lib-libXt-devel
58 BuildRequires:  xorg-lib-libXv-devel
59 BuildRequires:  xorg-proto-xextproto-devel
60 BuildRequires:  xvid-devel >= 1:1.0
61 Requires:       js(threads)
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 A small audio/video editing software for Linux.
66
67 %description -l pl.UTF-8
68 Mały edytor audio/wideo dla Linuksa.
69
70 %prep
71 %setup -q -n %{name}_%{version}
72 %patch0 -p1
73 %patch1 -p0
74 %patch2 -p1
75
76 echo 'pt_BR' >> po/LINGUAS
77
78 %build
79 %{__cp} /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
80 %{__make} -f admin/Makefile.common cvs
81 #%{__libtoolize}
82 #%{__aclocal} -I m4
83 #%{__autoconf}
84 #%{__automake}
85 %configure \
86         %{!?with_amr:ac_cv_header_amrnb_interf_dec_h=no} \
87         %{!?with_arts:--without-arts} \
88         %{!?with_esd:--without-esd} \
89         --disable-static \
90 %ifarch ppc
91         --enable-altivec \
92 %endif
93         %{?with_ssse3:--enable-ssse3} \
94 %if %{with qt}
95         --with-qt-dir=%{_prefix} \
96         --with-qt-include=%{_includedir}/qt4 \
97         --with-qt-lib=%{_libdir}
98 %endif
99
100 %{__make} -j1 -C po
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
111 install avidemux_icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
112
113 %find_lang %{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc AUTHORS History
121 %attr(755,root,root) %{_bindir}/avidemux2_cli
122 %attr(755,root,root) %{_bindir}/avidemux2_gtk
123 %{?with_qt:%attr(755,root,root) %{_bindir}/avidemux2_qt4}
124 %{_desktopdir}/*.desktop
125 %{_pixmapsdir}/*.png
This page took 0.029948 seconds and 4 git commands to generate.