]> git.pld-linux.org Git - packages/avidemux.git/blob - avidemux.spec
- cleanup
[packages/avidemux.git] / avidemux.spec
1 # TODO:
2 #       - build qt4 interface
3 #       - create aften.spec (aften.sf.net) and use it
4 #
5 # Conditional build:
6 %bcond_with     amr     # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
7 #
8 Summary:        A small audio/video editing software for Linux
9 Summary(pl.UTF-8):      Mały edytor audio/wideo dla Linuksa
10 Name:           avidemux
11 Version:        2.4
12 Release:        1
13 License:        GPL v2+
14 Group:          X11/Applications/Multimedia
15 Source0:        http://download2.berlios.de/avidemux/%{name}_%{version}.tar.gz
16 # Source0-md5:  2a752b9f6bab4123566894a6a21b353b
17 Source1:        %{name}.desktop
18 Patch0:         %{name}-autoconf.patch
19 Patch1:         %{name}-dts_internal.patch
20 URL:            http://fixounet.free.fr/avidemux/
21 BuildRequires:  SDL-devel
22 BuildRequires:  a52dec-libs-devel
23 BuildRequires:  alsa-lib-devel >= 1.0
24 %{?with_amr:BuildRequires:      amrnb-devel}
25 BuildRequires:  artsc-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  esound-devel
29 BuildRequires:  faad2-devel
30 BuildRequires:  ffmpeg-devel
31 BuildRequires:  freetype-devel >= 2.0.0
32 BuildRequires:  gettext-devel
33 BuildRequires:  gtk+2-devel >= 1:2.6.0
34 BuildRequires:  js-devel(threads)
35 BuildRequires:  lame-libs-devel
36 BuildRequires:  libdts-devel
37 BuildRequires:  libmad-devel
38 BuildRequires:  libmpeg3-devel
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libvorbis-devel
41 BuildRequires:  libx264-devel
42 BuildRequires:  libxml2-devel
43 BuildRequires:  pkgconfig
44 BuildRequires:  sed >= 4.0
45 BuildRequires:  xorg-lib-libXv-devel
46 BuildRequires:  xvid-devel >= 1:1.0
47 Requires:       js(threads)
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 A small audio/video editing software for Linux.
52
53 %description -l pl.UTF-8
54 Mały edytor audio/wideo dla Linuksa.
55
56 %prep
57 %setup -q -n %{name}_%{version}
58 %patch0 -p1
59 %patch1 -p0
60
61 echo 'pt_BR' >> po/LINGUAS
62
63 %build
64 export kde_htmldir=%{_kdedocdir}
65 export kde_libs_htmldir=%{_kdedocdir}
66 %{__make} -f admin/Makefile.common cvs
67 %configure \
68         %{!?with_amr:ac_cv_header_amrnb_interf_dec_h=no} \
69         --disable-static \
70 %ifarch ppc
71         --enable-altivec \
72 %endif
73         --with-jsapi-include=%{_includedir}/js
74 # moc-qt4 expected
75 #       --with-qt-dir=%{_prefix} \
76 #       --with-qt-include=%{_includedir}/qt4 \
77 #       --with-qt-lib=%{_libdir}
78
79 %{__make} -j1 -C po
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
90 install avidemux_icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
91
92 %find_lang %{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files -f %{name}.lang
98 %defattr(644,root,root,755)
99 %doc AUTHORS History
100 %attr(755,root,root) %{_bindir}/avidemux2_cli
101 %attr(755,root,root) %{_bindir}/avidemux2_gtk
102 %{_desktopdir}/*.desktop
103 %{_pixmapsdir}/*.png
This page took 0.069811 seconds and 4 git commands to generate.