]> git.pld-linux.org Git - packages/avidemux.git/blob - avidemux.spec
- qt4-based interface is ready
[packages/avidemux.git] / avidemux.spec
1 # TODO:
2 #       - create aften.spec (aften.sf.net) and use it
3 #
4 # Conditional build:
5 %bcond_with     amr     # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
6 %bcond_with     qt      # build qt4-base interface
7 #
8 Summary:        A small audio/video editing software for Linux
9 Summary(pl.UTF-8):      Mały edytor audio/wideo dla Linuksa
10 Name:           avidemux
11 Version:        2.4.1
12 Release:        1
13 License:        GPL v2+
14 Group:          X11/Applications/Multimedia
15 Source0:        http://download2.berlios.de/avidemux/%{name}_%{version}.tar.gz
16 # Source0-md5:  2d972f6b8795c891dd6e0ebe5035852a
17 Source1:        %{name}.desktop
18 Patch0:         %{name}-autoconf.patch
19 Patch1:         %{name}-dts_internal.patch
20 Patch2:         %{name}-sparc64.patch
21 URL:            http://fixounet.free.fr/avidemux/
22 BuildRequires:  SDL-devel
23 BuildRequires:  a52dec-libs-devel
24 BuildRequires:  alsa-lib-devel >= 1.0
25 %{?with_amr:BuildRequires:      amrnb-devel}
26 BuildRequires:  artsc-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  esound-devel
30 BuildRequires:  faad2-devel
31 BuildRequires:  ffmpeg-devel
32 BuildRequires:  freetype-devel >= 2.0.0
33 BuildRequires:  gettext-devel
34 BuildRequires:  gtk+2-devel >= 1:2.6.0
35 BuildRequires:  js-devel(threads)
36 BuildRequires:  lame-libs-devel
37 BuildRequires:  libdts-devel
38 BuildRequires:  libmad-devel
39 BuildRequires:  libmpeg3-devel
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtool
42 BuildRequires:  libvorbis-devel
43 BuildRequires:  libx264-devel
44 BuildRequires:  libxml2-devel
45 BuildRequires:  pkgconfig
46 %{?with_qt:BuildRequires:       QtGui-devel}
47 %{?with_qt:BuildRequires:       qt4-build}
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  xorg-lib-libXv-devel
50 BuildRequires:  xvid-devel >= 1:1.0
51 Requires:       js(threads)
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 A small audio/video editing software for Linux.
56
57 %description -l pl.UTF-8
58 Mały edytor audio/wideo dla Linuksa.
59
60 %prep
61 %setup -q -n %{name}_%{version}
62 %patch0 -p1
63 %patch1 -p0
64 %patch2 -p1
65
66 echo 'pt_BR' >> po/LINGUAS
67
68 %build
69 export kde_htmldir=%{_kdedocdir}
70 export kde_libs_htmldir=%{_kdedocdir}
71 %{__make} -f admin/Makefile.common cvs
72 %{__libtoolize}
73 %{__aclocal} -I m4
74 %{__automake}
75 %{__autoconf}
76 %configure \
77         %{!?with_amr:ac_cv_header_amrnb_interf_dec_h=no} \
78         --disable-static \
79 %ifarch ppc
80         --enable-altivec \
81 %endif
82         --with-jsapi-include=%{_includedir}/js \
83 %if %{with qt}
84         --with-qt-dir=%{_prefix} \
85         --with-qt-include=%{_includedir}/qt4 \
86         --with-qt-lib=%{_libdir}
87 %endif
88
89 %{__make} -j1 -C po
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
100 install avidemux_icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
101
102 %find_lang %{name}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files -f %{name}.lang
108 %defattr(644,root,root,755)
109 %doc AUTHORS History
110 %attr(755,root,root) %{_bindir}/avidemux2_cli
111 %attr(755,root,root) %{_bindir}/avidemux2_gtk
112 %{?with_qt:%attr(755,root,root) %{_bindir}/avidemux2_qt4}
113 %{_desktopdir}/*.desktop
114 %{_pixmapsdir}/*.png
This page took 0.083271 seconds and 4 git commands to generate.