]> git.pld-linux.org Git - packages/avfs.git/commitdiff
- taken from official repo
authorblekot <blekot@pld-linux.org>
Thu, 22 Mar 2012 20:49:37 +0000 (20:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    avfs-unrar.c.patch -> 1.1
    avfs.spec -> 1.16

avfs-unrar.c.patch [new file with mode: 0644]
avfs.spec

diff --git a/avfs-unrar.c.patch b/avfs-unrar.c.patch
new file mode 100644 (file)
index 0000000..d9e0b0a
--- /dev/null
@@ -0,0 +1,39 @@
+diff -ur avfs-1.0.0.old/avfscoda/dispatch.c avfs-1.0.0/avfscoda/dispatch.c
+--- avfs-1.0.0.old/avfscoda/dispatch.c 2012-03-22 18:29:17.000000000 +0000
++++ avfs-1.0.0/avfscoda/dispatch.c     2012-03-22 18:31:09.000000000 +0000
+@@ -147,7 +147,7 @@
+     va_end(ap);
+     buf[LOGMSG_SIZE] = '\0';
+-    syslog(LOG_INFO, buf);
++    syslog(LOG_INFO, "%s", buf);
+     log(buf);
+ }
+Only in avfs-1.0.0/avfscoda: dispatch.c~
+diff -ur avfs-1.0.0.old/modules/urar.c avfs-1.0.0/modules/urar.c
+--- avfs-1.0.0.old/modules/urar.c      2012-03-22 18:29:17.000000000 +0000
++++ avfs-1.0.0/modules/urar.c  2012-03-22 18:30:33.000000000 +0000
+@@ -587,7 +587,7 @@
+     if(res < 0)
+         return res;
+-    fd = open(tmpfile, O_RDWR | O_CREAT | O_TRUNC);
++    fd = open(tmpfile, O_RDWR | O_CREAT | O_TRUNC,0644);
+     if(fd == -1) {
+         res = -errno; 
+         av_log(AVLOG_ERROR, "RAR: Could not open %s: %s", tmpfile,
+Only in avfs-1.0.0/modules: urar.c~
+diff -ur avfs-1.0.0.old/src/sysdeps.c avfs-1.0.0/src/sysdeps.c
+--- avfs-1.0.0.old/src/sysdeps.c       2012-03-22 18:29:17.000000000 +0000
++++ avfs-1.0.0/src/sysdeps.c   2012-03-22 18:31:34.000000000 +0000
+@@ -209,7 +209,7 @@
+     va_end(ap);
+     if(logfile == NULL)
+-        syslog(LOG_INFO, buf);
++        syslog(LOG_INFO, "%s", buf);
+     else
+         filelog(buf);
+     AV_UNLOCK(loglock);
+Only in avfs-1.0.0/src: sysdeps.c~
index adaf468193cda792bdcc50bda6fee2d930a92df0..c3c349cf8b7a29c0665e7997d8d2a90bdaba244e 100644 (file)
--- a/avfs.spec
+++ b/avfs.spec
@@ -4,12 +4,13 @@
 Summary:       AVFS - A Virtual Filesystem
 Summary(pl.UTF-8):     AVFS - wirtualny system plików
 Name:          avfs
-Version:       0.9.8
-Release:       0.1
+Version:       1.0.0
+Release:       1
 License:       GPL
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/avf/%{name}-%{version}.tar.gz
-# Source0-md5: cd1d5c3616124bc8397936718cc0d651
+# Source0-md5: be6dd4417c3e96a294f1539ad22fddc9
+Patch0:                %{name}-unrar.c.patch
 URL:           http://sourceforge.net/projects/avf/
 BuildRequires: automake
 BuildRequires: libfuse-devel >= 0:2.4
@@ -66,6 +67,7 @@ Ten pakiet zawiera statyczną wersję biblioteki avfs.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 cp -f /usr/share/automake/config.* .
@@ -94,6 +96,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README doc/README.avfs-fuse
 %attr(755,root,root) %{_libdir}/libavfs.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}libavfs.so.0
 %attr(755,root,root) %{_bindir}/avfsd
 %attr(755,root,root) %{_bindir}/davpass
 %attr(755,root,root) %{_bindir}/ftppass
This page took 0.074019 seconds and 4 git commands to generate.