]> git.pld-linux.org Git - packages/avfs.git/blobdiff - avfs.spec
rebuild with separate debuginfo build-ids
[packages/avfs.git] / avfs.spec
index 879107c0dc6bdeef5b89acebebeb6c658e0d2a32..481c08171f50a68371e27845e2185fa5c64cc93c 100644 (file)
--- a/avfs.spec
+++ b/avfs.spec
@@ -1,20 +1,28 @@
 # TODO
 # do --enable-dav switch
 
-Summary:       AFS - A Virtual Filesystem
-Summary(pl):   AFS - wirtualny system plików
+Summary:       AVFS - A Virtual Filesystem
+Summary(pl.UTF-8):     AVFS - wirtualny system plików
 Name:          avfs
-Version:       0.9.6
-Release:       0.1
-License:       GPL
+Version:       1.1.4
+Release:       2
+License:       GPL v2+
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/avf/%{name}-%{version}.tar.gz
-# Source0-md5: 59829701fb2d7593ed7c1de9e0a5ac63
+Source0:       https://downloads.sourceforge.net/avf/%{name}-%{version}.tar.bz2
+# Source0-md5: c333462d744aeab2e6bee7a1af02350e
 URL:           http://sourceforge.net/projects/avf/
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
-BuildRequires: expat-devel
-BuildRequires: neon-devel
-BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: bzip2-devel
+BuildRequires: libfuse-devel >= 2.6.0
+BuildRequires: libtool
+BuildRequires: lzlib-devel
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
+BuildRequires: xz-devel
+BuildRequires: zlib-devel
+BuildRequires: zstd-devel
+Requires:      libfuse >= 2.6.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -27,31 +35,66 @@ and rar files, FTP sessions, http, webdav, rsh/rcp, ssh/scp. Quite a
 few other handlers are implemented with the Midnight Commander's
 external FS.
 
-%description -l pl
-AVFS to system, który umo¿liwia wszystkim programom zagl±danie do
-zarchiwizowanych lub skompresowanych plików lub dostêp do zdanych
-plików bez rekompilacji programów lub zmiany j±dra.
+%description -l pl.UTF-8
+AVFS to system, który umożliwia wszystkim programom zaglądanie do
+zarchiwizowanych lub skompresowanych plików lub dostęp do zdanych
+plików bez rekompilacji programów lub zmiany jądra.
 
-Aktualnie obs³uguje dyskietki, pliki tar, gzip, zip, bzip2, ar i rar,
-sesje FTP, http, webdav, rsh/rcp, ssh/scp. Jest te¿ trochê innych
-procedur obs³ugi zaimplementowanych z u¿yciem extfs (zewnêtrznych
-systemów plików) Midnight Commandera.
+Aktualnie obsługuje dyskietki, pliki tar, gzip, zip, bzip2, ar i rar,
+sesje FTP, http, webdav, rsh/rcp, ssh/scp. Jest też trochę innych
+procedur obsługi zaimplementowanych z użyciem extfs (zewnętrznych
+systemów plików) Midnight Commandera.
+
+%package devel
+Summary:       Header files for avfs library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki avfs
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description devel
+The avfs-devel package includes the header files necessary for
+developing programs using the avfs library.
+
+%description devel -l pl.UTF-8
+Pakiet avfs-devel zawiera pliki nagłówkowe niezbędne do budowania
+programów używających biblioteki avfs.
+
+%package static
+Summary:       Static avfs library
+Summary(pl.UTF-8):     Statyczna biblioteka avfs
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description static
+This package contains the static version of avfs library.
+
+%description static -l pl.UTF-8
+Ten pakiet zawiera statyczną wersję biblioteki avfs.
 
 %prep
 %setup -q
 
 %build
-install /usr/share/automake/config.* .
-
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
-       --enable-preload \
-       --enable-xml \
-       --with-neon \
-       --with-ssl \
-       --with-kernel=%{_kernelsrcdir}
-#        --enable-dav 
+       EMACS=%{_bindir}/emacs \
+       PERL=%{_bindir}/perl \
+       ZIP=%{_bindir}/zip \
+       UNZIP=%{_bindir}/unzip \
+       --disable-avfscoda \
+       --disable-dav \
+       --enable-fuse \
+       --enable-library \
+       --with-system-bzlib \
+       --with-system-zlib \
+       --with-xz \
+       --with-zstd
 # Comment:
-# I've no idea how to build this package with dav option with expat-devel.
+# I've no idea how to build this package with dav option with expat-devel  --blekot
 %{__make}
 
 %install
@@ -68,10 +111,24 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README
-%attr(755,root,root) %{_libdir}/*.so.*.*
+%doc README doc/README.avfs-fuse
+%attr(755,root,root) %{_libdir}/libavfs.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libavfs.so.0
+%attr(755,root,root) %{_bindir}/avfsd
 %attr(755,root,root) %{_bindir}/davpass
 %attr(755,root,root) %{_bindir}/ftppass
+%attr(755,root,root) %{_bindir}/mountavfs
+%attr(755,root,root) %{_bindir}/umountavfs
 %{_libdir}/%{name}
-%{_libdir}/avfs_preload.a
-%{_libdir}/avfs_preload.la
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/avfs-config
+%attr(755,root,root) %{_libdir}/libavfs.so
+%{_libdir}/libavfs.la
+%{_includedir}/*.h
+%{_pkgconfigdir}/avfs.pc
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libavfs.a
This page took 0.051007 seconds and 4 git commands to generate.