]> git.pld-linux.org Git - packages/avfs.git/blobdiff - avfs.spec
rebuild with separate debuginfo build-ids
[packages/avfs.git] / avfs.spec
index 7823891229f5c3fea48a00d1523df01bdd881f9a..481c08171f50a68371e27845e2185fa5c64cc93c 100644 (file)
--- a/avfs.spec
+++ b/avfs.spec
@@ -1,16 +1,28 @@
-Summary:       AFS - A Virtual Filesystem
-Summary(pl):   AFS - wirtualny system plików
+# TODO
+# do --enable-dav switch
+
+Summary:       AVFS - A Virtual Filesystem
+Summary(pl.UTF-8):     AVFS - wirtualny system plików
 Name:          avfs
-Version:       0.9.3
-Release:       1
-License:       GPL
+Version:       1.1.4
+Release:       2
+License:       GPL v2+
 Group:         Libraries
-# Source0-md5: 1b8087516b1abc9965056d1f4595c4f0
-Source0:       http://dl.sourceforge.net/avf/%{name}-%{version}.tar.gz
+Source0:       https://downloads.sourceforge.net/avf/%{name}-%{version}.tar.bz2
+# Source0-md5: c333462d744aeab2e6bee7a1af02350e
 URL:           http://sourceforge.net/projects/avf/
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
-BuildRequires: neon-devel
-BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: bzip2-devel
+BuildRequires: libfuse-devel >= 2.6.0
+BuildRequires: libtool
+BuildRequires: lzlib-devel
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
+BuildRequires: xz-devel
+BuildRequires: zlib-devel
+BuildRequires: zstd-devel
+Requires:      libfuse >= 2.6.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -19,37 +31,78 @@ or compressed files, or access remote files without recompiling the
 programs or changing the kernel.
 
 At the moment it supports floppies, tar and gzip files, zip, bzip2, ar
-and rar files, ftp sessions, http, webdav, rsh/rcp, ssh/scp. Quite a
+and rar files, FTP sessions, http, webdav, rsh/rcp, ssh/scp. Quite a
 few other handlers are implemented with the Midnight Commander's
 external FS.
 
-%description -l pl
-AVFS to system, który umo¿liwia wszystkim programom zagl±danie do
-zarchiwizowanych lub skompresowanych plików lub dostêp do zdanych
-plików bez rekompilacji programów lub zmiany j±dra.
+%description -l pl.UTF-8
+AVFS to system, który umożliwia wszystkim programom zaglądanie do
+zarchiwizowanych lub skompresowanych plików lub dostęp do zdanych
+plików bez rekompilacji programów lub zmiany jądra.
+
+Aktualnie obsługuje dyskietki, pliki tar, gzip, zip, bzip2, ar i rar,
+sesje FTP, http, webdav, rsh/rcp, ssh/scp. Jest też trochę innych
+procedur obsługi zaimplementowanych z użyciem extfs (zewnętrznych
+systemów plików) Midnight Commandera.
+
+%package devel
+Summary:       Header files for avfs library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki avfs
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description devel
+The avfs-devel package includes the header files necessary for
+developing programs using the avfs library.
+
+%description devel -l pl.UTF-8
+Pakiet avfs-devel zawiera pliki nagłówkowe niezbędne do budowania
+programów używających biblioteki avfs.
+
+%package static
+Summary:       Static avfs library
+Summary(pl.UTF-8):     Statyczna biblioteka avfs
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
 
-Aktualnie obs³uguje dyskietki, pliki tar, gzip, zip, bzip2, ar i rar,
-sesje ftp, http, webdav, rsh/rcp, ssh/scp. Jest te¿ trochê innych
-procedur obs³ugi zaimplementowanych z u¿yciem extfs (zewnêtrznych
-systemów plików) Midnight Commandera.
+%description static
+This package contains the static version of avfs library.
+
+%description static -l pl.UTF-8
+Ten pakiet zawiera statyczną wersję biblioteki avfs.
 
 %prep
 %setup -q
 
 %build
-install %{_datadir}/automake/config.* .
-%configure2_13 \
-       --enable-preload \
-       --enable-xml \
-       --enable-dav \
-       --with-neon \
-       --with-ssl \
-       --with-kernel=%{_kernelsrcdir}
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%configure \
+       EMACS=%{_bindir}/emacs \
+       PERL=%{_bindir}/perl \
+       ZIP=%{_bindir}/zip \
+       UNZIP=%{_bindir}/unzip \
+       --disable-avfscoda \
+       --disable-dav \
+       --enable-fuse \
+       --enable-library \
+       --with-system-bzlib \
+       --with-system-zlib \
+       --with-xz \
+       --with-zstd
+# Comment:
+# I've no idea how to build this package with dav option with expat-devel  --blekot
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
+%{__make} install \
+        DESTDIR=$RPM_BUILD_ROOT
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -58,5 +111,24 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README CHANGES CREDITS
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%doc README doc/README.avfs-fuse
+%attr(755,root,root) %{_libdir}/libavfs.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libavfs.so.0
+%attr(755,root,root) %{_bindir}/avfsd
+%attr(755,root,root) %{_bindir}/davpass
+%attr(755,root,root) %{_bindir}/ftppass
+%attr(755,root,root) %{_bindir}/mountavfs
+%attr(755,root,root) %{_bindir}/umountavfs
+%{_libdir}/%{name}
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/avfs-config
+%attr(755,root,root) %{_libdir}/libavfs.so
+%{_libdir}/libavfs.la
+%{_includedir}/*.h
+%{_pkgconfigdir}/avfs.pc
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libavfs.a
This page took 0.068807 seconds and 4 git commands to generate.