]> git.pld-linux.org Git - packages/autotrace.git/commitdiff
- up to 0.27a, renamed AutoTrace.spec to autotrace.spec, updated URLs
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 25 Oct 2001 21:47:46 +0000 (21:47 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- shared patch to make shared library, magick patch with Magick API update

Changed files:
    autotrace-magick.patch -> 1.1
    autotrace-shared.patch -> 1.1
    autotrace.spec -> 1.1

autotrace-magick.patch [new file with mode: 0644]
autotrace-shared.patch [new file with mode: 0644]
autotrace.spec [new file with mode: 0644]

diff --git a/autotrace-magick.patch b/autotrace-magick.patch
new file mode 100644 (file)
index 0000000..fcd161b
--- /dev/null
@@ -0,0 +1,11 @@
+--- autotrace-0.27a/input-magick.c.orig        Tue Mar 20 12:01:05 2001
++++ autotrace-0.27a/input-magick.c     Thu Oct 25 23:32:08 2001
+@@ -17,7 +17,7 @@
+   PixelPacket p;
+   PixelPacket *pixel=&p;
+   ExceptionInfo exception;
+-  MagickIncarnate("");
++  InitializeMagick("");
+   GetExceptionInfo(&exception);
+   image_info=CloneImageInfo((ImageInfo *) NULL);
+   (void) strcpy(image_info->filename,filename);
diff --git a/autotrace-shared.patch b/autotrace-shared.patch
new file mode 100644 (file)
index 0000000..8ff4942
--- /dev/null
@@ -0,0 +1,46 @@
+--- autotrace-0.27a/Makefile.am.orig   Sat Mar 24 19:56:35 2001
++++ autotrace-0.27a/Makefile.am        Thu Oct 25 22:24:51 2001
+@@ -6,7 +6,7 @@
+ AUTOMAKE_OPTIONS = foreign no-dependencies
+ autotraceincludedir=$(includedir)/autotrace
+-lib_LIBRARIES=libautotrace.a
++lib_LTLIBRARIES=libautotrace.la
+ bin_PROGRAMS=autotrace
+ if HAVE_MAGICK
+@@ -42,7 +42,7 @@
+ output-emf.c output-emf.h \
+ $(output_swf_src)
+-libautotrace_a_SOURCES = version.c               \
++libautotrace_la_SOURCES = version.c               \
+                 $(input_src) ${output_src}    \
+               fit.c                           \
+               bitmap.c                        \
+@@ -100,7 +100,13 @@
++libautotrace_la_LIBADD = \
++              $(MAGICK_LDFLAGS) \
++              $(LIBPNG_LDFLAGS) \
++              $(LIBSWF_LDFLAGS) \
++              -lm
++
+ INCLUDES = $(MAGICK_CFLAGS)
+ autotrace_LDADD =                 \
+-              libautotrace.a    \
++              libautotrace.la    \
+               $(MAGICK_LDFLAGS) \
+               $(LIBPNG_LDFLAGS) \
+               $(LIBSWF_LDFLAGS) \
+--- autotrace-0.27a/configure.in.orig  Sat Mar 24 19:57:10 2001
++++ autotrace-0.27a/configure.in       Thu Oct 25 22:31:17 2001
+@@ -8,7 +8,7 @@
+ AC_PROG_CC
+ AC_PROG_CPP
+-AC_PROG_RANLIB
++AM_PROG_LIBTOOL
+ dnl
+ dnl ImageMagick
diff --git a/autotrace.spec b/autotrace.spec
new file mode 100644 (file)
index 0000000..a370db6
--- /dev/null
@@ -0,0 +1,97 @@
+Summary:       AutoTrace - convert bitmap to vector graphics
+Summary(pl):   AutoTrace - konwersja grafiki rastrowej do wektorowej
+Name:          autotrace
+Version:       0.27a
+Release:       1
+License:       GPL
+Group:         Applications
+Source0:       ftp://ftp.sourceforge.net/pub/sourceforge/autotrace/%{name}-%{version}.tar.gz
+Patch0:                %{name}-shared.patch
+Patch1:                %{name}-magick.patch
+URL:           http://autotrace.sourceforge.net/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libpng-devel >= 1.0.6
+BuildRequires: ming-devel
+BuildRequires: ImageMagick-devel >= 5.2.1
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+AutoTrace is a utility that converts bitmap to vector graphics.
+It can import p[nbgp]m, bmp, tga, png (and many more through
+ImageMagick) files and write to emf, eps, ai, er, fig, svg, sk and swf
+files.
+
+%description -l pl
+AutoTrace jest narzêdziem do konwersji grafiki rastrowej na wektorow±.
+Mo¿e wczytywaæ pliki p[nbgp]m, bmp, tga, png (i wiele innych przez
+ImageMagick, a zapisywaæ w formacie emf, eps, ai, er, fig, svg, sk
+oraz swf.
+
+%package devel
+Summary:       AutoTrace library development files
+Summary(pl):   Pliki dla programistów u¿ywaj±cych biblioteki AutoTrace
+Group:         Development/Libraries
+Requires:      %{name} = %{version}
+
+%description devel
+AutoTrace library header files.
+
+%description devel -l pl
+Pliki nag³ówkowe do biblioteki AutoTrace.
+
+%package static
+Summary:       AutoTrace static library
+Summary(pl):   Biblioteka statyczna AutoTrace
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}
+
+%description static
+AutoTrace static library.
+
+%description static -l pl
+Biblioteka statyczna AutoTrace.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+libtoolize --copy --force
+aclocal
+autoconf
+automake -a -c
+%configure \
+       --enable-shared
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} install DESTDIR=$RPM_BUILD_ROOT
+
+gzip -9nf AUTHORS NEWS README THANKS
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc *.gz
+%attr(755,root,root) %{_bindir}/autotrace
+%attr(755,root,root) %{_libdir}/*.so.*.*
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/*.so
+%attr(755,root,root) %{_libdir}/*.la
+%attr(755,root,root) %{_bindir}/autotrace-config
+%{_includedir}/autotrace
+%{_aclocaldir}/autotrace.m4
+
+%files static
+%defattr(644,root,root,755)
This page took 0.114571 seconds and 4 git commands to generate.