]> git.pld-linux.org Git - packages/autorpm.git/blob - autorpm.spec
- changed all BuildRoot definitons
[packages/autorpm.git] / autorpm.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        RPM Auto-Installer or FTP Mirrorer
3 Summary(pl):    Auto instalator i ftp mirror pakietow rpm
4 Name:           autorpm
5 Version:        1.9.8.4
6 Release:        3
7 License:        GPL
8 Group:          Utilities/System
9 Group(pl):      Narzêdzia/System
10 Source0:        ftp://ftp.kaybee.org/pub/linux/%{name}-%{version}.tar.gz
11 URL:            http://www.kaybee.org/~kirk/html/linux.html
12 Requires:       /bin/rpm
13 Requires:       /usr/bin/whiptail
14 Requires:       /bin/mail
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 AutoRPM is a program that can do any combination of the following: mirror
19 RPMs from an FTP site, keep installed RPMs consistent with an FTP site or
20 local directory, and keep installed RPMs in a cluster or network of systems
21 consistent. It is highly flexible and even contains a very nice,
22 menu-driven Interactive-Install mode.
23
24 %description -l pl
25 AutoRPM jest programem, który mo¿e wykonywaæ dowoln± kombinacjê
26 nastêpuj±cych czynno¶ci: mirrorowanie pakietów rpm z podanego adresu serwea
27 ftp, aktualizowanie bazy zainstalowanych pakietów wzglêdem zawarto¶ci
28 serwera ftp lub katalogu lokalnego. Autorpm jest do¶æ ³atwo konfigurowalny
29 i posiada do¶æ du¿e mo¿liwo¶ci. Mo¿na go u¿ywaæ w trybie wsadowym i
30 interakcyjnym gdzie posiada do¶æ przyjemny interfejs.
31
32 %prep
33 %setup -q
34
35 %build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT{/etc/cron.daily,%{_mandir}/man{5,8},%{_sbindir}} \
40         $RPM_BUILD_ROOT{/var/spool/autorpm,%{_sysconfdir}/autorpm.d/pools}
41
42 install autorpm.pl      $RPM_BUILD_ROOT%{_sbindir}/autorpm
43 install autorpm.conf    $RPM_BUILD_ROOT%{_sysconfdir}/autorpm.d/autorpm.conf.sample
44 touch $RPM_BUILD_ROOT%{_sysconfdir}/autorpm.d/autorpm.conf
45 install autorpm.d/*     $RPM_BUILD_ROOT%{_sysconfdir}/autorpm.d/
46 install pools/*         $RPM_BUILD_ROOT%{_sysconfdir}/autorpm.d/pools/
47
48 install autorpm.conf.5  $RPM_BUILD_ROOT%{_mandir}/man5
49 install autorpm.8       $RPM_BUILD_ROOT%{_mandir}/man8
50
51 sed  -e "s=/bin/bash=/bin/sh=" autorpm.cron > $RPM_BUILD_ROOT/etc/cron.daily/autorpm
52
53 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
54         README CHANGES CREDITS TODO
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc {README,CHANGES,CREDITS,TODO}.gz
62 %{_mandir}/man[58]/*
63 %defattr(640,root,root,750)
64 %dir /var/spool/autorpm
65 %dir %{_sysconfdir}/autorpm.d
66 %dir %{_sysconfdir}/autorpm.d/pools
67 %config(missingok) %verify(not mtime,md5,size) %{_sysconfdir}/autorpm.d/autorpm.conf.sample
68 %ghost %{_sysconfdir}/autorpm.d/autorpm.conf
69 %config(missingok) %verify(not mtime,md5,size) %{_sysconfdir}/autorpm.d/*updates*
70 %config(missingok) %verify(not mtime,md5,size) %{_sysconfdir}/autorpm.d/pools/*updates*
71
72 %attr(750,root,root) %{_sbindir}/autorpm
73 %attr(750,root,root) /etc/cron.daily/autorpm
This page took 0.037742 seconds and 4 git commands to generate.