]> git.pld-linux.org Git - packages/autoq3d.git/blob - autoq3d.spec
- added QTDIR.
[packages/autoq3d.git] / autoq3d.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        autoq3d
7 Summary(pl):    autoq3d
8 Name:           AutoQ3D
9 Version:        1.20
10 Release:        0.1
11 License:        GPL
12 Group:          Applications
13 Source0:        http://dl.sourceforge.net/autoq3d/%{name}-v%{version}sourceLinux.zip
14 # Source0-md5:  cccd22e1c068651c8ad7c0831acd2aba
15 #Source1:       -
16 # Source1-md5:  -
17 #Patch0:                %{name}-DESTDIR.patch
18 URL:            http://autoq3d.ecuadra.com/
19 BuildRequires:  QtGui-devel
20 BuildRequires:  Mesa-libGL-devel
21 BuildRequires:  QtOpenGL-devel
22 BuildRequires:  qt4-build
23 #BuildRequires: libtool
24 #Requires(postun):      -
25 #Requires(pre,post):    -
26 #Requires(preun):       -
27 #Requires:      -
28 #Provides:      -
29 #Provides:      group(foo)
30 #Provides:      user(foo)
31 #Obsoletes:     -
32 #Conflicts:     -
33 #BuildArch:     noarch
34 #ExclusiveArch: %{ix86}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38
39 %description -l pl
40
41 %package subpackage
42 Summary:        -
43 Summary(pl):    -
44 Group:          -
45
46 %description subpackage
47
48 %description subpackage -l pl
49
50 %package libs
51 Summary:        -
52 Summary(pl):    -
53 Group:          Libraries
54
55 %description libs
56
57 %description libs -l pl
58
59
60 %package devel
61 Summary:        Header files for ... library
62 Summary(pl):    Pliki nag³ówkowe biblioteki ...
63 Group:          Development/Libraries
64 #Requires:      %{name} = %{version}-%{release}
65
66 %description devel
67 This is the package containing the header files for ... library.
68
69 %description devel -l pl
70 Ten pakiet zawiera pliki nag³ówkowe biblioteki ....
71
72 %package static
73 Summary:        Static ... library
74 Summary(pl):    Statyczna biblioteka ...
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static ... library.
80
81 %description static -l pl
82 Statyczna biblioteka ....
83
84 %prep
85 %setup -q -n %{name}
86
87 %build
88 QTDIR=/usr; export QTDIR
89 /usr/bin/qmake -o Makefile AutoQ3D.pro
90
91 %{__make} \
92         CFLAGS="%{rpmcflags}" \
93         LDFLAGS="%{rpmldflags}"
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 # create directories if necessary
98 #install -d $RPM_BUILD_ROOT
99 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %pre
108
109 %post
110
111 %preun
112
113 %postun
114
115 %if %{with ldconfig}
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118 %endif
119
120 %if %{with initscript}
121 %post init
122 /sbin/chkconfig --add %{name}
123 %service %{name} restart
124
125 %preun init
126 if [ "$1" = "0" ]; then
127         %service -q %{name} stop
128         /sbin/chkconfig --del %{name}
129 fi
130 %endif
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
135
136 %if 0
137 # if _sysconfdir != /etc:
138 #%%dir %{_sysconfdir}
139 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
140 %attr(755,root,root) %{_bindir}/*
141 %{_datadir}/%{name}
142 %endif
143
144 # initscript and its config
145 %if %{with initscript}
146 %attr(754,root,root) /etc/rc.d/init.d/%{name}
147 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
148 %endif
149
150 #%{_examplesdir}/%{name}-%{version}
151
152 %if %{with subpackage}
153 %files subpackage
154 %defattr(644,root,root,755)
155 #%doc extras/*.gz
156 #%{_datadir}/%{name}-ext
157 %endif
This page took 0.107095 seconds and 3 git commands to generate.