]> git.pld-linux.org Git - packages/automake.git/blobdiff - automake.spec
- fix version detection for python 3.10, rel 3
[packages/automake.git] / automake.spec
index 51bff626a245d3ac62aad85f7370102575239266..e68c1fc38e8b03404dcaf3f1d1d56d7bd82b5f0d 100644 (file)
@@ -1,8 +1,7 @@
 #
 # Conditional build:
-%bcond_with            bootstrap       # without full regeneration
+%bcond_with    bootstrap       # without full regeneration
 
-%include       /usr/lib/rpm/macros.perl
 Summary:       GNU automake - Makefile configuration tools
 Summary(de.UTF-8):     GNU automake - Makefile-Konfigurationstools
 Summary(es.UTF-8):     GNU automake - herramientas de configuración de Makefile
@@ -14,28 +13,27 @@ Summary(ru.UTF-8):  GNU automake - инструменты для автомати
 Summary(tr.UTF-8):     Makefile yapılandırma araçları
 Summary(uk.UTF-8):     GNU automake - інструменти для автоматичної генерації Makefile'ів
 Name:          automake
-Version:       1.11.4
-Release:       1
+Version:       1.16.5
+Release:       3
 Epoch:         1
 License:       GPL v2+
 Group:         Development/Building
-Source0:       http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.xz
-# Source0-md5: d1dd41acf56a30d8da7bf20c5ac223db
+Source0:       https://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.xz
+# Source0-md5: 4017e96f89fca45ca946f1c5db6be714
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-man.patch
 Patch2:                %{name}-no_versioned_dir.patch
-Patch3:                %{name}-morearchs.patch
+Patch3:                revert-debian-python-hacks.patch
+Patch4:                python-3.10.patch
 URL:           http://sources.redhat.com/automake/
-%if %{with bootstrap}
-BuildRequires: autoconf >= 2.62
-%else
-BuildRequires: autoconf >= 2.68
-BuildRequires: automake >= 1:1.10a
+BuildRequires: autoconf >= 2.69
+%if %{without bootstrap}
+BuildRequires: automake >= 1:1.14
 %endif
 BuildRequires: help2man
 BuildRequires: rpm-perlprov
 BuildRequires: tar >= 1:1.22
-BuildRequires: texinfo >= 4.7
+BuildRequires: texinfo >= 4.9
 BuildRequires: xz
 Requires(pre): fileutils
 Requires:      filesystem >= 3.0-2
@@ -45,11 +43,13 @@ Requires:   perl(File::Glob)
 Requires:      perl(Thread::Queue)
 Requires:      perl(threads)
 %endif
-Conflicts:     autoconf < 2.60
+Conflicts:     autoconf < 2.65
 Conflicts:     libtool < 2:1.5-11
+Conflicts:     texinfo < 4.9
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                ver_maj         %(echo %{version} | cut -d. -f1-2)
 %define                _enable_debug_packages  0
 
 %description
@@ -107,8 +107,11 @@ Makefile'ів.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %if %{without bootstrap}
+%{__sed} -i -e '/AM_INIT_AUTOMAKE/ s/-Werror //' configure.ac
+
 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
 mkdir m4-tmp
 cd m4-tmp
@@ -124,11 +127,12 @@ ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
 %{__automake}
 %endif
 
-# NOTE: _target macro becames "noarch" if ./builder passes --target=noarch, so
-# be sure use plain /usr/bin/rpmbuild.
 %configure \
+%if "%{_host_cpu}" != "x32"
        --host=%{_host} \
-       --build=%{_host}
+       --build=%{_host} \
+%endif
+       --disable-silent-rules
 %{__make}
 
 %install
@@ -141,48 +145,49 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 cp -a aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
+# not needed when dir/files are handled by package system
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/aclocal/README
+
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p      /sbin/postshell
+%post  -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun        -p      /sbin/postshell
+%postun        -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README THANKS TODO
+%doc AUTHORS ChangeLog NEWS README THANKS
 %attr(755,root,root) %{_bindir}/aclocal*
 %attr(755,root,root) %{_bindir}/automake*
 %{_infodir}/automake.info*
+%{_infodir}/automake-history.info*
 %{_mandir}/man1/aclocal.1*
-%{_mandir}/man1/aclocal-1.11.1*
+%{_mandir}/man1/aclocal-%{ver_maj}.1*
 %{_mandir}/man1/automake.1*
-%{_mandir}/man1/automake-1.11.1*
+%{_mandir}/man1/automake-%{ver_maj}.1*
 
-%{_datadir}/aclocal-*
+%{_datadir}/aclocal-%{ver_maj}
 %dir %{_datadir}/automake
 %{_datadir}/automake/am
 %{_datadir}/automake/Automake
 %{_datadir}/automake/COPYING
 %{_datadir}/automake/INSTALL
 %{_datadir}/automake/texinfo.tex
-%{_datadir}/automake/ansi2knr*
 %attr(755,root,root) %{_datadir}/automake/ar-lib
-%attr(755,root,root) %{_datadir}/automake/acinstall
 %attr(755,root,root) %{_datadir}/automake/compile
 %attr(755,root,root) %{_datadir}/automake/config.guess
 %attr(755,root,root) %{_datadir}/automake/config.sub
-%attr(755,root,root) %{_datadir}/automake/config-ml.in
 %attr(755,root,root) %{_datadir}/automake/depcomp
-%attr(755,root,root) %{_datadir}/automake/elisp-comp
 %attr(755,root,root) %{_datadir}/automake/install-sh
 %attr(755,root,root) %{_datadir}/automake/mdate-sh
 %attr(755,root,root) %{_datadir}/automake/missing
 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
 %attr(755,root,root) %{_datadir}/automake/py-compile
-%attr(755,root,root) %{_datadir}/automake/symlink-tree
+%attr(755,root,root) %{_datadir}/automake/tap-driver.sh
+%attr(755,root,root) %{_datadir}/automake/test-driver
 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.14564 seconds and 4 git commands to generate.