]> git.pld-linux.org Git - packages/automake.git/blobdiff - automake.spec
- updated to 1.12.1
[packages/automake.git] / automake.spec
index 579fe2a8fa14b64db8225f2400924554ee51368c..a0567164a6326a35810b809a2733ecb1cd561873 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Conditional build:
-%bcond_without regeneration    # without full regeneration
-#
+%bcond_with    bootstrap       # without full regeneration
+
 %include       /usr/lib/rpm/macros.perl
 Summary:       GNU automake - Makefile configuration tools
 Summary(de.UTF-8):     GNU automake - Makefile-Konfigurationstools
@@ -14,34 +14,44 @@ Summary(ru.UTF-8):  GNU automake - инструменты для автомати
 Summary(tr.UTF-8):     Makefile yapılandırma araçları
 Summary(uk.UTF-8):     GNU automake - інструменти для автоматичної генерації Makefile'ів
 Name:          automake
-Version:       1.11
+Version:       1.12.1
 Release:       1
 Epoch:         1
 License:       GPL v2+
 Group:         Development/Building
-Source0:       http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.bz2
-# Source0-md5: 4db4efe027e26b33930a7e151de19d0f
+Source0:       http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.xz
+# Source0-md5: 036d79de6e443e02aec2be1df2b4f0ac
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-man.patch
 Patch2:                %{name}-no_versioned_dir.patch
 Patch3:                %{name}-morearchs.patch
 URL:           http://sources.redhat.com/automake/
-%if %{with regeneration}
-BuildRequires: autoconf >= 2.60
-BuildRequires: automake >= 1:1.10a
+%if %{with bootstrap}
+BuildRequires: autoconf >= 2.62
 %else
-BuildRequires: autoconf >= 2.63
+BuildRequires: autoconf >= 2.68
+BuildRequires: automake >= 1:1.10a
 %endif
+BuildRequires: help2man
 BuildRequires: rpm-perlprov
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.7
+BuildRequires: xz
 Requires(pre): fileutils
 Requires:      filesystem >= 3.0-2
 Requires:      perl(File::Glob)
+%if %(%{__perl} -le 'use threads; print 1' || echo 0)
+# required only if perl was built with threads
+Requires:      perl(Thread::Queue)
+Requires:      perl(threads)
+%endif
 Conflicts:     autoconf < 2.60
 Conflicts:     libtool < 2:1.5-11
-#BuildArch:    noarch -- autoconf doesn't allow
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _enable_debug_packages  0
+
 %description
 Automake is an experimental Makefile generator. Automake was inspired
 by the 4.4BSD make and include files, but aims to be portable and to
@@ -98,7 +108,7 @@ Makefile'ів.
 %patch2 -p1
 %patch3 -p1
 
-%if %{with regeneration}
+%if %{without bootstrap}
 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
 mkdir m4-tmp
 cd m4-tmp
@@ -106,14 +116,19 @@ ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
 %endif
 
 %build
-%if %{with regeneration}
+%if %{without bootstrap}
 %{__aclocal} -I m4-tmp
 %endif
 %{__autoconf}
-%if %{with regeneration}
+%if %{without bootstrap}
 %{__automake}
 %endif
-%configure
+
+# NOTE: _target macro becames "noarch" if ./builder passes --target=noarch, so
+# be sure use plain /usr/bin/rpmbuild.
+%configure \
+       --host=%{_host} \
+       --build=%{_host}
 %{__make}
 
 %install
@@ -124,29 +139,33 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
        DESTDIR=$RPM_BUILD_ROOT \
        pkgvdatadir=%{_datadir}/automake
 
-install aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
+cp -a aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
+
+# not needed when dir/files are handled by package system
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/aclocal/README
 
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p      /sbin/postshell
+%post  -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun        -p      /sbin/postshell
+%postun        -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README THANKS TODO
+%doc AUTHORS ChangeLog NEWS README THANKS
 %attr(755,root,root) %{_bindir}/aclocal*
 %attr(755,root,root) %{_bindir}/automake*
 %{_infodir}/automake.info*
+%{_infodir}/automake-history.info*
 %{_mandir}/man1/aclocal.1*
-%{_mandir}/man1/aclocal-1.11.1*
+%{_mandir}/man1/aclocal-1.12.1*
 %{_mandir}/man1/automake.1*
-%{_mandir}/man1/automake-1.11.1*
+%{_mandir}/man1/automake-1.12.1*
 
 %{_datadir}/aclocal-*
 %dir %{_datadir}/automake
@@ -155,12 +174,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/automake/COPYING
 %{_datadir}/automake/INSTALL
 %{_datadir}/automake/texinfo.tex
-%{_datadir}/automake/ansi2knr*
-%attr(755,root,root) %{_datadir}/automake/acinstall
+%attr(755,root,root) %{_datadir}/automake/ar-lib
 %attr(755,root,root) %{_datadir}/automake/compile
 %attr(755,root,root) %{_datadir}/automake/config.guess
 %attr(755,root,root) %{_datadir}/automake/config.sub
-%attr(755,root,root) %{_datadir}/automake/config-ml.in
 %attr(755,root,root) %{_datadir}/automake/depcomp
 %attr(755,root,root) %{_datadir}/automake/elisp-comp
 %attr(755,root,root) %{_datadir}/automake/install-sh
@@ -168,5 +185,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_datadir}/automake/missing
 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
 %attr(755,root,root) %{_datadir}/automake/py-compile
-%attr(755,root,root) %{_datadir}/automake/symlink-tree
+%attr(755,root,root) %{_datadir}/automake/tap-driver.pl
+%attr(755,root,root) %{_datadir}/automake/tap-driver.sh
+%attr(755,root,root) %{_datadir}/automake/test-driver
 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.052474 seconds and 4 git commands to generate.