]> git.pld-linux.org Git - packages/automake.git/blame_incremental - automake.spec
- threads are required only if perl was built with threads
[packages/automake.git] / automake.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without regeneration # without full regeneration
4#
5%include /usr/lib/rpm/macros.perl
6Summary: GNU automake - Makefile configuration tools
7Summary(de.UTF-8): GNU automake - Makefile-Konfigurationstools
8Summary(es.UTF-8): GNU automake - herramientas de configuración de Makefile
9Summary(fr.UTF-8): automake de GNU - Outils de configuration des makefiles
10Summary(ko.UTF-8): 스스로 Makefile을 만들어주는 GNU 도구
11Summary(pl.UTF-8): GNU Automake - generator plików Makefile
12Summary(pt_BR.UTF-8): GNU automake - ferramentas de configuração de Makefile
13Summary(ru.UTF-8): GNU automake - инструменты для автоматической генерации Makefile'ов
14Summary(tr.UTF-8): Makefile yapılandırma araçları
15Summary(uk.UTF-8): GNU automake - інструменти для автоматичної генерації Makefile'ів
16Name: automake
17Version: 1.11
18Release: 2
19Epoch: 1
20License: GPL v2+
21Group: Development/Building
22Source0: http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.bz2
23# Source0-md5: 4db4efe027e26b33930a7e151de19d0f
24Patch0: %{name}-info.patch
25Patch1: %{name}-man.patch
26Patch2: %{name}-no_versioned_dir.patch
27Patch3: %{name}-morearchs.patch
28URL: http://sources.redhat.com/automake/
29%if %{with regeneration}
30BuildRequires: autoconf >= 2.60
31BuildRequires: automake >= 1:1.10a
32%else
33BuildRequires: autoconf >= 2.63
34%endif
35BuildRequires: rpm-perlprov
36BuildRequires: texinfo >= 4.7
37Requires(pre): fileutils
38Requires: filesystem >= 3.0-2
39Requires: perl(File::Glob)
40%if %(%{__perl} -le 'use threads; print 1' || echo 0)
41# required only if perl was built with threads
42Requires: perl(Thread::Queue)
43Requires: perl(threads)
44%endif
45Conflicts: autoconf < 2.60
46Conflicts: libtool < 2:1.5-11
47#BuildArch: noarch -- autoconf doesn't allow
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51Automake is an experimental Makefile generator. Automake was inspired
52by the 4.4BSD make and include files, but aims to be portable and to
53conform to the GNU standards for Makefile variables and targets.
54
55%description -l de.UTF-8
56Automake ist ein experimenteller Makefile-Generator, inspiriert durch
57die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
58Konformität mit den GNU-Standards für Makefile-Variable und Targets
59abzielt.
60
61%description -l es.UTF-8
62Automake es un creador experimental de Makefiles. Fue inspirado en el
634.4BSD make y incluye archivos, pero visa ser portátil y compatible
64con los padrones GNU para variables y dianas de Makefile.
65
66%description -l fr.UTF-8
67automake est un générateur expérimental de makefiles. Il a été inspiré
68par le make de BSD 4.4, mais se veut portable et conforme aux
69standards GNU pour les variables et les cibles des makefiles.
70
71%description -l pl.UTF-8
72Automake jest eksperymentalnym generatorem plików Makefile'a.
73Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
744.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
75platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
76
77%description -l pt_BR.UTF-8
78Automake é um gerador experimental de Makefiles. Ele foi inspirado
79pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
80com os padrões GNU para variáveis e alvos de Makefile.
81
82%description -l ru.UTF-8
83Automake - это экспериментальный генератор Makefile'ов. Идея была
84навеяна программой make и хедерами из 4.4BSD, но automake претендует
85на то, чтобы быть портабельной и соответствовать стандартам GNU на
86переменные и цели Makefile'ов.
87
88%description -l tr.UTF-8
89Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
90dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
91değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
92
93%description -l uk.UTF-8
94Automake - це експериментальний генератор Makefile'ів. Ідея була
95навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
96мобільність та відповідність стандартам GNU на змінні ті цілі
97Makefile'ів.
98
99%prep
100%setup -q
101%patch0 -p1
102%patch1 -p1
103%patch2 -p1
104%patch3 -p1
105
106%if %{with regeneration}
107# prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
108mkdir m4-tmp
109cd m4-tmp
110ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
111%endif
112
113%build
114%if %{with regeneration}
115%{__aclocal} -I m4-tmp
116%endif
117%{__autoconf}
118%if %{with regeneration}
119%{__automake}
120%endif
121%configure
122%{__make}
123
124%install
125rm -rf $RPM_BUILD_ROOT
126install -d $RPM_BUILD_ROOT%{_mandir}/man1
127
128%{__make} install \
129 DESTDIR=$RPM_BUILD_ROOT \
130 pkgvdatadir=%{_datadir}/automake
131
132install aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
133
134rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post -p /sbin/postshell
140-/usr/sbin/fix-info-dir -c %{_infodir}
141
142%postun -p /sbin/postshell
143-/usr/sbin/fix-info-dir -c %{_infodir}
144
145%files
146%defattr(644,root,root,755)
147%doc AUTHORS ChangeLog NEWS README THANKS TODO
148%attr(755,root,root) %{_bindir}/aclocal*
149%attr(755,root,root) %{_bindir}/automake*
150%{_infodir}/automake.info*
151%{_mandir}/man1/aclocal.1*
152%{_mandir}/man1/aclocal-1.11.1*
153%{_mandir}/man1/automake.1*
154%{_mandir}/man1/automake-1.11.1*
155
156%{_datadir}/aclocal-*
157%dir %{_datadir}/automake
158%{_datadir}/automake/am
159%{_datadir}/automake/Automake
160%{_datadir}/automake/COPYING
161%{_datadir}/automake/INSTALL
162%{_datadir}/automake/texinfo.tex
163%{_datadir}/automake/ansi2knr*
164%attr(755,root,root) %{_datadir}/automake/acinstall
165%attr(755,root,root) %{_datadir}/automake/compile
166%attr(755,root,root) %{_datadir}/automake/config.guess
167%attr(755,root,root) %{_datadir}/automake/config.sub
168%attr(755,root,root) %{_datadir}/automake/config-ml.in
169%attr(755,root,root) %{_datadir}/automake/depcomp
170%attr(755,root,root) %{_datadir}/automake/elisp-comp
171%attr(755,root,root) %{_datadir}/automake/install-sh
172%attr(755,root,root) %{_datadir}/automake/mdate-sh
173%attr(755,root,root) %{_datadir}/automake/missing
174%attr(755,root,root) %{_datadir}/automake/mkinstalldirs
175%attr(755,root,root) %{_datadir}/automake/py-compile
176%attr(755,root,root) %{_datadir}/automake/symlink-tree
177%attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.088816 seconds and 4 git commands to generate.