]> git.pld-linux.org Git - packages/automake.git/blame_incremental - automake.spec
- updated to 1.16
[packages/automake.git] / automake.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with bootstrap # without full regeneration
4
5%include /usr/lib/rpm/macros.perl
6Summary: GNU automake - Makefile configuration tools
7Summary(de.UTF-8): GNU automake - Makefile-Konfigurationstools
8Summary(es.UTF-8): GNU automake - herramientas de configuración de Makefile
9Summary(fr.UTF-8): automake de GNU - Outils de configuration des makefiles
10Summary(ko.UTF-8): 스스로 Makefile을 만들어주는 GNU 도구
11Summary(pl.UTF-8): GNU Automake - generator plików Makefile
12Summary(pt_BR.UTF-8): GNU automake - ferramentas de configuração de Makefile
13Summary(ru.UTF-8): GNU automake - инструменты для автоматической генерации Makefile'ов
14Summary(tr.UTF-8): Makefile yapılandırma araçları
15Summary(uk.UTF-8): GNU automake - інструменти для автоматичної генерації Makefile'ів
16Name: automake
17Version: 1.16
18Release: 1
19Epoch: 1
20License: GPL v2+
21Group: Development/Building
22Source0: http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.xz
23# Source0-md5: bfdf69ac36c327b3a59b83ab01057e30
24Patch0: %{name}-info.patch
25Patch1: %{name}-man.patch
26Patch2: %{name}-no_versioned_dir.patch
27Patch3: %{name}-morearchs.patch
28Patch4: revert-debian-python-hacks.patch
29URL: http://sources.redhat.com/automake/
30BuildRequires: autoconf >= 2.69
31%if %{without bootstrap}
32BuildRequires: automake >= 1:1.14
33%endif
34BuildRequires: help2man
35BuildRequires: rpm-perlprov
36BuildRequires: tar >= 1:1.22
37BuildRequires: texinfo >= 4.9
38BuildRequires: xz
39Requires(pre): fileutils
40Requires: filesystem >= 3.0-2
41Requires: perl(File::Glob)
42%if %(%{__perl} -le 'use threads; print 1' || echo 0)
43# required only if perl was built with threads
44Requires: perl(Thread::Queue)
45Requires: perl(threads)
46%endif
47Conflicts: autoconf < 2.65
48Conflicts: libtool < 2:1.5-11
49Conflicts: texinfo < 4.9
50BuildArch: noarch
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%define ver_maj %(echo %{version} | cut -d. -f1-2)
54%define _enable_debug_packages 0
55
56%description
57Automake is an experimental Makefile generator. Automake was inspired
58by the 4.4BSD make and include files, but aims to be portable and to
59conform to the GNU standards for Makefile variables and targets.
60
61%description -l de.UTF-8
62Automake ist ein experimenteller Makefile-Generator, inspiriert durch
63die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
64Konformität mit den GNU-Standards für Makefile-Variable und Targets
65abzielt.
66
67%description -l es.UTF-8
68Automake es un creador experimental de Makefiles. Fue inspirado en el
694.4BSD make y incluye archivos, pero visa ser portátil y compatible
70con los padrones GNU para variables y dianas de Makefile.
71
72%description -l fr.UTF-8
73automake est un générateur expérimental de makefiles. Il a été inspiré
74par le make de BSD 4.4, mais se veut portable et conforme aux
75standards GNU pour les variables et les cibles des makefiles.
76
77%description -l pl.UTF-8
78Automake jest eksperymentalnym generatorem plików Makefile'a.
79Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
804.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
81platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
82
83%description -l pt_BR.UTF-8
84Automake é um gerador experimental de Makefiles. Ele foi inspirado
85pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
86com os padrões GNU para variáveis e alvos de Makefile.
87
88%description -l ru.UTF-8
89Automake - это экспериментальный генератор Makefile'ов. Идея была
90навеяна программой make и хедерами из 4.4BSD, но automake претендует
91на то, чтобы быть портабельной и соответствовать стандартам GNU на
92переменные и цели Makefile'ов.
93
94%description -l tr.UTF-8
95Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
96dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
97değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
98
99%description -l uk.UTF-8
100Automake - це експериментальний генератор Makefile'ів. Ідея була
101навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
102мобільність та відповідність стандартам GNU на змінні ті цілі
103Makefile'ів.
104
105%prep
106%setup -q
107%patch0 -p1
108%patch1 -p1
109%patch2 -p1
110%patch3 -p1
111%patch4 -p1
112
113%if %{without bootstrap}
114# prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
115mkdir m4-tmp
116cd m4-tmp
117ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
118%endif
119
120%build
121%if %{without bootstrap}
122%{__aclocal} -I m4-tmp
123%endif
124%{__autoconf}
125%if %{without bootstrap}
126%{__automake}
127%endif
128
129%configure \
130%if "%{_host_cpu}" != "x32"
131 --host=%{_host} \
132 --build=%{_host} \
133%endif
134 --disable-silent-rules
135%{__make}
136
137%install
138rm -rf $RPM_BUILD_ROOT
139install -d $RPM_BUILD_ROOT%{_mandir}/man1
140
141%{__make} install \
142 DESTDIR=$RPM_BUILD_ROOT \
143 pkgvdatadir=%{_datadir}/automake
144
145cp -a aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
146
147# not needed when dir/files are handled by package system
148%{__rm} $RPM_BUILD_ROOT%{_datadir}/aclocal/README
149
150rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%post -p /sbin/postshell
156-/usr/sbin/fix-info-dir -c %{_infodir}
157
158%postun -p /sbin/postshell
159-/usr/sbin/fix-info-dir -c %{_infodir}
160
161%files
162%defattr(644,root,root,755)
163%doc AUTHORS ChangeLog NEWS README THANKS
164%attr(755,root,root) %{_bindir}/aclocal*
165%attr(755,root,root) %{_bindir}/automake*
166%{_infodir}/automake.info*
167%{_infodir}/automake-history.info*
168%{_mandir}/man1/aclocal.1*
169%{_mandir}/man1/aclocal-%{ver_maj}.1*
170%{_mandir}/man1/automake.1*
171%{_mandir}/man1/automake-%{ver_maj}.1*
172
173%{_datadir}/aclocal-%{ver_maj}
174%dir %{_datadir}/automake
175%{_datadir}/automake/am
176%{_datadir}/automake/Automake
177%{_datadir}/automake/COPYING
178%{_datadir}/automake/INSTALL
179%{_datadir}/automake/texinfo.tex
180%attr(755,root,root) %{_datadir}/automake/ar-lib
181%attr(755,root,root) %{_datadir}/automake/compile
182%attr(755,root,root) %{_datadir}/automake/config.guess
183%attr(755,root,root) %{_datadir}/automake/config.sub
184%attr(755,root,root) %{_datadir}/automake/depcomp
185%attr(755,root,root) %{_datadir}/automake/install-sh
186%attr(755,root,root) %{_datadir}/automake/mdate-sh
187%attr(755,root,root) %{_datadir}/automake/missing
188%attr(755,root,root) %{_datadir}/automake/mkinstalldirs
189%attr(755,root,root) %{_datadir}/automake/py-compile
190%attr(755,root,root) %{_datadir}/automake/tap-driver.sh
191%attr(755,root,root) %{_datadir}/automake/test-driver
192%attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.060627 seconds and 4 git commands to generate.