]> git.pld-linux.org Git - packages/aumix-gtk.git/commitdiff
- fixed for 2.8 auto/ac/aumix-2_8-1 auto/ac/aumix-2_8-2 auto/ac/aumix-2_8-3 auto/ac/aumix-2_8-4 auto/th/aumix-2_8-4 auto/ti/aumix-2_8-4
authorhavner <havner@pld-linux.org>
Mon, 26 Jul 2004 21:23:37 +0000 (21:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    aumix-home_etc.patch -> 1.9

aumix-home_etc.patch

index cb8386a6d38b041efb263998882b3f7c2b49e542..99e45a29f41be298e360836394cbaa49a011bdd6 100644 (file)
@@ -115,12 +115,12 @@ diff -Nru aumix-2.6.1/po/gl.po aumix-2.6.1.new/po/gl.po
  "  h:  this helpful message\n"
  msgstr ""
  "  d:  axustar outro dispositivo que non sexa /dev/mixer\n"
- "  f:  especificar ficheiro para gardar e cargar parámetros (por omisión é\n"
+ "  f:  especificar ficheiro para gardar e cargar opcións (por omisión é\n"
 -"      ~/.aumixrc ou /etc/aumixrc)\n"
 +"      $CONFIG_DIR/aumixrc ou /etc/aumixrc)\n"
  "  h:  amosar esta mensaxe de axuda\n"
  
- #: src/common.c:689
+ #: src/common.c:707
 diff -Nru aumix-2.6.1/po/pl.po aumix-2.6.1.new/po/pl.po
 --- aumix-2.6.1/po/pl.po       Tue Jun 27 23:11:47 2000
 +++ aumix-2.6.1.new/po/pl.po   Tue Jun 27 23:16:16 2000
@@ -150,13 +150,13 @@ diff -Nru aumix-2.6.1/po/pt_BR.po aumix-2.6.1.new/po/pt_BR.po
 +"      $CONFIG_DIR/aumixrc or /etc/aumixrc)\n"
  "  h:  this helpful message\n"
  msgstr ""
- "  d:  usar outro dispositivo que não o /dev/mixer\n"
- "  f:  SPECIFY FILE FOR SAVING AND LOADING SETTINGS (DEFAULTS TO\n"
--"      ~/.aumixrc or /etc/aumixrc)\n"
+ "  d:  ajusta um dispositivo em /dev/mixer\n"
+ "  f:  especifica um arquivo para ler e gravar as configurações (o padrão é   "
+-"    ~/.aumixrc or /etc/aumixrc)\n"
 +"      $CONFIG_DIR/aumixrc or /etc/aumixrc)\n"
- "  h:  esta mensagem de ajuda\n"
+ "  h:  essa mensagem de ajuda\n"
  
- #: src/common.c:689
+ #: src/common.c:707
 diff -Nru aumix-2.6.1/po/ru.po aumix-2.6.1.new/po/ru.po
 --- aumix-2.6.1/po/ru.po       Tue Jun 27 23:11:47 2000
 +++ aumix-2.6.1.new/po/ru.po   Tue Jun 27 23:16:07 2000
@@ -187,12 +187,12 @@ diff -Nru aumix-2.6.1/po/uk.po aumix-2.6.1.new/po/uk.po
  "  h:  this helpful message\n"
  msgstr ""
  "  d:  ÒÅÇÕÌÀ×ÁÔÉ ÐÒÉÓÔÒϧ ÏËҦ͠/dev/mixer\n"
- "  f:  ×ËÁÚÁÎÎÑ ¦ÍÅΦ ÆÁÊÌÕ ÄÌÑ ÚÂÅÒ¦ÇÁÎÎÑ Ò¦×Φנ(ÚÁ ÚÁÍÏ×ÞÁÎÎÑÍ\n"
+ "  f:  ×ËÁÚÁÔÉ ¦Í'Ñ ÆÁÊÌÕ ÄÌÑ ÚÂÅÒÅÖÅÎÎÑ Ò¦×Φנ(ÚÁ ÚÁÍÏ×ÞÁÎÎÑÍ\n"
 -"      ~/.aumixrc ÞÉ /etc/aumixrc)\n"
 +"      $CONFIG_DIR/aumixrc ÞÉ /etc/aumixrc)\n"
  "  h:  ÃÑ ÄÏÐÏÍÏÇÁ\n"
  
- #: src/common.c:689
+ #: src/common.c:707
 diff -Nru aumix-2.6.1/src/Makefile.am aumix-2.6.1.new/src/Makefile.am
 --- aumix-2.6.1/src/Makefile.am        Tue Jun 27 23:11:47 2000
 +++ aumix-2.6.1.new/src/Makefile.am    Wed Jun 28 00:12:13 2000
@@ -243,12 +243,12 @@ diff -Nru aumix-2.6.1/src/common.c aumix-2.6.1.new/src/common.c
 @@ -571,6 +573,8 @@
        FILE           *setfile;
        char           *home;
-       char            filename[FILENAME_MAX];
+       char            filename[PATH_MAX];
 +      struct cfv      etcfile;
 +
        if (save_filename == NULL) {
                home = getenv("HOME");
-               if ((strlen(home) + strlen(AUMIXRC)) < PATH_MAX) {
+               if ((strlen(home) + strlen(AUMIXRC) + 2) < PATH_MAX) {
 @@ -585,6 +589,19 @@
                }
                if (setfile == NULL) {
@@ -268,7 +268,7 @@ diff -Nru aumix-2.6.1/src/common.c aumix-2.6.1.new/src/common.c
 +                      setfile = fopen(filename, mode);
                }
        } else
-               setfile = fopen(save_filename, mode);
+               setfile = CheckAndOpen(save_filename, mode);
 diff -Nru aumix-2.6.1/src/userdir.c aumix-2.6.1.new/src/userdir.c
 --- aumix-2.6.1/src/userdir.c  Thu Jan  1 01:00:00 1970
 +++ aumix-2.6.1.new/src/userdir.c      Tue Jun 27 23:11:28 2000
This page took 0.039301 seconds and 4 git commands to generate.