]> git.pld-linux.org Git - packages/aufs.git/commitdiff
- new cvs snapshot - 2007.04.24
authorpascalek <pascalek@pld-linux.org>
Wed, 25 Apr 2007 10:53:07 +0000 (10:53 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- vserver patch and bcond
- prepared for smponly kernel
- builds now but CONFIG_AUFS_SYSAUFS should be y and need fixing

Changed files:
    aufs.spec -> 1.4

aufs.spec

index d9a02d37bf82819cfc2337da5ef5401f1c91eb0b..ea4f3f491d9018ecafba99bdf1c49ad5675742e9 100644 (file)
--- a/aufs.spec
+++ b/aufs.spec
@@ -2,29 +2,30 @@
 # Conditional build:
 %bcond_without dist_kernel     # allow non-distribution kernel
 %bcond_without kernel          # don't build kernel modules
-%bcond_without up              # don't build UP module
-%bcond_without smp             # don't build SMP module
 %bcond_without userspace       # don't build userspace programs
 %bcond_with    verbose         # verbose build (V=1)
+%bcond_without vserver         # kernel build --without vserver & grsecurity
 
 %if %{without kernel}
 %undefine      with_dist_kernel
 %endif
 
-%define                _rel    0.1
-Summary:       Aufs - Another Unionfs
+%define                _cvsdate        20070424
+%define                _rel            0.%{_cvsdate}.1
+Summary:       aufs - Another Unionfs
 Summary(pl.UTF-8):     aufs (Another Unionfs) - inny unionfs
 Name:          aufs
 Version:       0
 Release:       %{_rel}
 License:       GPL v2
 Group:         Base/Kernel
-Source0:       %{name}-20070220.tar.bz2
-# Source0-md5: 81bc264f83a3cdd579e0bffcbf5f0d74
+Source0:       http://www.pers.pl/%{name}-%{_cvsdate}.tar.bz2
+# Source0-md5: 526264eaac467144032e66a680fa03bf
+Patch0:                %{name}-vserver.patch
 URL:           http://aufs.sourceforge.net/
 %if %{with kernel}
 %{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.14}
-BuildRequires: rpmbuild(macros) >= 1.330
+BuildRequires: rpmbuild(macros) >= 1.379
 %endif
 BuildRequires: sed >= 4.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -54,8 +55,8 @@ Release:      %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 Requires(post,postun): /sbin/depmod
 %if %{with dist_kernel}
-%requires_releq_kernel_up
-Requires(postun):      %releq_kernel_up
+%requires_releq_kernel
+Requires(postun):      %releq_kernel
 %endif
 
 %description -n kernel%{_alt_kernel}-fs-aufs
@@ -68,36 +69,33 @@ Sterownik dla Linuksa do aufs.
 
 Ten pakiet zawiera moduł jądra Linuksa.
 
-%package -n kernel%{_alt_kernel}-smp-fs-aufs
-Summary:       Linux SMP driver for aufs
-Summary(pl.UTF-8):     Sterownik dla Linuksa SMP do aufs
-Release:       %{_rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-Requires(post,postun): /sbin/depmod
-%if %{with dist_kernel}
-%requires_releq_kernel_smp
-Requires(postun):      %releq_kernel_smp
-%endif
-
-%description -n kernel%{_alt_kernel}-smp-fs-aufs
-This is driver for aufs for Linux.
-
-This package contains Linux SMP module.
-
-%description -n kernel%{_alt_kernel}-smp-fs-aufs -l pl.UTF-8
-Sterownik dla Linuksa do aufs.
-
-Ten pakiet zawiera moduł jądra Linuksa SMP.
-
 %prep
 %setup -qn %{name}
-sed 's/$(CONFIG_AUFS)/m/; %{!?debug:s/$(CONFIG_AUFS_DEBUG.*)/n/}; s/$(CONFIG_AUFS_HINOTIFY)/n/' -i fs/aufs/Makefile
+%if %{with vserver}
+%patch0 -p1
+%endif
+
+sed '
+       s/$(CONFIG_AUFS)/m/; 
+       %{!?debug:s/$(CONFIG_AUFS_DEBUG.*)/n/}; 
+       s/$(CONFIG_AUFS_HINOTIFY)/n/;
+       s/$(CONFIG_AUFS_EXPORT)/y/;
+       s/$(CONFIG_AUFS_SYSAUFS)/n/
+' -i fs/aufs/Makefile
 cp -a include/linux fs/aufs
 
 %build
 %if %{with kernel}
 %build_kernel_modules -C fs/aufs -m aufs \
-       EXTRA_CFLAGS="-DCONFIG_AUFS_BRANCH_MAX_CHAR -DCONFIG_AUFS_FAKE_DM -DCONFIG_AUFS_MODULE -UCONFIG_AUFS_KSIZE_PATCH %{?debug:-DCONFIG_AUFS_DEBUG}"
+       EXTRA_CFLAGS=" \
+               -DCONFIG_AUFS_BRANCH_MAX_127 \
+               -DCONFIG_AUFS_BRANCH_MAX_CHAR \
+               -DCONFIG_AUFS_FAKE_DM \
+               -DCONFIG_AUFS_MODULE \
+               -UCONFIG_AUFS_KSIZE_PATCH \
+               %{?debug:-DCONFIG_AUFS_DEBUG} \
+               %{?with_vserver:-DVSERVER} \
+       "
 %endif
 
 %install
@@ -116,26 +114,12 @@ rm -rf $RPM_BUILD_ROOT
 %postun        -n kernel%{_alt_kernel}-fs-aufs
 %depmod %{_kernel_ver}
 
-%post  -n kernel%{_alt_kernel}-smp-fs-aufs
-%depmod %{_kernel_ver}smp
-
-%postun        -n kernel%{_alt_kernel}-smp-fs-aufs
-%depmod %{_kernel_ver}smp
-
 %if %{with kernel}
-%if %{with up} || %{without dist_kernel}
 %files -n kernel%{_alt_kernel}-fs-aufs
 %defattr(644,root,root,755)
 /lib/modules/%{_kernel_ver}/fs/*.ko*
 %endif
 
-%if %{with smp} && %{with dist_kernel}
-%files -n kernel%{_alt_kernel}-smp-fs-aufs
-%defattr(644,root,root,755)
-/lib/modules/%{_kernel_ver}smp/fs/*.ko*
-%endif
-%endif
-
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
This page took 0.107922 seconds and 4 git commands to generate.