]> git.pld-linux.org Git - packages/aufs.git/blobdiff - aufs.spec
- disable requirement security_inode_permission export in kernel (needs check)
[packages/aufs.git] / aufs.spec
index ea4f3f491d9018ecafba99bdf1c49ad5675742e9..e6ee133dff3dc3980730bbd05e972af1c752c241 100644 (file)
--- a/aufs.spec
+++ b/aufs.spec
@@ -4,27 +4,30 @@
 %bcond_without kernel          # don't build kernel modules
 %bcond_without userspace       # don't build userspace programs
 %bcond_with    verbose         # verbose build (V=1)
-%bcond_without vserver         # kernel build --without vserver & grsecurity
+%bcond_without vserver         # kernel build without vserver & grsecurity
 
 %if %{without kernel}
 %undefine      with_dist_kernel
 %endif
 
-%define                _cvsdate        20070424
-%define                _rel            0.%{_cvsdate}.1
+%define                subver          20080313
+%define                prel            0.%{subver}.%{rel}
+
+%define                rel             10
 Summary:       aufs - Another Unionfs
 Summary(pl.UTF-8):     aufs (Another Unionfs) - inny unionfs
 Name:          aufs
 Version:       0
-Release:       %{_rel}
+Release:       %{prel}
 License:       GPL v2
 Group:         Base/Kernel
-Source0:       http://www.pers.pl/%{name}-%{_cvsdate}.tar.bz2
-# Source0-md5: 526264eaac467144032e66a680fa03bf
+Source0:       %{name}-%{subver}.tar.bz2
+# Source0-md5: 044ba36a61ca6a0ebe72108aaa77b816
 Patch0:                %{name}-vserver.patch
+Patch1:                %{name}-disable-security_inode_permission.patch
 URL:           http://aufs.sourceforge.net/
 %if %{with kernel}
-%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.14}
+%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRequires: rpmbuild(macros) >= 1.379
 %endif
 BuildRequires: sed >= 4.0
@@ -51,7 +54,7 @@ aufs-a. Część terminologii wywodzi się z unionfs-a.
 %package -n kernel%{_alt_kernel}-fs-aufs
 Summary:       Linux driver for aufs
 Summary(pl.UTF-8):     Sterownik dla Linuksa do aufs
-Release:       %{_rel}@%{_kernel_ver_str}
+Release:       %{prel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 Requires(post,postun): /sbin/depmod
 %if %{with dist_kernel}
@@ -74,6 +77,7 @@ Ten pakiet zawiera moduł jądra Linuksa.
 %if %{with vserver}
 %patch0 -p1
 %endif
+%patch1 -p1
 
 sed '
        s/$(CONFIG_AUFS)/m/; 
@@ -93,16 +97,28 @@ cp -a include/linux fs/aufs
                -DCONFIG_AUFS_FAKE_DM \
                -DCONFIG_AUFS_MODULE \
                -UCONFIG_AUFS_KSIZE_PATCH \
+               -UCONFIG_AUFS_DLGT \
                %{?debug:-DCONFIG_AUFS_DEBUG} \
-               %{?with_vserver:-DVSERVER} \
-       "
+               %{?with_vserver:-DVSERVER}"
+%endif
+
+%if %{with userspace}
+%{__make} -C util \
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags} -DCONFIG_AUFS_BRANCH_MAX_127"
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with userspace}
+install -d $RPM_BUILD_ROOT{%{_mandir}/man5,%{_sbindir}}
+install util/{mount.aufs,umount.aufs,auplink,aulchown} $RPM_BUILD_ROOT%{_sbindir}
+install util/aufs.5 $RPM_BUILD_ROOT%{_mandir}/man5/
+%endif
+
 %if %{with kernel}
-%install_kernel_modules -m fs/aufs/aufs -d fs
+%install_kernel_modules -m fs/aufs/aufs -d kernel/fs/aufs
 %endif
 
 %clean
@@ -117,11 +133,14 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with kernel}
 %files -n kernel%{_alt_kernel}-fs-aufs
 %defattr(644,root,root,755)
-/lib/modules/%{_kernel_ver}/fs/*.ko*
+%dir /lib/modules/%{_kernel_ver}/kernel/fs/aufs
+/lib/modules/%{_kernel_ver}/kernel/fs/aufs/*.ko*
 %endif
 
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
 %doc README History
+%attr(755,root,root) %{_sbindir}/*
+%{_mandir}/man5/*
 %endif
This page took 0.13551 seconds and 4 git commands to generate.