]> git.pld-linux.org Git - packages/aufs.git/blobdiff - aufs.spec
- rel 11 (2.6.22.19-5)
[packages/aufs.git] / aufs.spec
index 1d0681a56f27459e94b3f94391da0d25bf1efdf7..6c43a4f4ff8ca7679512aa8e55b4d2db4d7fb923 100644 (file)
--- a/aufs.spec
+++ b/aufs.spec
@@ -4,27 +4,29 @@
 %bcond_without kernel          # don't build kernel modules
 %bcond_without userspace       # don't build userspace programs
 %bcond_with    verbose         # verbose build (V=1)
-%bcond_without vserver         # kernel build without vserver & grsecurity
 
 %if %{without kernel}
 %undefine      with_dist_kernel
 %endif
 
-%define                _cvsdate        20070424
-%define                _rel            0.%{_cvsdate}.1
+%define                subver          20080313
+%define                prel            0.%{subver}.%{rel}
+
+%define                rel             11
 Summary:       aufs - Another Unionfs
 Summary(pl.UTF-8):     aufs (Another Unionfs) - inny unionfs
 Name:          aufs
 Version:       0
-Release:       %{_rel}
+Release:       %{prel}
 License:       GPL v2
 Group:         Base/Kernel
-Source0:       http://www.pers.pl/%{name}-%{_cvsdate}.tar.bz2
-# Source0-md5: 526264eaac467144032e66a680fa03bf
+Source0:       %{name}-%{subver}.tar.bz2
+# Source0-md5: 044ba36a61ca6a0ebe72108aaa77b816
 Patch0:                %{name}-vserver.patch
+Patch1:                %{name}-disable-security_inode_permission.patch
 URL:           http://aufs.sourceforge.net/
 %if %{with kernel}
-%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.14}
+%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRequires: rpmbuild(macros) >= 1.379
 %endif
 BuildRequires: sed >= 4.0
@@ -51,7 +53,7 @@ aufs-a. Część terminologii wywodzi się z unionfs-a.
 %package -n kernel%{_alt_kernel}-fs-aufs
 Summary:       Linux driver for aufs
 Summary(pl.UTF-8):     Sterownik dla Linuksa do aufs
-Release:       %{_rel}@%{_kernel_ver_str}
+Release:       %{prel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 Requires(post,postun): /sbin/depmod
 %if %{with dist_kernel}
@@ -71,9 +73,8 @@ Ten pakiet zawiera moduł jądra Linuksa.
 
 %prep
 %setup -qn %{name}
-%if %{with vserver}
 %patch0 -p1
-%endif
+%patch1 -p1
 
 sed '
        s/$(CONFIG_AUFS)/m/; 
@@ -86,6 +87,9 @@ cp -a include/linux fs/aufs
 
 %build
 %if %{with kernel}
+if [ -f %{_kernelsrcdir}/include/linux/vs_base.h ]; then
+       isvserver="-DVSERVER"
+fi
 %build_kernel_modules -C fs/aufs -m aufs \
        EXTRA_CFLAGS=" \
                -DCONFIG_AUFS_BRANCH_MAX_127 \
@@ -93,14 +97,26 @@ cp -a include/linux fs/aufs
                -DCONFIG_AUFS_FAKE_DM \
                -DCONFIG_AUFS_MODULE \
                -UCONFIG_AUFS_KSIZE_PATCH \
+               -UCONFIG_AUFS_DLGT \
                %{?debug:-DCONFIG_AUFS_DEBUG} \
-               %{?with_vserver:-DVSERVER} \
-       "
+               $isvserver"
+%endif
+
+%if %{with userspace}
+%{__make} -C util \
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags} -DCONFIG_AUFS_BRANCH_MAX_127"
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with userspace}
+install -d $RPM_BUILD_ROOT{%{_mandir}/man5,%{_sbindir}}
+install util/{mount.aufs,umount.aufs,auplink,aulchown} $RPM_BUILD_ROOT%{_sbindir}
+install util/aufs.5 $RPM_BUILD_ROOT%{_mandir}/man5/
+%endif
+
 %if %{with kernel}
 %install_kernel_modules -m fs/aufs/aufs -d kernel/fs/aufs
 %endif
@@ -125,4 +141,6 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README History
+%attr(755,root,root) %{_sbindir}/*
+%{_mandir}/man5/*
 %endif
This page took 0.130351 seconds and 4 git commands to generate.