]> git.pld-linux.org Git - packages/aufs.git/blame - aufs.spec
- rel 11 (2.6.22.19-5)
[packages/aufs.git] / aufs.spec
CommitLineData
bf531407 1#
4734e1ff
ER
2# Conditional build:
3%bcond_without dist_kernel # allow non-distribution kernel
4%bcond_without kernel # don't build kernel modules
4734e1ff
ER
5%bcond_without userspace # don't build userspace programs
6%bcond_with verbose # verbose build (V=1)
7
8%if %{without kernel}
9%undefine with_dist_kernel
10%endif
11
3b805c44 12%define subver 20080313
46de4e94
ER
13%define prel 0.%{subver}.%{rel}
14
5fe7fd60 15%define rel 11
509b678e 16Summary: aufs - Another Unionfs
bf531407 17Summary(pl.UTF-8): aufs (Another Unionfs) - inny unionfs
4734e1ff
ER
18Name: aufs
19Version: 0
46de4e94 20Release: %{prel}
4734e1ff
ER
21License: GPL v2
22Group: Base/Kernel
46de4e94 23Source0: %{name}-%{subver}.tar.bz2
3b805c44 24# Source0-md5: 044ba36a61ca6a0ebe72108aaa77b816
509b678e 25Patch0: %{name}-vserver.patch
3b805c44 26Patch1: %{name}-disable-security_inode_permission.patch
4734e1ff
ER
27URL: http://aufs.sourceforge.net/
28%if %{with kernel}
a18698d8 29%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
509b678e 30BuildRequires: rpmbuild(macros) >= 1.379
4734e1ff 31%endif
518cfd38 32BuildRequires: sed >= 4.0
4734e1ff
ER
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36In the early days, aufs was entirely re-designed and re-implemented
37Unionfs. After many original ideas, approaches, improvements and
38implementations, it becomes totally different from Unionfs while
39keeping the basic features. Unionfs is being developed by Professor
40Erez Zadok at Stony Brook University and his team. If you don't know
41Unionfs, I recommend you to try and know it before using aufs. Some
42terminology in aufs follows Unionfs's.
43
bf531407
JB
44%description -l pl.UTF-8
45Początkowo aufs był całkowicie przeprojektowanym i od nowa
46zaimplementowanym unionfs-em. Po wielu oryginalnych pomysłach,
47podejściach, poprawkach i implementacjach stał sie całkowicie innym
48niż unionfs zachowując podstawowe możliwości. unionfs jest rozwijany
49przez profesora Ereza Zadoka w Stony Brook University i jego zespół.
50Nie znający unionfs-a powinni spróbować go i poznać przed używaniem
51aufs-a. Część terminologii wywodzi się z unionfs-a.
52
4734e1ff
ER
53%package -n kernel%{_alt_kernel}-fs-aufs
54Summary: Linux driver for aufs
55Summary(pl.UTF-8): Sterownik dla Linuksa do aufs
46de4e94 56Release: %{prel}@%{_kernel_ver_str}
4734e1ff
ER
57Group: Base/Kernel
58Requires(post,postun): /sbin/depmod
59%if %{with dist_kernel}
509b678e 60%requires_releq_kernel
61Requires(postun): %releq_kernel
4734e1ff
ER
62%endif
63
64%description -n kernel%{_alt_kernel}-fs-aufs
65This is driver for aufs for Linux.
66
67This package contains Linux module.
68
69%description -n kernel%{_alt_kernel}-fs-aufs -l pl.UTF-8
70Sterownik dla Linuksa do aufs.
71
72Ten pakiet zawiera moduł jądra Linuksa.
73
4734e1ff
ER
74%prep
75%setup -qn %{name}
509b678e 76%patch0 -p1
3b805c44 77%patch1 -p1
509b678e 78
79sed '
80 s/$(CONFIG_AUFS)/m/;
81 %{!?debug:s/$(CONFIG_AUFS_DEBUG.*)/n/};
82 s/$(CONFIG_AUFS_HINOTIFY)/n/;
83 s/$(CONFIG_AUFS_EXPORT)/y/;
84 s/$(CONFIG_AUFS_SYSAUFS)/n/
85' -i fs/aufs/Makefile
518cfd38 86cp -a include/linux fs/aufs
4734e1ff
ER
87
88%build
89%if %{with kernel}
dd9fb61b 90if [ -f %{_kernelsrcdir}/include/linux/vs_base.h ]; then
91 isvserver="-DVSERVER"
92fi
518cfd38 93%build_kernel_modules -C fs/aufs -m aufs \
509b678e 94 EXTRA_CFLAGS=" \
95 -DCONFIG_AUFS_BRANCH_MAX_127 \
96 -DCONFIG_AUFS_BRANCH_MAX_CHAR \
97 -DCONFIG_AUFS_FAKE_DM \
98 -DCONFIG_AUFS_MODULE \
99 -UCONFIG_AUFS_KSIZE_PATCH \
3b805c44 100 -UCONFIG_AUFS_DLGT \
509b678e 101 %{?debug:-DCONFIG_AUFS_DEBUG} \
dd9fb61b 102 $isvserver"
4734e1ff
ER
103%endif
104
7d59a9cf 105%if %{with userspace}
106%{__make} -C util \
107 CC="%{__cc}" \
108 CFLAGS="%{rpmcflags} -DCONFIG_AUFS_BRANCH_MAX_127"
109%endif
110
4734e1ff
ER
111%install
112rm -rf $RPM_BUILD_ROOT
113
7d59a9cf 114%if %{with userspace}
115install -d $RPM_BUILD_ROOT{%{_mandir}/man5,%{_sbindir}}
116install util/{mount.aufs,umount.aufs,auplink,aulchown} $RPM_BUILD_ROOT%{_sbindir}
117install util/aufs.5 $RPM_BUILD_ROOT%{_mandir}/man5/
118%endif
119
4734e1ff 120%if %{with kernel}
0f3a7497 121%install_kernel_modules -m fs/aufs/aufs -d kernel/fs/aufs
4734e1ff
ER
122%endif
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -n kernel%{_alt_kernel}-fs-aufs
128%depmod %{_kernel_ver}
129
130%postun -n kernel%{_alt_kernel}-fs-aufs
131%depmod %{_kernel_ver}
132
4734e1ff 133%if %{with kernel}
4734e1ff
ER
134%files -n kernel%{_alt_kernel}-fs-aufs
135%defattr(644,root,root,755)
0f3a7497 136%dir /lib/modules/%{_kernel_ver}/kernel/fs/aufs
137/lib/modules/%{_kernel_ver}/kernel/fs/aufs/*.ko*
4734e1ff
ER
138%endif
139
4734e1ff
ER
140%if %{with userspace}
141%files
142%defattr(644,root,root,755)
143%doc README History
7d59a9cf 144%attr(755,root,root) %{_sbindir}/*
145%{_mandir}/man5/*
4734e1ff 146%endif
This page took 0.465794 seconds and 4 git commands to generate.