]> git.pld-linux.org Git - packages/aufs.git/blame - aufs.spec
- builds
[packages/aufs.git] / aufs.spec
CommitLineData
4734e1ff
ER
1# Conditional build:
2%bcond_without dist_kernel # allow non-distribution kernel
3%bcond_without kernel # don't build kernel modules
4%bcond_without up # don't build UP module
5%bcond_without smp # don't build SMP module
6%bcond_without userspace # don't build userspace programs
7%bcond_with verbose # verbose build (V=1)
8
9%if %{without kernel}
10%undefine with_dist_kernel
11%endif
12
13%define _rel 0.1
14Summary: Aufs - Another Unionfs
15Name: aufs
16Version: 0
17Release: %{_rel}
18License: GPL v2
19Group: Base/Kernel
20Source0: %{name}-20070220.tar.bz2
21# Source0-md5: 81bc264f83a3cdd579e0bffcbf5f0d74
22URL: http://aufs.sourceforge.net/
23%if %{with kernel}
24%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.14}
25BuildRequires: rpmbuild(macros) >= 1.330
26%endif
518cfd38 27BuildRequires: sed >= 4.0
4734e1ff
ER
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31In the early days, aufs was entirely re-designed and re-implemented
32Unionfs. After many original ideas, approaches, improvements and
33implementations, it becomes totally different from Unionfs while
34keeping the basic features. Unionfs is being developed by Professor
35Erez Zadok at Stony Brook University and his team. If you don't know
36Unionfs, I recommend you to try and know it before using aufs. Some
37terminology in aufs follows Unionfs's.
38
39%package -n kernel%{_alt_kernel}-fs-aufs
40Summary: Linux driver for aufs
41Summary(pl.UTF-8): Sterownik dla Linuksa do aufs
42Release: %{_rel}@%{_kernel_ver_str}
43Group: Base/Kernel
44Requires(post,postun): /sbin/depmod
45%if %{with dist_kernel}
46%requires_releq_kernel_up
47Requires(postun): %releq_kernel_up
48%endif
49
50%description -n kernel%{_alt_kernel}-fs-aufs
51This is driver for aufs for Linux.
52
53This package contains Linux module.
54
55%description -n kernel%{_alt_kernel}-fs-aufs -l pl.UTF-8
56Sterownik dla Linuksa do aufs.
57
58Ten pakiet zawiera moduł jądra Linuksa.
59
60%package -n kernel%{_alt_kernel}-smp-fs-aufs
61Summary: Linux SMP driver for aufs
62Summary(pl.UTF-8): Sterownik dla Linuksa SMP do aufs
63Release: %{_rel}@%{_kernel_ver_str}
64Group: Base/Kernel
65Requires(post,postun): /sbin/depmod
66%if %{with dist_kernel}
67%requires_releq_kernel_smp
68Requires(postun): %releq_kernel_smp
69%endif
70
71%description -n kernel%{_alt_kernel}-smp-fs-aufs
72This is driver for aufs for Linux.
73
74This package contains Linux SMP module.
75
76%description -n kernel%{_alt_kernel}-smp-fs-aufs -l pl.UTF-8
77Sterownik dla Linuksa do aufs.
78
79Ten pakiet zawiera moduł jądra Linuksa SMP.
80
81%prep
82%setup -qn %{name}
518cfd38 83sed 's/$(CONFIG_AUFS)/m/; %{!?debug:s/$(CONFIG_AUFS_DEBUG.*)/n/}; s/$(CONFIG_AUFS_HINOTIFY)/n/' -i fs/aufs/Makefile
84cp -a include/linux fs/aufs
4734e1ff
ER
85
86%build
87%if %{with kernel}
518cfd38 88%build_kernel_modules -C fs/aufs -m aufs \
89 EXTRA_CFLAGS="-DCONFIG_AUFS_BRANCH_MAX_CHAR -DCONFIG_AUFS_FAKE_DM -DCONFIG_AUFS_MODULE -UCONFIG_AUFS_KSIZE_PATCH %{?debug:-DCONFIG_AUFS_DEBUG}"
4734e1ff
ER
90%endif
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95%if %{with kernel}
518cfd38 96%install_kernel_modules -m fs/aufs/aufs -d fs
4734e1ff
ER
97%endif
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post -n kernel%{_alt_kernel}-fs-aufs
103%depmod %{_kernel_ver}
104
105%postun -n kernel%{_alt_kernel}-fs-aufs
106%depmod %{_kernel_ver}
107
108%post -n kernel%{_alt_kernel}-smp-fs-aufs
109%depmod %{_kernel_ver}smp
110
111%postun -n kernel%{_alt_kernel}-smp-fs-aufs
112%depmod %{_kernel_ver}smp
113
114%if %{with kernel}
115%if %{with up} || %{without dist_kernel}
116%files -n kernel%{_alt_kernel}-fs-aufs
117%defattr(644,root,root,755)
118/lib/modules/%{_kernel_ver}/fs/*.ko*
119%endif
120
121%if %{with smp} && %{with dist_kernel}
122%files -n kernel%{_alt_kernel}-smp-fs-aufs
123%defattr(644,root,root,755)
124/lib/modules/%{_kernel_ver}smp/fs/*.ko*
125%endif
126%endif
127
128%if %{with userspace}
129%files
130%defattr(644,root,root,755)
131%doc README History
132%endif
This page took 0.066501 seconds and 4 git commands to generate.