]> git.pld-linux.org Git - packages/audit.git/commitdiff
- updated to 3.1.2; flexible array workaround already in code master auto/th/audit-3.1.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 28 Sep 2023 04:37:33 +0000 (06:37 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 28 Sep 2023 04:37:33 +0000 (06:37 +0200)
audit-flex-array-workaround.patch [deleted file]
audit-undo-flex-array.patch [deleted file]
audit.spec

diff --git a/audit-flex-array-workaround.patch b/audit-flex-array-workaround.patch
deleted file mode 100644 (file)
index 3f22d37..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -urp audit-3.0.8.orig/bindings/swig/src/auditswig.i audit-3.0.8/bindings/swig/src/auditswig.i
---- audit-3.0.8.orig/bindings/swig/src/auditswig.i     2022-03-29 16:52:34.000000000 -0400
-+++ audit-3.0.8/bindings/swig/src/auditswig.i  2022-03-29 17:31:15.810268855 -0400
-@@ -39,7 +39,7 @@ signed
- #define __attribute(X) /*nothing*/
- typedef unsigned __u32;
- typedef unsigned uid_t;
--%include "/usr/include/linux/audit.h"
-+%include "../lib/audit.h"
- #define __extension__ /*nothing*/
- %include <stdint.i>
- %include "../lib/libaudit.h"
-diff -urp audit-3.0.8.orig/lib/audit.h audit-3.0.8/lib/audit.h
---- audit-3.0.8.orig/lib/audit.h       2022-03-29 17:29:30.358211892 -0400
-+++ audit-3.0.8/lib/audit.h    2022-03-29 17:31:15.811268833 -0400
-@@ -514,7 +514,7 @@ struct audit_rule_data {
-       __u32           values[AUDIT_MAX_FIELDS];
-       __u32           fieldflags[AUDIT_MAX_FIELDS];
-       __u32           buflen; /* total length of string fields */
--      char            buf[];  /* string fields buffer */
-+      char            buf[0]; /* string fields buffer */
- };
- #endif /* _LINUX_AUDIT_H_ */
-diff -urp audit-3.0.8.orig/lib/libaudit.h audit-3.0.8/lib/libaudit.h
---- audit-3.0.8.orig/lib/libaudit.h    2022-03-29 16:52:34.000000000 -0400
-+++ audit-3.0.8/lib/libaudit.h 2022-03-29 17:31:15.812268812 -0400
-@@ -27,7 +27,7 @@
- #include <stdint.h>
- #include <sys/socket.h>
- #include <linux/netlink.h>
--#include <linux/audit.h>
-+#include "audit.h"
- #include <stdarg.h>
- #include <syslog.h>
- #ifndef __attr_access
-Only in audit-3.0.8/lib: libaudit.h.orig
diff --git a/audit-undo-flex-array.patch b/audit-undo-flex-array.patch
deleted file mode 100644 (file)
index b74bd33..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urp usr.orig/include/libaudit.h.orig usr/include/libaudit.h
---- usr.orig/include/libaudit.h.orig   2022-02-14 14:14:08.000000000 -0500
-+++ usr/include/libaudit.h     2022-02-23 13:35:52.638340789 -0500
-@@ -39,7 +39,7 @@ extern "C" {
- #include <stdint.h>
- #include <sys/socket.h>
- #include <linux/netlink.h>
--#include "audit.h"
-+#include <linux/audit.h>
- #include <stdarg.h>
- #include <syslog.h>
index ddd373043fa698b7acbf2675d8bcc9401fc6e179..14b62586380c32b7beb3c9a20a239f9e58547665 100644 (file)
 %undefine      with_python3
 %endif
 
-%if %{_ver_ge %(rpm -q --qf='%%{E}:%%{V}' linux-libc-headers) 7:5.17}
-%define                with_flex_array_fix     1
-%endif
 Summary:       User space tools for 2.6 kernel auditing
 Summary(pl.UTF-8):     Narzędzia przestrzeni użytkownika do audytu jąder 2.6
 Name:          audit
-Version:       3.1.1
-Release:       2
+Version:       3.1.2
+Release:       1
 License:       GPL v2+
 Group:         Daemons
 Source0:       https://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
-# Source0-md5: 75363550690ee057f2fcf4f13eddcb4d
+# Source0-md5: 9d325b543f79b20a8f7ff2021ebac0c3
 Source2:       %{name}d.init
 Source3:       %{name}d.sysconfig
 Patch0:                %{name}-install.patch
@@ -36,8 +33,6 @@ Patch1:               %{name}-nolibs.patch
 Patch2:                %{name}-systemd-notonly.patch
 Patch3:                %{name}-no-refusemanualstop.patch
 Patch4:                golang-paths.patch
-Patch5:                %{name}-flex-array-workaround.patch
-Patch6:                %{name}-undo-flex-array.patch
 URL:           http://people.redhat.com/sgrubb/audit/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1:1.12.6
@@ -187,12 +182,6 @@ Interfejs Pythona 3.x do biblioteki libaudit.
 %patch3 -p1
 %patch4 -p1
 
-%if %{with flex_array_fix}
-# workaround flexible array member (char buf[]) incompatible with swig<=4.1.1
-cp /usr/include/linux/audit.h lib
-%patch5 -p1
-%endif
-
 %if %{without python}
 sed 's#[^ ]*swig/[^ ]*/Makefile ##g' -i configure.ac
 sed 's/swig//' -i bindings/Makefile.am
@@ -225,13 +214,6 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/audit/rules.d,%{_var}/log/audit}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%if %{with flex_array_fix}
-# undo include change
-cd $RPM_BUILD_ROOT
-patch -p0 --no-backup-if-mismatch < %{PATCH6}
-cd -
-%endif
-
 # default to no audit (and no overhead)
 cp -p rules/10-no-audit.rules $RPM_BUILD_ROOT%{_sysconfdir}/audit/rules.d
 
This page took 0.20793 seconds and 4 git commands to generate.