]> git.pld-linux.org Git - packages/audit.git/commitdiff
- up to 2.0 auto/aidath/audit-2_0-1 auto/th/audit-2_0-1 auto/ti/audit-2_0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 18 Aug 2009 09:14:23 +0000 (09:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    audit-m4.patch -> 1.1
    audit.spec -> 1.73

audit-m4.patch [new file with mode: 0644]
audit.spec

diff --git a/audit-m4.patch b/audit-m4.patch
new file mode 100644 (file)
index 0000000..94fd850
--- /dev/null
@@ -0,0 +1,45 @@
+diff -urN audit-2.0.org/acinclude.m4 audit-2.0/acinclude.m4
+--- audit-2.0.org/acinclude.m4 1970-01-01 01:00:00.000000000 +0100
++++ audit-2.0/acinclude.m4     2009-08-18 11:11:24.700738677 +0200
+@@ -0,0 +1,41 @@
++# libcap-ng.m4 - Checks for the libcap-ng support
++#     Copyright (c) 2009 Steve Grubb sgrubb@redhat.com
++#
++AC_DEFUN([LIBCAP_NG_PATH],
++[
++  AC_ARG_WITH(libcap-ng,
++    [  --with-libcap-ng=[auto/yes/no]  Add Libcap-ng support [default=auto]],,
++    with_libcap_ng=auto)
++
++  # Check for Libcap-ng API
++  #
++  # libcap-ng detection
++
++  if test x$with_libcap_ng = xno ; then
++      have_libcap_ng=no;
++  else
++      # Start by checking for header file
++      AC_CHECK_HEADER(cap-ng.h, capng_headers=yes, capng_headers=no)
++
++      # See if we have libcap-ng library
++      AC_CHECK_LIB(cap-ng, capng_clear,
++               CAPNG_LDADD=-lcap-ng,)
++
++      # Check results are usable
++      if test x$with_libcap_ng = xyes -a x$CAPNG_LDADD = x ; then
++         AC_MSG_ERROR(libcap-ng support was requested and the library was not found)
++      fi
++      if test x$CAPNG_LDADD != x -a $capng_headers = no ; then
++         AC_MSG_ERROR(libcap-ng libraries found but headers are missing)
++      fi
++  fi
++  AC_SUBST(CAPNG_LDADD)
++  AC_MSG_CHECKING(whether to use libcap-ng)
++  if test x$CAPNG_LDADD != x ; then
++      AC_DEFINE(HAVE_LIBCAP_NG,1,[libcap-ng support])
++      AC_MSG_RESULT(yes)
++  else
++      AC_MSG_RESULT(no)
++  fi
++])
++
index 7821219ae60d79a68c8dc0633157274ab7cbd9bd..8217765475c90137eca7d478deab6f259e5dc61c 100644 (file)
@@ -7,16 +7,17 @@
 Summary:       User space tools for 2.6 kernel auditing
 Summary(pl.UTF-8):     Narzędzia przestrzeni użytkownika do audytu jąder 2.6
 Name:          audit
-Version:       1.7.13
-Release:       5
+Version:       2.0
+Release:       1
 License:       GPL v2+
 Group:         Daemons
 Source0:       http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
-# Source0-md5: 967776cbec046043ef02ffefe0e89cb7
+# Source0-md5: d0c064c4646f8fe5c50de789c627f2da
 Source2:       %{name}d.init
 Source3:       %{name}d.sysconfig
 Patch0:                %{name}-install.patch
 Patch1:                %{name}-pthread.patch
+Patch2:                %{name}-m4.patch
 URL:           http://people.redhat.com/sgrubb/audit/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1:1.9
@@ -152,27 +153,19 @@ Narzędzie do zmiany konfiguracji audytu.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %if !%{with python}
 sed 's#swig/Makefile ##' -i configure.ac
 sed 's/swig//' -i Makefile.am
 %endif
 
-sed -i -e 's,/main\.py,/main.pyc,' system-config-audit/src/system-config-audit.in
-
 %build
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-cd system-config-audit
-%{__libtoolize}
-%{__aclocal}
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-cd ..
 %configure \
        --with-apparmor \
        --enable-gssapi-krb5 \
@@ -215,9 +208,6 @@ install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/auditd
 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/*.py
 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
-
-%py_postclean $RPM_BUILD_ROOT%{_datadir}/system-config-audit
-%find_lang system-config-audit
 %endif
 
 %clean
@@ -285,7 +275,7 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) /%{_lib}/libaudit.so.*.*.*
-%attr(755,root,root) %ghost /%{_lib}/libaudit.so.0
+%attr(755,root,root) %ghost /%{_lib}/libaudit.so.1
 %attr(755,root,root) /%{_lib}/libauparse.so.*.*.*
 %attr(755,root,root) %ghost /%{_lib}/libauparse.so.0
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libaudit.conf
@@ -325,11 +315,4 @@ fi
 %attr(755,root,root) %{py_sitedir}/_audit.so
 %attr(755,root,root) %{py_sitedir}/auparse.so
 %{py_sitedir}/audit.py[co]
-
-%files -n system-config-audit -f system-config-audit.lang
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/system-config-audit
-%attr(755,root,root) %{_libexecdir}/system-config-audit-server
-%{_datadir}/system-config-audit
-%{_desktopdir}/system-config-audit.desktop
 %endif
This page took 0.148182 seconds and 4 git commands to generate.