]> git.pld-linux.org Git - packages/audacity.git/commitdiff
- use system sbsms auto/th/audacity-2.4.2-2
authorKrzysztof Mrozowicz <mrozowik@pld-linux.org>
Mon, 25 Jan 2021 17:18:52 +0000 (17:18 +0000)
committerKrzysztof Mrozowicz <mrozowik@pld-linux.org>
Mon, 25 Jan 2021 17:18:52 +0000 (17:18 +0000)
audacity.spec
use-system-libsbsms.patch [new file with mode: 0644]

index ecc54de52a0e6e7514bd1f40a351dcb537ee8600..4cfbadca79a08931f303f481c1bc0b338076ddbb 100644 (file)
@@ -2,8 +2,6 @@
 # - internal portaudio crashes when only OSS is available on startup
 # - use system portaudio (>= 19, but relies on local changes)
 # - use system portSMF?
-# - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12, libavutil)
-# - use system sbsms (>= 1.6.0, but relies on local changes)
 # - use system libnyquist (if ever; currently it's a part of audacity project)
 #
 # Conditional build:
@@ -28,7 +26,7 @@ Summary(pl.UTF-8):    Audacity - narzędzie do obróbki plików dźwiękowych
 Summary(ru.UTF-8):     Кроссплатформенный звуковой редактор
 Name:          audacity
 Version:       2.4.2
-Release:       1
+Release:       2
 License:       GPL v2+
 Group:         X11/Applications/Sound
 #Source0Download: http://www.fosshub.com/Audacity.html
@@ -39,6 +37,7 @@ Source1:      %{name}-manual-%{version}.zip
 Patch0:                %{name}-opt.patch
 Patch1:                %{name}-no-macos.patch
 Patch2:                %{name}-desktop.patch
+Patch3:                use-system-libsbsms.patch
 URL:           http://audacityteam.org/
 BuildRequires: alsa-lib-devel
 BuildRequires: autoconf >= 2.59
@@ -56,8 +55,7 @@ BuildRequires:        lame-libs-devel
 BuildRequires: libid3tag-devel >= 0.15.0b-2
 BuildRequires: libjpeg-devel
 BuildRequires: libmad-devel >= 0.14.2b-4
-#BuildRequires:        libsbsms-devel >= 1.6.0
-#BuildRequires:        libsbsms2-devel >= 2.0.2
+BuildRequires: libsbsms2-devel >= 2.1.0
 BuildRequires: libsndfile-devel >= 1.0.0
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:2
@@ -87,6 +85,7 @@ Requires:     flac-c++ >= 1.3.0
 Requires:      lame-libs
 Requires:      libid3tag >= 0.15.0b-2
 Requires:      libmad >= 0.14.2b-4
+Requires:      libsbsms2 >= 2.1.0
 Requires:      libsndfile >= 1.0.0
 Requires:      lilv >= 0.16
 Requires:      soundtouch >= 1.3.0
@@ -121,9 +120,13 @@ Audacity - это звуковой редактор, позволяющий ра
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
 
+# Make sure we use the system versions.
+%{__rm} -rf lib-src/{expat,ffmpeg,libflac,libid3tag,lame,lv2,libmad,libogg,libsndfile,soundtouch,libsoxr,twolame,libvamp,libvorbis,sbsms}/
+
 # Audacity's cmake can't find libmp3lame without a .pc file
 # This is a temporary workaround.
 if ! test -e %{_pkgconfigdir}/lame.pc
diff --git a/use-system-libsbsms.patch b/use-system-libsbsms.patch
new file mode 100644 (file)
index 0000000..9dc3059
--- /dev/null
@@ -0,0 +1,21 @@
+--- audacity-minsrc-2.4.2/cmake-proxies/CMakeLists.txt~        2020-05-30 11:55:53.000000000 +0000
++++ audacity-minsrc-2.4.2/cmake-proxies/CMakeLists.txt 2021-01-25 15:40:30.370255530 +0000
+@@ -149,7 +149,7 @@
+ addlib( portmidi           midi        MIDI        NO    YES   "portmidi >= 0.1" )
+ addlib( portmixer          portmixer   PORTMIXER   NO    YES   "" )
+ addlib( portsmf            portsmf     PORTSMF     NO    YES   "portSMF >= 0.1" )
+-addlib( sbsms              sbsms       SBSMS       NO    YES   "" )
++addlib( sbsms              sbsms       SBSMS       NO    YES   "sbsms" )
+ addlib( soundtouch         soundtouch  SOUNDTOUCH  NO    YES   "soundtouch >= 1.7.1" )
+ addlib( twolame            twolame     LIBTWOLAME  NO    YES   "twolame >= 0.3.13" )
+--- audacity-minsrc-2.4.2/lib-src/header-substitutes/sbsms.h~  2018-08-28 10:48:03.000000000 +0000
++++ audacity-minsrc-2.4.2/lib-src/header-substitutes/sbsms.h   2021-01-25 16:18:05.627283474 +0000
+@@ -11,6 +11,6 @@
+ #else //_MSC_VER
+-#include "../sbsms/include/sbsms.h"
++#include "/usr/include/sbsms.h"
+ #endif //_MSC_VER
This page took 0.030262 seconds and 4 git commands to generate.