]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- up to 3.4.2
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12, libavutil)
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 # - use system libnyquist (if ever; currently it's a part of audacity project)
8 #
9 # Conditional build:
10 %bcond_with     ffmpeg          # build with ffmpeg support (currently audacity does not support ffmpeg 1.0)
11 %bcond_with     gtk3            # GTK+ 3.x instead of 2.x
12 #
13 Summary:        Audacity - manipulate digital audio waveforms
14 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
15 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
16 Name:           audacity
17 Version:        2.1.3
18 Release:        1
19 License:        GPL v2+
20 Group:          X11/Applications/Sound
21 #Source0Download: http://www.fosshub.com/Audacity.html
22 Source0:        %{name}-minsrc-%{version}.tar.xz
23 # Source0-md5:  c8c8225739bc7eecec9fae68a0ced471
24 Source1:        %{name}-manual-%{version}.zip
25 # Source1-md5:  ec45390889e7f1cda26c764bbd6b4979
26 Source2:        %{name}.desktop
27 Source3:        %{name}-icon.png
28 Patch0:         %{name}-opt.patch
29 Patch1:         %{name}-no-macos.patch
30 URL:            http://audacityteam.org/
31 BuildRequires:  alsa-lib-devel
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake >= 1:1.9
34 BuildRequires:  expat-devel >= 1.95
35 # libavcodec >= 51.53 libavformat >= 52.12 libavutil
36 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.8.0}
37 BuildRequires:  flac-c++-devel >= 1.3.0
38 BuildRequires:  gettext-tools >= 0.18
39 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2.0}
40 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0}
41 BuildRequires:  jack-audio-connection-kit-devel
42 BuildRequires:  hpklinux-devel >= 4.06
43 BuildRequires:  lame-libs-devel
44 BuildRequires:  libid3tag-devel >= 0.15.0b-2
45 BuildRequires:  libjpeg-devel
46 BuildRequires:  libmad-devel >= 0.14.2b-4
47 #BuildRequires: libsbsms-devel >= 1.6.0
48 #BuildRequires: libsbsms2-devel >= 2.0.2
49 BuildRequires:  libsndfile-devel >= 1.0.0
50 BuildRequires:  libstdc++-devel
51 BuildRequires:  libtool >= 2:2
52 BuildRequires:  libvorbis-devel >= 1:1.0
53 BuildRequires:  lilv-devel >= 0.16
54 BuildRequires:  lv2-devel
55 #BuildRequires: portaudio-devel >= 19
56 BuildRequires:  pkgconfig
57 BuildRequires:  soundtouch-devel >= 1.3.0
58 BuildRequires:  soxr-devel >= 0.0.5
59 BuildRequires:  speex-devel
60 BuildRequires:  suil-devel >= 0.8.2
61 BuildRequires:  twolame-devel >= 0.3.9
62 BuildRequires:  udev-devel
63 BuildRequires:  unzip
64 BuildRequires:  vamp-devel >= 2.0
65 BuildRequires:  which
66 %{!?with_gtk3:BuildRequires:    wxGTK2-unicode-devel >= 2.8.0}
67 %{?with_gtk3:BuildRequires:     wxGTK3-unicode-devel >= 2.8.0}
68 Requires(post,postun):  shared-mime-info
69 Requires:       flac-c++ >= 1.3.0
70 # dlopened
71 Requires:       lame-libs
72 Requires:       libid3tag >= 0.15.0b-2
73 Requires:       libmad >= 0.14.2b-4
74 Requires:       libsndfile >= 1.0.0
75 Requires:       lilv >= 0.16
76 Requires:       soundtouch >= 1.3.0
77 %{?with_soxr:Requires:  soxr >= 0.0.5}
78 Requires:       suil >= 0.8.2
79 Requires:       twolame-libs >= 0.3.9
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 Audacity is a program that lets you manipulate digital audio
84 waveforms. It imports many sound file formats, including WAV, AIFF,
85 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
86 operations such as Cut, Copy, and Paste, plus it will mix tracks and
87 let you apply plug-in effects to any part of a sound.
88
89 %description -l pl.UTF-8
90 Audacity to program obsługujący różne formaty plików audio. Obsługuje
91 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
92 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
93 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
94 wykonywanie dowolnych innych operacji poprzez system wtyczek.
95
96 %description -l ru.UTF-8
97 Audacity - это звуковой редактор, позволяющий работать с файлами в
98 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
99 основные операции, такие как удаление, копирование, вставка,
100 микширование треков и применение эффектов, оформленных в виде
101 плагинов, к любой части звукового файла.
102
103 %package devel
104 Summary:        Header files for Audacity interfaces
105 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsów Audacity
106 Group:          Development/Libraries
107 Requires:       libstdc++-devel
108 Requires:       wxWidgets-devel >= 2.8.0
109 # doesn't require base
110
111 %description devel
112 Header files for Audacity interfaces.
113
114 %description devel -l pl.UTF-8
115 Pliki nagłówkowe interfejsów Audacity.
116
117 %prep
118 %setup -q -n %{name}-minsrc-%{version}
119 %patch0 -p1
120 %patch1 -p1
121
122 # OPTIONAL_SUBDIRS are not included in tarball; allow autotools to work
123 %{__sed} -i '/SUBDIRS += \$(OPTIONAL_SUBDIRS)/d' lib-src/Makefile.am
124
125 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
126
127 %build
128 cd lib-src/portmixer
129 %{__libtoolize}
130 %{__aclocal} -I m4
131 %{__autoconf}
132 %{__automake}
133 cd ../lib-widget-extra
134 %{__libtoolize}
135 %{__aclocal} -I m4
136 %{__autoconf}
137 %{__automake}
138 cd ../FileDialog
139 %{__libtoolize}
140 %{__aclocal} -I m4
141 %{__autoconf}
142 %{__automake}
143 cd ../portsmf
144 %{__aclocal} -I autotools/m4
145 %{__autoconf}
146 %{__automake}
147 cd ../..
148 %{__libtoolize}
149 %{__aclocal} -I m4
150 %{__autoconf}
151 %{__automake}
152
153 export WX_CONFIG=$(which wx-gtk%{?with_gtk3:3}%{!?with_gtk3:2}-unicode-config)
154 %configure \
155         %{?with_gtk3:--enable-gtk3} \
156         --with-ffmpeg%{!?with_ffmpeg:=no} \
157         --with-help \
158         --with-id3tag=system \
159         --with-libmad=system \
160         --with-libsndfile=system \
161         --with-libflac=system \
162         --with-sbsms=local \
163         --with-soxr=system \
164         --with-vorbis=system
165
166 %{__make}
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
171
172 %{__make} install \
173         DESTDIR=$RPM_BUILD_ROOT \
174         INSTALL_PATH=$RPM_BUILD_ROOT
175
176 # install headers in standard location
177 install -d $RPM_BUILD_ROOT%{_includedir}
178 %{__mv} $RPM_BUILD_ROOT%{_datadir}/audacity/include/audacity $RPM_BUILD_ROOT%{_includedir}
179 rmdir $RPM_BUILD_ROOT%{_datadir}/audacity/include
180
181 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
182 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
183 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
184
185 # unify locale names
186 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{ca_ES@valencia,ca@valencia}
187 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{pt_PT,pt}
188 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{sr_RS,sr}
189 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{sr_RS@latin,sr@latin}
190
191 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
192 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
193 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
194 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
195
196 %{__rm} $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/README.txt
197 %{__rm} $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/LICENSE.txt
198 %{__rmdir} $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}
199
200 %find_lang %{name}
201
202 %clean
203 rm -rf $RPM_BUILD_ROOT
204
205 %post
206 %update_mime_database
207
208 %postun
209 %update_mime_database
210
211 %files -f %{name}.lang
212 %defattr(644,root,root,755)
213 %doc README.txt LICENSE.txt
214 %attr(755,root,root) %{_bindir}/audacity
215 %dir %{_datadir}/%{name}
216 %{_datadir}/%{name}/nyquist
217 %{_datadir}/%{name}/plug-ins
218 %{_datadir}/%{name}/EQDefaultCurves.xml
219 %doc %{_datadir}/%{name}/help
220 %{_mandir}/man1/audacity.1*
221 %{_desktopdir}/audacity.desktop
222 %{_pixmapsdir}/audacity-icon.png
223 %{_datadir}/appdata/audacity.appdata.xml
224 %{_datadir}/mime/packages/audacity.xml
225 %{_iconsdir}/hicolor/*/apps/audacity.png
226 %{_iconsdir}/hicolor/*/apps/audacity.svg
227
228 %files devel
229 %defattr(644,root,root,755)
230 %{_includedir}/audacity
This page took 0.0788 seconds and 3 git commands to generate.