]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
07f114ab2a7146362cf51e344f36c6f884fd9ceb
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12, libavutil)
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 # - use system libnyquist (if ever; currently it's a part of audacity project)
8 #
9 # Conditional build:
10 %bcond_with     ffmpeg          # build with ffmpeg support (currently audacity does not support ffmpeg 1.0)
11 %bcond_with     gtk3            # GTK+ 3.x instead of 2.x
12 #
13 Summary:        Audacity - manipulate digital audio waveforms
14 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
15 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
16 Name:           audacity
17 Version:        2.1.1
18 Release:        2
19 License:        GPL v2+
20 Group:          X11/Applications/Sound
21 #Source0Download: http://www.oldfoss.com/Audacity.html
22 Source0:        http://app.oldfoss.com:81/download/Audacity/%{name}-minsrc-%{version}.tar.xz
23 # Source0-md5:  9e37b1f5cde38d089a35febb904a9e39
24 Source1:        http://app.oldfoss.com:81/download/Audacity/%{name}-manual-%{version}.zip
25 # Source1-md5:  a4116a20798b827cd1e06e50c8099aa6
26 Source2:        %{name}.desktop
27 Source3:        %{name}-icon.png
28 Patch0:         %{name}-cast.patch
29 Patch1:         %{name}-opt.patch
30 Patch2:         %{name}-no-macos.patch
31 URL:            http://audacityteam.org/
32 BuildRequires:  alsa-lib-devel
33 BuildRequires:  autoconf >= 2.59
34 BuildRequires:  automake >= 1:1.9
35 BuildRequires:  expat-devel >= 1.95
36 # libavcodec >= 51.53 libavformat >= 52.12 libavutil
37 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.8.0}
38 BuildRequires:  flac-c++-devel >= 1.3.0
39 BuildRequires:  gettext-tools >= 0.18
40 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2.0}
41 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0}
42 BuildRequires:  jack-audio-connection-kit-devel
43 BuildRequires:  hpklinux-devel >= 4.06
44 BuildRequires:  lame-libs-devel
45 BuildRequires:  libid3tag-devel >= 0.15.0b-2
46 BuildRequires:  libjpeg-devel
47 BuildRequires:  libmad-devel >= 0.14.2b-4
48 #BuildRequires: libsbsms-devel >= 1.6.0
49 #BuildRequires: libsbsms2-devel >= 2.0.2
50 BuildRequires:  libsndfile-devel >= 1.0.0
51 BuildRequires:  libstdc++-devel
52 BuildRequires:  libtool >= 2:2
53 BuildRequires:  libvorbis-devel >= 1:1.0
54 BuildRequires:  lilv-devel >= 0.16
55 BuildRequires:  lv2-devel
56 #BuildRequires: portaudio-devel >= 19
57 BuildRequires:  pkgconfig
58 BuildRequires:  soundtouch-devel >= 1.3.0
59 BuildRequires:  soxr-devel >= 0.0.5
60 BuildRequires:  speex-devel
61 BuildRequires:  suil-devel >= 0.8.2
62 BuildRequires:  twolame-devel >= 0.3.9
63 BuildRequires:  udev-devel
64 BuildRequires:  unzip
65 BuildRequires:  vamp-devel >= 2.0
66 BuildRequires:  which
67 %{!?with_gtk3:BuildRequires:    wxGTK2-unicode-devel >= 2.8.0}
68 %{?with_gtk3:BuildRequires:     wxGTK3-unicode-devel >= 2.8.0}
69 Requires(post,postun):  shared-mime-info
70 Requires:       flac-c++ >= 1.3.0
71 Requires:       lame-libs
72 Requires:       libid3tag >= 0.15.0b-2
73 Requires:       libmad >= 0.14.2b-4
74 Requires:       libsndfile >= 1.0.0
75 Requires:       lilv
76 Requires:       soundtouch >= 1.3.0
77 %{?with_soxr:Requires:  soxr >= 0.0.5}
78 Requires:       suil
79 Requires:       twolame-libs >= 0.3.9
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 Audacity is a program that lets you manipulate digital audio
84 waveforms. It imports many sound file formats, including WAV, AIFF,
85 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
86 operations such as Cut, Copy, and Paste, plus it will mix tracks and
87 let you apply plug-in effects to any part of a sound.
88
89 %description -l pl.UTF-8
90 Audacity to program obsługujący różne formaty plików audio. Obsługuje
91 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
92 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
93 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
94 wykonywanie dowolnych innych operacji poprzez system wtyczek.
95
96 %description -l ru.UTF-8
97 Audacity - это звуковой редактор, позволяющий работать с файлами в
98 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
99 основные операции, такие как удаление, копирование, вставка,
100 микширование треков и применение эффектов, оформленных в виде
101 плагинов, к любой части звукового файла.
102
103 %package devel
104 Summary:        Header files for Audacity interfaces
105 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsów Audacity
106 Group:          Development/Libraries
107 Requires:       libstdc++-devel
108 Requires:       wxWidgets-devel >= 2.8.0
109 # doesn't require base
110
111 %description devel
112 Header files for Audacity interfaces.
113
114 %description devel -l pl.UTF-8
115 Pliki nagłówkowe interfejsów Audacity.
116
117 %prep
118 %setup -q -n %{name}-minsrc-%{version}
119 %patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122
123 # OPTIONAL_SUBDIRS are not included in tarball; allow autotools to work
124 %{__sed} -i '/SUBDIRS += \$(OPTIONAL_SUBDIRS)/d' lib-src/Makefile.am
125
126 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
127
128 %build
129 cd lib-src/portmixer
130 %{__libtoolize}
131 %{__aclocal} -I m4
132 %{__autoconf}
133 %{__automake}
134 cd ../lib-widget-extra
135 %{__libtoolize}
136 %{__aclocal} -I m4
137 %{__autoconf}
138 %{__automake}
139 cd ../FileDialog
140 %{__libtoolize}
141 %{__aclocal} -I m4
142 %{__autoconf}
143 %{__automake}
144 cd ../portsmf
145 %{__aclocal} -I autotools/m4
146 %{__autoconf}
147 %{__automake}
148 cd ../..
149 %{__libtoolize}
150 %{__aclocal} -I m4
151 %{__autoconf}
152 %{__automake}
153
154 export WX_CONFIG=$(which wx-gtk%{?with_gtk3:3}%{!?with_gtk3:2}-unicode-config)
155 %configure \
156         %{?with_gtk3:--enable-gtk3} \
157         --with-ffmpeg%{!?with_ffmpeg:=no} \
158         --with-help \
159         --with-id3tag=system \
160         --with-libmad=system \
161         --with-libsndfile=system \
162         --with-libflac=system \
163         --with-sbsms=local \
164         --with-soxr=system \
165         --with-vorbis=system
166
167 %{__make}
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
172
173 %{__make} install \
174         DESTDIR=$RPM_BUILD_ROOT \
175         INSTALL_PATH=$RPM_BUILD_ROOT
176
177 # install headers in standard location
178 install -d $RPM_BUILD_ROOT%{_includedir}
179 %{__mv} $RPM_BUILD_ROOT%{_datadir}/audacity/include/audacity $RPM_BUILD_ROOT%{_includedir}
180 rmdir $RPM_BUILD_ROOT%{_datadir}/audacity/include
181
182 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
183 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
184 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
185
186 # unify locale names
187 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{ca_ES@valencia,ca@valencia}
188 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{sr_RS,sr}
189 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{sr_RS@latin,sr@latin}
190 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
191
192 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
193 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
194 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
195 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
196
197 %find_lang %{name}
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %post
203 %update_mime_database
204
205 %postun
206 %update_mime_database
207
208 %files -f %{name}.lang
209 %defattr(644,root,root,755)
210 %doc README.txt
211 %attr(755,root,root) %{_bindir}/audacity
212 %dir %{_datadir}/%{name}
213 %{_datadir}/%{name}/nyquist
214 %{_datadir}/%{name}/plug-ins
215 %{_datadir}/%{name}/EQDefaultCurves.xml
216 %doc %{_datadir}/%{name}/help
217 %{_mandir}/man1/audacity.1*
218 %{_desktopdir}/audacity.desktop
219 %{_pixmapsdir}/audacity-icon.png
220 %{_datadir}/appdata/audacity.appdata.xml
221 %{_datadir}/mime/packages/audacity.xml
222 %{_iconsdir}/hicolor/*/apps/audacity.png
223 %{_iconsdir}/hicolor/*/apps/audacity.svg
224
225 %files devel
226 %defattr(644,root,root,755)
227 %{_includedir}/audacity
This page took 0.074232 seconds and 2 git commands to generate.