]> git.pld-linux.org Git - packages/audacity.git/blame_incremental - audacity.spec
- rel 2
[packages/audacity.git] / audacity.spec
... / ...
CommitLineData
1# TODO:
2# - internal portaudio crashes when only OSS is available on startup
3# - use system vamp
4#
5# Conditional build:
6%bcond_with libresample # using libresample (default libsamplerate)
7#
8Summary: Audacity - manipulate digital audio waveforms
9Summary(pl.UTF-8): Audacity - narzędzie do obróbki plików dźwiękowych
10Summary(ru.UTF-8): Кроссплатформенный звуковой редактор
11Name: audacity
12Version: 1.3.11
13Release: 2
14License: GPL
15Group: X11/Applications/Sound
16Source0: http://audacity.googlecode.com/files/%{name}-minsrc-%{version}.tar.bz2
17# Source0-md5: 670937c483fb5273ceff9e38a82db55f
18# Link from http://manual.audacityteam.org/index.php?title=Main_Page
19Source1: http://manual.audacityteam.org/help.zip
20# Source1-md5: 95cd5f0f73116512e577592faa4fcb02
21Source2: %{name}.desktop
22Source3: %{name}-icon.png
23Patch0: %{name}-system-libs.patch
24Patch1: %{name}-opt.patch
25URL: http://audacity.sourceforge.net/
26BuildRequires: autoconf >= 2.50
27BuildRequires: automake
28BuildRequires: expat-devel >= 1.95
29BuildRequires: fftw-devel >= 2.1.4
30BuildRequires: flac-c++-devel >= 1.2.0
31BuildRequires: gettext-devel
32BuildRequires: libid3tag-devel >= 0.15.0b-2
33BuildRequires: libjpeg-devel
34BuildRequires: libmad-devel >= 0.14.2b-4
35%{?with_libresample:BuildRequires: libresample-devel >= 0.1.3}
36%{!?with_libresample:BuildRequires: libsamplerate-devel >= 0.1.2}
37BuildRequires: libsndfile-devel >= 1.0.0
38BuildRequires: libstdc++-devel
39BuildRequires: libvorbis-devel >= 1:1.0
40BuildRequires: pkgconfig
41BuildRequires: soundtouch-devel >= 1.3.0
42BuildRequires: speex-devel
43BuildRequires: twolame-devel
44BuildRequires: which
45BuildRequires: wxGTK2-unicode-devel >= 2.8.0
46BuildRequires: zip
47Requires(post,postun): shared-mime-info
48Requires: lame-libs
49Requires: libid3tag >= 0.15.0b-2
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%description
53Audacity is a program that lets you manipulate digital audio
54waveforms. It imports many sound file formats, including WAV, AIFF,
55AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
56operations such as Cut, Copy, and Paste, plus it will mix tracks and
57let you apply plug-in effects to any part of a sound.
58
59%description -l pl.UTF-8
60Audacity to program obsługujący różne formaty plików audio. Obsługuje
61WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
62wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
63wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
64wykonywanie dowolnych innych operacji poprzez system wtyczek.
65
66%description -l ru.UTF-8
67Audacity - это звуковой редактор, позволяющий работать с файлами в
68форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
69основные операции, такие как удаление, копирование, вставка,
70микширование треков и применение эффектов, оформленных в виде
71плагинов, к любой части звукового файла.
72
73%prep
74%setup -q -n %{name}-src-%{version}-beta
75%patch0 -p1
76%patch1 -p1
77
78sed -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
79
80%build
81cd lib-src/portmixer
82%{__autoconf}
83cd ../portsmf
84%{__aclocal} -I autotools/m4
85%{__autoconf}
86cd ../..
87%{__aclocal} -I m4
88%{__autoconf}
89
90export WX_CONFIG=$(which wx-gtk2-unicode-config)
91%configure \
92%if %{with libresample}
93 --with-libresample=system \
94%else
95 --with-libresample=no \
96 --with-libsamplerate=system \
97%endif
98 --with-help \
99 --with-id3tag=system \
100 --with-libmad=system \
101 --with-libsndfile=system \
102 --with-libflac=system \
103 --with-vorbis=system
104
105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
110
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT \
113 INSTALL_PATH=$RPM_BUILD_ROOT
114
115cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
116cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
117%{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
118
119mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
120rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/
121rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca@valencia
122
123%find_lang %{name}
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post
129%update_mime_database
130
131%postun
132%update_mime_database
133
134%files -f %{name}.lang
135%defattr(644,root,root,755)
136%doc README.txt
137%attr(755,root,root) %{_bindir}/audacity
138%dir %{_datadir}/%{name}
139%{_datadir}/%{name}/nyquist
140%{_datadir}/%{name}/plug-ins
141%doc %{_datadir}/%{name}/help
142%{_mandir}/man1/*.1*
143%{_desktopdir}/*.desktop
144%{_pixmapsdir}/*.png
145%{_datadir}/mime/packages/audacity.xml
This page took 0.052682 seconds and 4 git commands to generate.