]> git.pld-linux.org Git - packages/aubio.git/blob - aubio.spec
- upstream fix for ffmpeg 6, rel 6
[packages/aubio.git] / aubio.spec
1 #
2 # Conditional build:
3 %bcond_without  python2  # python bindings
4 %bcond_without  python3  # python bindings
5 #
6 Summary:        aubio - library for audio labelling
7 Summary(pl.UTF-8):      aubio - biblioteka do oznaczania dźwięku
8 Name:           aubio
9 Version:        0.4.3
10 Release:        2
11 License:        GPL v3+
12 Group:          Libraries
13 Source0:        http://aubio.piem.org/pub/%{name}-%{version}.tar.bz2
14 # Source0-md5:  52a960cfc8a3e3125f3a258545d1c7e5
15 URL:            http://aubio.piem.org/
16 BuildRequires:  alsa-lib-devel >= 0.9.0
17 BuildRequires:  doxygen
18 BuildRequires:  ffmpeg-devel
19 BuildRequires:  fftw3-single-devel >= 3.0.0
20 BuildRequires:  jack-audio-connection-kit-devel >= 0.15.0
21 BuildRequires:  libsamplerate-devel >= 0.0.15
22 BuildRequires:  libsndfile-devel >= 1.0.4
23 BuildRequires:  pkgconfig
24 BuildRequires:  txt2man
25 %if %{with python2} || %{with python3}
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 %endif
29 %if %{with python2}
30 BuildRequires:  python-devel
31 BuildRequires:  python-numpy-devel
32 BuildRequires:  python-setuptools
33 %endif
34 %if %{with python3}
35 BuildRequires:  python3-devel
36 BuildRequires:  python3-numpy-devel
37 BuildRequires:  python3-setuptools
38 %endif
39 BuildRequires:  sed >= 4.0
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 aubio is a library for audio labelling.
44
45 %description -l pl.UTF-8
46 aubio to biblioteka do oznaczania dźwięku.
47
48 %package devel
49 Summary:        Header files for aubio library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki aubio
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       fftw3-single-devel >= 3.0.0
54 Requires:       libsamplerate-devel >= 0.0.15
55 # for libaubioext:
56 # alsa-lib-devel >= 0.9.0
57 # jack-audio-connection-kit-devel >= 0.15.0
58 # libsndfile-devel >= 1.0.4
59
60 %description devel
61 Header files for aubio library.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki aubio.
65
66 %package static
67 Summary:        Static aubio library
68 Summary(pl.UTF-8):      Statyczna biblioteka aubio
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static aubio library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka aubio.
77
78 %package progs
79 Summary:        Example applications using aubio library
80 Summary(pl.UTF-8):      Przykładowe programy korzystajace z biblioteki aubio
81 Group:          Applications/Sound
82 Requires:       %{name} = %{version}-%{release}
83
84 %description progs
85 A few examples of applications using aubio library:
86 - aubioonset: outputs the onset detected.
87 - aubionotes: uses both onset and pitch to extract symbolic music data
88   from an audio source and emit MIDI like data.
89 - aubiocut: a Python script that takes an input sound and creates one
90   new sample at each detected onset or beat. The slices produced by
91   aubiocut are useful for use with a sequencer such as Hydrogen.
92 - aubiopitch: a Python script to extract pitch tracks from sound
93   files.
94
95 %description progs -l pl.UTF-8
96 Kilka przykładowych aplikacji korzystających z biblioteki dubio:
97 - aubioonset - wypisuje wykryty początek.
98 - aubionotes - wykorzystuje początek i wysokość do wyciągnięcia
99   symbolicznych danych muzycznych ze źródła dźwięku i stworzenia danych
100   typu MIDI.
101 - aubiocut - skrypt Pythona pobierający dźwięk wejściowy i tworzący
102   nową próbkę dla każdego wykrytego początku lub taktu. Fragmenty
103   tworzone przez aubiocut są przydatne do wykorzystania przez sekwencer,
104   jak np. Hydrogen.
105 - aubiopitch - skrypt Pythona do wyciągania ścieżek wysokości z plików
106   dźwiękowych.
107
108 %package -n python-aubio
109 Summary:        aubio Python bindings
110 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki aubio
111 Group:          Libraries/Python
112 Requires:       %{name} = %{version}-%{release}
113
114 %description -n python-aubio
115 aubio Python bindings.
116
117 %description -n python-aubio -l pl.UTF-8
118 Wiązania Pythona do biblioteki aubio.
119
120 %package -n python3-aubio
121 Summary:        aubio Python bindings
122 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki aubio
123 Group:          Libraries/Python
124 Requires:       %{name} = %{version}-%{release}
125
126 %description -n python3-aubio
127 aubio Python bindings.
128
129 %description -n python3-aubio -l pl.UTF-8
130 Wiązania Pythona do biblioteki aubio.
131
132 %prep
133 %setup -q
134
135 %build
136 export CC="%{__cc}"
137 export CXX="%{__cxx}"
138 export CFLAGS="%{rpmcflags}"
139 export CXXFLAGS="%{rpmcxxflags}"
140 export LDFLAGS="%{rpmldflags}"
141 ./waf configure \
142         --prefix=%{_prefix} \
143         --libdir=%{_libdir} \
144         --libexecdir=%{_libexecdir} \
145         --enable-fftw3f \
146         --enable-jack \
147         --enable-sndfile \
148         --enable-avcodec \
149         --enable-samplerate \
150         --disable-atlas \
151         --enable-docs
152
153 ./waf build -v
154
155 %if %{with python2}
156 %py_build %{?with_tests:test}
157 %endif
158
159 %if %{with python3}
160 %py3_build %{?with_tests:test}
161 %endif
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 ./waf install -v \
167         --destdir=$RPM_BUILD_ROOT \
168         --libdir=%{_libdir} \
169         --prefix=%{_prefix} \
170         --libexecdir=%{_libexecdir}
171
172 %if %{with python2}
173 %py_install
174 %endif
175
176 %if %{with python3}
177 %py3_install
178 %endif
179
180 rm -r $RPM_BUILD_ROOT%{_docdir}/libaubio-doc
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post   -p /sbin/ldconfig
186 %postun -p /sbin/ldconfig
187
188 %files
189 %defattr(644,root,root,755)
190 %doc AUTHORS ChangeLog README.md
191 %attr(755,root,root) %{_libdir}/libaubio.so.5.*.*
192 %attr(755,root,root) %ghost %{_libdir}/libaubio.so.5
193
194 %files devel
195 %defattr(644,root,root,755)
196 %doc doc/web/html/*
197 %attr(755,root,root) %{_libdir}/libaubio.so
198 %{_includedir}/%{name}
199 %{_pkgconfigdir}/aubio.pc
200
201 %files progs
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_bindir}/aubiomfcc
204 %attr(755,root,root) %{_bindir}/aubionotes
205 %attr(755,root,root) %{_bindir}/aubioonset
206 %attr(755,root,root) %{_bindir}/aubiopitch
207 %attr(755,root,root) %{_bindir}/aubioquiet
208 %attr(755,root,root) %{_bindir}/aubiotrack
209 %{_mandir}/man1/aubiomfcc.1*
210 %{_mandir}/man1/aubionotes.1*
211 %{_mandir}/man1/aubioonset.1*
212 %{_mandir}/man1/aubiopitch.1*
213 %{_mandir}/man1/aubioquiet.1*
214 %{_mandir}/man1/aubiotrack.1*
215
216 %if %{with python2}
217 %files -n python-aubio
218 %defattr(644,root,root,755)
219 %dir %{py_sitedir}/aubio
220 %{py_sitedir}/aubio/*.py*
221 %attr(755,root,root) %{py_sitedir}/aubio/_aubio.so
222 %{py_sitedir}/aubio*.egg-info
223 %if %{without python3}
224 %attr(755,root,root) %{_bindir}/aubiocut
225 %{_mandir}/man1/aubiocut.1*
226 %endif
227 %endif
228
229 %if %{with python3}
230 %files -n python3-aubio
231 %defattr(644,root,root,755)
232 %dir %{py3_sitedir}/aubio
233 %{py3_sitedir}/aubio/__pycache__
234 %{py3_sitedir}/aubio/*.py
235 %attr(755,root,root) %{py3_sitedir}/aubio/_aubio.*.so
236 %{py3_sitedir}/aubio*.egg-info
237 %attr(755,root,root) %{_bindir}/aubiocut
238 %{_mandir}/man1/aubiocut.1*
239 %endif
This page took 0.081646 seconds and 3 git commands to generate.