]> git.pld-linux.org Git - packages/attr.git/blobdiff - attr.spec
- BR: sed 4.0 is required
[packages/attr.git] / attr.spec
index a9c4daf38897ae32fdde19af45427f0aea3918ea..fc391ffdaa5562c123fa86313c5ea0cc2bcf6ba5 100644 (file)
--- a/attr.spec
+++ b/attr.spec
@@ -1,21 +1,26 @@
 Summary:       Utility for managing filesystem extended attributes
-Summary(pl):   Narzêdzia do zarz±dzania rozszerzonymi atrybutami fs
+Summary(pl):   Narzêdzia do zarz±dzania rozszerzonymi atrybutami systemu plików
 Name:          attr
-Version:       2.2.0
-Release:       2
+Version:       2.4.19
+Release:       1
+# most part is on LGPL v2.1, but the rest enforces GPL
 License:       GPL
 Group:         Applications/System
 Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
+# Source0-md5: 0ea0d3bea5a58727eafd46fa1c0f09cc
 Patch0:                %{name}-miscfix.patch
+Patch1:                %{name}-po.patch
 URL:           http://oss.sgi.com/projects/xfs/
 BuildRequires: autoconf
-BuildRequires: e2fsprogs-devel
-BuildRequires: xfsprogs-devel >= 2.0.0
+BuildRequires: automake
+BuildRequires: gettext-devel
+BuildRequires: sed >= 4.0
+Obsoletes:     libattr
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _bindir         /bin
-%define                _libdir         /lib
-%define                _libexecdir     /usr/lib
+%define                _libdir         /%{_lib}
+%define                _libexecdir     /usr/%{_lib}
 
 %description
 An experimental attr command to manipulate extended attributes under
@@ -27,9 +32,9 @@ atrybutami pod systemem Linux.
 
 %package devel
 Summary:       Header files and libraries to use extended attributes
-Summary(pl):   Pliki nag³ówkowe i biblioteki
+Summary(pl):   Pliki nag³ówkowe i biblioteki do korzystania z rozszerzonych atrybutów
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files to develop software which manipulate extended attributes.
@@ -40,45 +45,56 @@ rozszerzonymi atrybutami.
 
 %package static
 Summary:       Static libraries for extended attributes
-Summary(pl):   Biblioteki statyczne attr
+Summary(pl):   Biblioteki statyczne do korzystania z rozszerzonych atrybutów
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static libraries for extended attributes.
 
 %description static -l pl
-Biblioteki statyczne attr.
+Biblioteki statyczne do korzystania z rozszerzonych atrybutów.
 
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
-DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
+rm -f aclocal.m4
+%{__aclocal} -I m4
 %{__autoconf}
-%configure
+%configure \
+       DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
+       OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-DIST_ROOT="$RPM_BUILD_ROOT"
+DIST_ROOT=$RPM_BUILD_ROOT
 DIST_INSTALL=`pwd`/install.manifest
 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
 
-%{__make} install DIST_MANIFEST="$DIST_INSTALL"
-%{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
-%{__make} install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
+%{__make} install \
+       DIST_MANIFEST=$DIST_INSTALL
+%{__make} install-dev \
+       DIST_MANIFEST=$DIST_INSTALL_DEV
+%{__make} install-lib \
+       DIST_MANIFEST=$DIST_INSTALL_LIB
 
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
 rm -rf $RPM_BUILD_ROOT%{_mandir}/man2
 
-ln -sf %{_libdir}/libattr.so.1.0.1 $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
+ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libattr.so.*.*.*) \
+        $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
+
+%{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
+       $RPM_BUILD_ROOT%{_libexecdir}/libattr.la
 
 echo ".so attr_get.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
 echo ".so attr_list.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
@@ -91,22 +107,22 @@ echo ".so attr_set.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc doc/CHANGES
+%doc README doc/CHANGES
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
-%{_mandir}/man[18]/*
+%{_mandir}/man[158]/*
 
 %files devel
 %defattr(644,root,root,755)
 %{_libexecdir}/lib*.la
 %attr(755,root,root) %{_libexecdir}/lib*.so
 %{_includedir}/attr
-%{_mandir}/man[35]/*
+%{_mandir}/man3/*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.059845 seconds and 4 git commands to generate.