]> git.pld-linux.org Git - packages/attr.git/blobdiff - attr.spec
- initial, for 2.4.14
[packages/attr.git] / attr.spec
index e0a23fb0c5709059cda940918f0e7a1f5fc20bbf..3ca7016816cce94c497e06780b4de8c7a02181e8 100644 (file)
--- a/attr.spec
+++ b/attr.spec
@@ -1,45 +1,49 @@
 Summary:       Utility for managing filesystem extended attributes
-Summary(pl):   Narzêdzia do zarz±dzania rozszerzonymi atrybutami fs
+Summary(pl):   Narzêdzia do zarz±dzania rozszerzonymi atrybutami systemu plików
 Name:          attr
-Version:       2.0.7
+Version:       2.4.13
 Release:       1
+# most part is on LGPL v2.1, but the rest enforces GPL
 License:       GPL
 Group:         Applications/System
 Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
+# Source0-md5: 3a68ebd892976e732c4fca96a62db885
 Patch0:                %{name}-miscfix.patch
 URL:           http://oss.sgi.com/projects/xfs/
 BuildRequires: autoconf
-BuildRequires: e2fsprogs-devel
-BuildRequires: xfsprogs-devel
+BuildRequires: automake
+BuildRequires: gettext-devel
+BuildRequires: xfsprogs-devel 
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _bindir         /bin
+%define                _libdir         /%{_lib}
+%define                _libexecdir     /usr/%{_lib}
 
 %description
 An experimental attr command to manipulate extended attributes under
 Linux.
 
 %description -l pl
-Eksperymentalne wersja polecenia attr to zarz±dzania rozszerzonymi
+Eksperymentalna wersja polecenia attr to zarz±dzania rozszerzonymi
 atrybutami pod systemem Linux.
 
 %package devel
 Summary:       Header files and libraries to use extended attributes
-Summary(pl):   Pliki nag³ówkowe i biblioteki
+Summary(pl):   Pliki nag³ówkowe i biblioteki do korzystania z rozszerzonych atrybutów
 Group:         Development/Libraries
 Requires:      %{name} = %{version}
 
 %description devel
-Header files and libraries to develop software which manipulate
-extended attributes.
+Header files to develop software which manipulate extended attributes.
 
 %description devel -l pl
-Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
-manipuluj±cego rozszerzonymi atrybutami.
+Pliki nag³ówkowe potrzebne do tworzenia oprogramowania manipuluj±cego
+rozszerzonymi atrybutami.
 
 %package static
 Summary:       Static libraries for extended attributes
-Summary(pl):   Biblioteki statyczne attr
+Summary(pl):   Biblioteki statyczne do korzystania z rozszerzonych atrybutów
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}
 
@@ -47,37 +51,44 @@ Requires:   %{name}-devel = %{version}
 Static libraries for extended attributes.
 
 %description static -l pl
-Biblioteki statyczne attr.
+Biblioteki statyczne do korzystania z rozszerzonych atrybutów.
 
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
 
 %build
-DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
-autoconf
-%configure
+rm -f aclocal.m4
+%{__aclocal} -I m4
+%{__autoconf}
+%configure \
+       DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
+       OPTIMIZER="%{rpmcflags}"
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-DIST_ROOT="$RPM_BUILD_ROOT"
+DIST_ROOT=$RPM_BUILD_ROOT
 DIST_INSTALL=`pwd`/install.manifest
 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
 
-%{__make} install DIST_MANIFEST="$DIST_INSTALL"
-%{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
-%{__make} install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
+%{__make} install \
+       DIST_MANIFEST=$DIST_INSTALL
+%{__make} install-dev \
+       DIST_MANIFEST=$DIST_INSTALL_DEV
+%{__make} install-lib \
+       DIST_MANIFEST=$DIST_INSTALL_LIB
 
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
+rm -rf $RPM_BUILD_ROOT%{_mandir}/man2
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
-ln -sf /lib/libattr.so.1.0.0 $RPM_BUILD_ROOT%{_libdir}/libattr.so
+ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libattr.so.*.*.*) \
+        $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
 
 echo ".so attr_get.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
 echo ".so attr_list.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
@@ -85,7 +96,7 @@ echo ".so attr_multi.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
 echo ".so attr_set.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
 
-gzip -9nf doc/CHANGES
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -93,20 +104,20 @@ rm -rf $RPM_BUILD_ROOT
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc doc/*.gz
+%doc README doc/CHANGES
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) /lib/lib*.so.*.*
-%{_mandir}/man[18]/*
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%{_mandir}/man[158]/*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.la
-%attr(755,root,root) %{_libdir}/lib*.so
+%{_libexecdir}/lib*.la
+%attr(755,root,root) %{_libexecdir}/lib*.so
 %{_includedir}/attr
-%{_mandir}/man[23]/*
+%{_mandir}/man3/*
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libexecdir}/lib*.a
This page took 0.056125 seconds and 4 git commands to generate.