]> git.pld-linux.org Git - packages/atomic.git/blob - atomic.spec
- initial
[packages/atomic.git] / atomic.spec
1 Summary:        Atomic operations implementation
2 Name:           atomic
3 Version:        1.0.0
4 Release:        1
5 License:        GPL v2+
6 Group:          Development/Libraries
7 Source0:        http://www.ioremap.net/archive/libatomic/%{name}-%{version}.tar.gz
8 # Source0-md5:  e615316852011269e26f4cea8b1f0c8d
9 URL:            http://www.ioremap.net/projects/libatomic
10 BuildRequires:  gcc >= 4.1.0
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 Libatomic provides arch-independant API for the low-level atomic
15 implementation. Library supports x86 (both i386 and x86_64), PPC64,
16 Sparc64 (v9 and higher) and with modern gcc (version higher than
17 4.1.0) and its __sync extensions all its supported platforms.
18
19 %package devel
20 Summary:        Header files and develpment documentation for atomic
21 Group:          Development/Libraries
22 Requires:       %{name} = %{epoch}:%{version}-%{release}
23
24 %description devel
25 Header files and develpment documentation for atomic.
26
27 %package static
28 Summary:        Static atomic library
29 Group:          Development/Libraries
30 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
31
32 %description static
33 Static atomic library.
34
35 %prep
36 %setup -q
37
38 %build
39 %configure
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post -p /sbin/ldconfig
52 %postun -p /sbin/ldconfig
53
54 %files
55 %defattr(644,root,root,755)
56 %doc AUTHORS
57 %attr(755,root,root) %{_libdir}/libatomic.so.*.*
58 %attr(755,root,root) %ghost %{_libdir}/libatomic.so.0
59
60 %files devel
61 %defattr(644,root,root,755)
62 %{_includedir}/atomic
63 %attr(755,root,root) %{_libdir}/libatomic.so
64 %{_libdir}/libatomic.la
65
66 %files static
67 %defattr(644,root,root,755)
68 %{_libdir}/libatomic.a
This page took 0.045448 seconds and 3 git commands to generate.