]> git.pld-linux.org Git - packages/atmelwlandriver.git/commitdiff
- orphaned, outdated
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 21 Apr 2006 23:40:26 +0000 (23:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    atmelwlandriver-delay.patch -> 1.2
    atmelwlandriver-fpmath.patch -> 1.2
    atmelwlandriver-fucd-makefile.patch -> 1.2
    atmelwlandriver-usb_defctrl.patch -> 1.2
    atmelwlandriver.config -> 1.2

atmelwlandriver-delay.patch [deleted file]
atmelwlandriver-fpmath.patch [deleted file]
atmelwlandriver-fucd-makefile.patch [deleted file]
atmelwlandriver-usb_defctrl.patch [deleted file]
atmelwlandriver.config [deleted file]

diff --git a/atmelwlandriver-delay.patch b/atmelwlandriver-delay.patch
deleted file mode 100644 (file)
index 27f0946..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
-diff -uNr atmelwlandriver/src/usb.orig/reset_device.c atmelwlandriver/src/usb/reset_device.c
---- atmelwlandriver/src/usb.orig/reset_device.c        2004-06-05 06:11:18.000000000 +0200
-+++ atmelwlandriver/src/usb/reset_device.c     2004-07-18 23:50:44.597568680 +0200
-@@ -21,6 +21,7 @@
- #include "vnetusba.h"
- #include "hub.h"
- #include "hcd.h"
-+#include <linux/delay.h>
- #include "linux/device.h"
- static DECLARE_MUTEX(usb_address0_sem);
-@@ -551,7 +552,7 @@
-                       delay_time < HUB_RESET_TIMEOUT;
-                       delay_time += delay) {
-               /* wait to give the device a chance to reset */
--              wait_ms(delay);
-+              mdelay(delay);
-               /* read and decode port status */
-               ret = __hub_port_status(hub, port, &portstatus, &portchange);
-@@ -1057,7 +1058,7 @@
-                       if (retval >= 0)
-                               break;
-                     printk(KERN_INFO "TON PINOUME EDW1\n");
--                      wait_ms(200);
-+                      mdelay(200);
-                 }
-               if (retval < 0) {
-                     printk(KERN_INFO "TON PINOUME EDW2\n");
-@@ -1080,14 +1081,14 @@
-                * FIXME assumes device->descriptor cacheline is dma-coherent
-                * and so does usb_get_device_descriptor
-                */
--              wait_ms(10);
-+              mdelay(10);
-                     printk(KERN_INFO "TON PINOUME EDW4\n");
-               retval = usb_get_descriptor(dev, USB_DT_DEVICE, 0,
-                               &dev->descriptor, 8);
-                     printk(KERN_INFO "TON PINOUME EDW5\n");
-               if (retval >= 8)
-                       break;
--              wait_ms(100);
-+              mdelay(100);
-       }
-       if (retval != 8) {
-               dev_err(&dev->dev, "device descriptor read/%s, error %d\n",
-@@ -1213,7 +1214,7 @@
-       }
-       /* Let the SET_ADDRESS settle */
--      wait_ms(10);
-+      mdelay(10);
-       up(&usb_address0_sem);
-diff -uNr atmelwlandriver/src/usb.orig/vnet.c atmelwlandriver/src/usb/vnet.c
---- atmelwlandriver/src/usb.orig/vnet.c        2004-06-05 06:11:18.000000000 +0200
-+++ atmelwlandriver/src/usb/vnet.c     2004-07-18 23:50:29.620845488 +0200
-@@ -20,6 +20,7 @@
- **************************************************************************************/
- #include "vnetusba.h"
-+#include <linux/delay.h>
- #include <linux/wireless.h>
- #include "command.h"
- #include "rx.h"
-@@ -622,7 +623,7 @@
-               if (pTxList->status & UNDER_SUBMIT) {
-                       dbgcond(DBG_TX, "tx packet %p dropped\n", pTxList);
--                      wait_ms(10);
-+                      mdelay(10);
-                       pTxList->status &= ~UNDER_SUBMIT;       /* jal: shall we inform USB somehow ??? */
-               }
-diff -uNr atmelwlandriver/src/usb.orig/vnetusba.c atmelwlandriver/src/usb/vnetusba.c
---- atmelwlandriver/src/usb.orig/vnetusba.c    2004-07-18 23:27:40.000000000 +0200
-+++ atmelwlandriver/src/usb/vnetusba.c 2004-07-18 23:49:34.409238928 +0200
-@@ -1320,9 +1320,6 @@
- static void __exit usb_vnet_exit(void)
- {
--#if (LINUX_VERSION_CODE < 0x020500)
--      wait_ms(250);           //wait for call_usermodehelper to finish.
--#endif
-       //printk("AtmelWlanDriver Is deregistered!\n");
-       usb_deregister(&vnet_driver);
- }
diff --git a/atmelwlandriver-fpmath.patch b/atmelwlandriver-fpmath.patch
deleted file mode 100644 (file)
index e2d2cab..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
---- atmelwlandriver/src/usb/vnetusba.c.orig    2004-06-05 06:11:18.000000000 +0200
-+++ atmelwlandriver/src/usb/vnetusba.c 2004-07-18 23:11:38.302259784 +0200
-@@ -702,19 +702,19 @@
-               wrq->u.bitrate.fixed = 0;
-               switch (Adapter->TxRate) {
-               case 0:
--                      wrq->u.bitrate.value = 1e6;
-+                      wrq->u.bitrate.value = 1000000;
-                       break;
-               case 1:
--                      wrq->u.bitrate.value = 2e6;
-+                      wrq->u.bitrate.value = 2000000;
-                       break;
-               case 2:
--                      wrq->u.bitrate.value = 5.5e6;
-+                      wrq->u.bitrate.value = 5500000;
-                       break;
-               case 3:
--                      wrq->u.bitrate.value = 11e6;
-+                      wrq->u.bitrate.value = 11000000;
-                       break;
-               default:
--                      wrq->u.bitrate.value = 2e9;
-+                      wrq->u.bitrate.value = 2000000000;
-                       break;
-               }
-               break;
-@@ -768,14 +768,14 @@
-                       ChangeConfiguration(Adapter, &DevConfig);
-                       return 0;
-               }
--              if ((wrq->u.bitrate.value / 1e6) > 2) {
--                      if ((wrq->u.bitrate.value / 1e6) > 6)
-+              if ((wrq->u.bitrate.value / 1000000) > 2) {
-+                      if ((wrq->u.bitrate.value / 1000000) > 6)
-                               DevConfig.TxRate = 3;
-                       else
-                               DevConfig.TxRate = 2;
-               } else
-                       DevConfig.TxRate =
--                          (wrq->u.bitrate.value / 1e6) - 1;
-+                          (wrq->u.bitrate.value / 1000000) - 1;
-               ChangeConfiguration(Adapter, &DevConfig);
-               break;
-       case SIOCSIWESSID:      //ESSID change
---- atmelwlandriver/src/Pcmcia_Pci/fastvnet_cs.c.orig  2004-06-05 06:11:18.000000000 +0200
-+++ atmelwlandriver/src/Pcmcia_Pci/fastvnet_cs.c       2004-07-18 23:24:29.586006832 +0200
-@@ -1570,19 +1570,19 @@
-       switch (Adapter->DataFramesTxRate)
-       {
-       case 0:
--        wrq->u.bitrate.value = 1e6;
-+        wrq->u.bitrate.value = 1000000;
-         break;
-       case 1:
--        wrq->u.bitrate.value = 2e6;
-+        wrq->u.bitrate.value = 2000000;
-         break;
-       case 2:
--        wrq->u.bitrate.value = 5.5e6;
-+        wrq->u.bitrate.value = 5500000;
-         break;
-       case 3:
--        wrq->u.bitrate.value = 11e6;
-+        wrq->u.bitrate.value = 11000000;
-         break;
-       default:
--        wrq->u.bitrate.value = 2e9;
-+        wrq->u.bitrate.value = 2000000000;
-         break;
-       }
-       break;
-@@ -1614,15 +1614,15 @@
-         EnableInterrupts (Adapter);
-         return 0;
-       }
--      if ((wrq->u.bitrate.value / 1e6) > 2)
-+      if ((wrq->u.bitrate.value / 1000000) > 2)
-       {
--        if ((wrq->u.bitrate.value / 1e6) > 6)
-+        if ((wrq->u.bitrate.value / 1000000) > 6)
-           DevConfig.TxRate = 3;
-         else
-           DevConfig.TxRate = 2;
-       }
-       else
--      DevConfig.TxRate = (wrq->u.bitrate.value / 1e6) - 1;
-+      DevConfig.TxRate = (wrq->u.bitrate.value / 1000000) - 1;
-       ChangeConfiguration (Adapter, &DevConfig);
-       break;
-     case SIOCSIWENCODE:
diff --git a/atmelwlandriver-fucd-makefile.patch b/atmelwlandriver-fucd-makefile.patch
deleted file mode 100644 (file)
index f04e7ec..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
---- atmelwlandriver/src/apps/fw-upgrade/Makefile.orig  2004-08-12 22:31:50.000000000 +0200
-+++ atmelwlandriver/src/apps/fw-upgrade/Makefile       2004-08-12 22:34:26.000000000 +0200
-@@ -3,10 +3,10 @@
- #########################################
--CC:=$(shell wx-config --cxx)
-+CC:=$(shell wxgtk-2.4-config --cxx)
- CCC:=gcc
--CFLAGS:=$(shell wx-config --cxxflags) 
--CFLAGS1:=$(shell wx-config --libs)
-+CFLAGS:=$(OPT) $(shell wxgtk-2.4-config --cxxflags) 
-+CFLAGS1:=$(OPT) $(shell wxgtk-2.4-config --libs)
- CCFLAGS:=$(OPT)
- OUTDIR:="/usr/local/bin"
-@@ -34,7 +34,7 @@
- wxconfig:
-       @config_exists=no;\
-       for path_dir in `echo $(PATH) | tr : ' '`; do\
--        if test -f $$path_dir/wx-config; then\
-+        if test -f $$path_dir/wxgtk-2.4-config; then\
-           config_exists=yes;\
-         fi\
-       done;\
diff --git a/atmelwlandriver-usb_defctrl.patch b/atmelwlandriver-usb_defctrl.patch
deleted file mode 100644 (file)
index 4961dd5..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- atmelwlandriver/src/usb/reset_device.c.orig        2004-07-18 23:50:44.000000000 +0200
-+++ atmelwlandriver/src/usb/reset_device.c     2004-07-19 00:04:03.736081160 +0200
-@@ -24,6 +24,9 @@
- #include <linux/delay.h>
- #include "linux/device.h"
-+#define usb_snddefctrl(dev)   ((PIPE_CONTROL << 30) | __create_pipe(dev,0))
-+#define usb_rcvdefctrl(dev)   ((PIPE_CONTROL << 30) | __create_pipe(dev,0) | USB_DIR_IN)
-+
- static DECLARE_MUTEX(usb_address0_sem);
- static inline struct device *hubdev (struct usb_device *dev)
diff --git a/atmelwlandriver.config b/atmelwlandriver.config
deleted file mode 100644 (file)
index 0f320cf..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-#PCMCIA Drivers
-CONFIG_WPA=y
-CONFIG_PCMCIA_502A=y
-CONFIG_PCMCIA_3COM=y
-CONFIG_PCMCIA_502AD=y
-CONFIG_PCMCIA_502AE=y
-CONFIG_PCMCIA_504=y
-CONFIG_PCMCIA_504_2958=y
-CONFIG_PCMCIA_504A_2958=y
-
-CONFIG_PCI_506=y
-
-#USB Drivers
-CONFIG_USB_503A_RFMD=y
-CONFIG_USB_505=y
-CONFIG_USB_505A=y
-CONFIG_USB_505_2958=y
-
-#Applications Configuration
-CONFIG_CMD_LINE=y
-CONFIG_Winter=y
-CONFIG_XAPP=y
-
-#DEBUG INFORMATION
-#DEBUG=D
-#CONFIG_MODVERSIONS=y
-HAS_FORMS = y
-PCMCIA_CONFIG = /etc/pcmcia
-USB_CONFIG = /etc/hotplug
-
-
This page took 0.090748 seconds and 4 git commands to generate.