]> git.pld-linux.org Git - packages/atmelwlandriver.git/blobdiff - atmelwlandriver.spec
- all userspace fixed
[packages/atmelwlandriver.git] / atmelwlandriver.spec
index 9faf4d6dd844746b117fbe578f0d0e2ab61dbb0c..46cb77c82a01787013decff374d142c4308b5899 100644 (file)
@@ -3,6 +3,7 @@
 %bcond_without dist_kernel     # allow non-distribution kernel
 %bcond_without kernel          # don't build kernel modules
 %bcond_without smp             # don't build SMP modules
+%bcond_with    unicode         # use wx-gtk2-unicode-config instead of ansi
 %bcond_without userspace       # don't build userspace applications
 %bcond_with    verbose         # verbose build (V=1)
 
 Summary:       Linux driver for WLAN card based on AT76C5XXx
 Summary(pl):   Sterownik dla Linuksa do kart WLAN opartych na ukĀ³adach AT76C5XXx
 Name:          atmelwlandriver
-Version:       3.4.1.0
-%define                _rel    0.1
+Version:       3.4.1.1
+%define                _rel    0.9
 Release:       %{_rel}@%{_kernel_ver_str}
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://dl.sourceforge.net/atmelwlandriver/%{name}-%{version}.tar.bz2
-# Source0-md5: 288882c65cc13fbe48d5c5ed69aba1a8
+# Source0-md5: 6cb3671091c7ccaa646222c50ee242c9
 Source1:       %{name}-vnetrc
 Patch0:                %{name}-makefile.patch
 Patch1:                %{name}-etc.patch
 Patch2:                %{name}-usb-api.patch
 Patch3:                %{name}-gcc4.patch
 Patch4:                %{name}-winter-makefile.patch
+Patch5:                %{name}-fwupgrade.patch
+Patch6:                %{name}-cmdline.patch
 #Patch2:               %{name}-fpmath.patch
 #Patch3:               %{name}-delay.patch
 #Patch4:               %{name}-usb_defctrl.patch
@@ -41,8 +44,12 @@ BuildRequires:       rpmbuild(macros) >= 1.217
 BuildRequires: libusb-devel
 BuildRequires: ncurses-devel
 BuildRequires: ncurses-ext-devel
-BuildRequires: wxWindows-devel >= 2.4.0
-BuildRequires: wxGTK2-devel >= 2.4.0
+BuildRequires: wxGTK2-devel >= 2.6.0
+%if %{with unicode}
+BuildRequires: wxWidgets-unicode-devel >= 2.6.0
+%else
+BuildRequires: wxWidgets-devel >= 2.6.0
+%endif
 %endif
 Requires:      wireless-tools
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -149,12 +156,14 @@ Narz
 kart ATMELa.
 
 %prep
-%setup -q -n atmelwlandriver
+%setup -q -n %{name}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 %build
 ln -sf Makefile.kernelv2.6 Makefile
@@ -194,17 +203,21 @@ done
 
 %if %{with userspace}
 %{__make} winter \
-       OPT="%{rpmcflags}"
+       OPT="%{rpmcflags}" \
+       WXCONFIG="wx-gtk2-%{?with_uncide:unicode}%{!?with_unicode:ansi}-config"
 
 %{__make} lvnet \
-       OPT="%{rpmcflags} %{rpmldflags}"
+       OPT="%{rpmcflags} %{rpmldflags}" \
+       INCDIR=%{_includedir}
 
 %{__make} -C src/apps/fw-upgrade atmelup \
-       CCC=%{__cc} \
-       CCFLAGS="%{rpmcflags}"
+       CCC="%{__cc}" \
+       CCFLAGS="%{rpmcflags}" \
+       WXCONFIG="wx-gtk2-%{?with_uncide:unicode}%{!?with_unicode:ansi}-config"
 
 %{__make} -C src/apps/fw-upgrade fucd \
-       OPT="%{rpmcflags}"
+       OPT="%{rpmcflags}" \
+       WXCONFIG="wx-gtk2-%{?with_uncide:unicode}%{!?with_unicode:ansi}-config"
 %endif
 
 %install
@@ -279,8 +292,8 @@ rm -rf $RPM_BUILD_ROOT
 %files -n kernel-net-atmelwlandriver
 %defattr(644,root,root,755)
 %doc CHANGES README
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pcmcia/atmel.conf
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vnetrc
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pcmcia/atmel.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vnetrc
 %attr(755,root,root) %{_sbindir}/fastvnet.sh
 /lib/modules/%{_kernel_ver}/kernel/drivers/net/pcmcia/*.ko*
 /lib/modules/%{_kernel_ver}/kernel/drivers/usb/net/*.ko*
@@ -289,8 +302,8 @@ rm -rf $RPM_BUILD_ROOT
 %files -n kernel-smp-net-atmelwlandriver
 %defattr(644,root,root,755)
 %doc CHANGES README
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pcmcia/atmel.conf
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vnetrc
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pcmcia/atmel.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vnetrc
 %attr(755,root,root) %{_sbindir}/fastvnet.sh
 /lib/modules/%{_kernel_ver}smp/kernel/drivers/net/pcmcia/*.ko*
 /lib/modules/%{_kernel_ver}smp/kernel/drivers/usb/net/*.ko*
This page took 0.039481 seconds and 4 git commands to generate.