]> git.pld-linux.org Git - packages/atermlib.git/blob - atermlib.spec
BR: pkgconfig
[packages/atermlib.git] / atermlib.spec
1 Summary:        The ATerm Library
2 Name:           atermlib
3 Version:        2.5
4 Release:        1
5 License:        LGPL
6 Group:          Development
7 Source0:        http://ftp.strategoxt.org/pub/stratego/StrategoXT/strategoxt-0.17/aterm-%{version}.tar.gz
8 # Source0-md5:  33ddcb1a229baf406ad1f603eb1d5995
9 Patch0:         https://svn.nixos.org/repos/nix/nixpkgs/trunk/pkgs/development/libraries/aterm/max-long.patch
10 # Patch0-md5:   0c7e50b3686a079959e7c978af9444db
11 Patch1:         strdup.patch
12 URL:            http://www.cwi.nl/htbin/sen1/twiki/bin/view/SEN1/ATermLibrary
13 BuildRequires:  pkgconfig
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %undefine       __cxx
17
18 %description
19 ATerm (short for Annotated Term) is an abstract data type designed for
20 the exchange of tree-like data structures between distributed
21 applications.
22
23 The ATerm library forms a comprehensive procedural interface which
24 enables creation and manipulation of ATerms in C and Java. The ATerm
25 implementation is based on maximal subterm sharing and automatic
26 garbage collection.
27
28 A binary exchange format for the concise representation of ATerms
29 (sharing preserved) allows the fast exchange of ATerms between
30 applications. In a typical application---parse trees which contain
31 considerable redundant information---less than 2 bytes are needed to
32 represent a node in memory, and less than 2 bits are needed to
33 represent it in binary format. The implementation of ATerms scales up
34 to the manipulation of ATerms in the giga-byte range.
35
36 Programming
37
38 The ATerm library provides a comprehensive interface in C and Java to
39 handle the annotated term data-type in an efficient manner. If the
40 terms you handle are limited to a specific signature, you can use
41 ApiGen to generate typed interfaces to the same ATerms.
42
43 %prep
44 %setup -q -n aterm-%{version}
45 %patch0 -p1
46 %patch1 -p1
47
48 %build
49 CFLAGS="%{rpmcflags} -D__NO_CTYPE"
50 %configure \
51         --disable-static
52 %{__make} -j1
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %{__make} install \
57         INSTALL="install -p" \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libATerm.la
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %attr(755,root,root) %{_bindir}/atdiff
68 %attr(755,root,root) %{_bindir}/atrmannos
69 %attr(755,root,root) %{_bindir}/atsum
70 %attr(755,root,root) %{_bindir}/baf2taf
71 %attr(755,root,root) %{_bindir}/baf2trm
72 %attr(755,root,root) %{_bindir}/baffle
73 %attr(755,root,root) %{_bindir}/dicttoc
74 %attr(755,root,root) %{_bindir}/taf2baf
75 %attr(755,root,root) %{_bindir}/taf2trm
76 %attr(755,root,root) %{_bindir}/termsize
77 %attr(755,root,root) %{_bindir}/trm2baf
78 %attr(755,root,root) %{_bindir}/trm2taf
79 %attr(755,root,root) %{_bindir}/trmcat
80 %{_includedir}/abool.h
81 %{_includedir}/afun.h
82 %{_includedir}/aterm1.h
83 %{_includedir}/aterm2.h
84 %{_includedir}/atypes.h
85 %{_includedir}/deprecated.h
86 %{_includedir}/encoding.h
87 %attr(755,root,root) %{_libdir}/libATerm.so
88 %{_pkgconfigdir}/aterm.pc
This page took 0.06282 seconds and 3 git commands to generate.