]> git.pld-linux.org Git - packages/at.git/commitdiff
Sources .. PATCH
authorwojtek <wojtek@pld.org.pl>
Tue, 9 Feb 1999 11:53:06 +0000 (11:53 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    at-install.patch -> 1.1
    at-lockfile.patch -> 1.1
    at-man.patch -> 1.1

at-install.patch [new file with mode: 0644]
at-lockfile.patch [new file with mode: 0644]
at-man.patch [new file with mode: 0644]

diff --git a/at-install.patch b/at-install.patch
new file mode 100644 (file)
index 0000000..a032d88
--- /dev/null
@@ -0,0 +1,58 @@
+diff -Nur at-3.1.8/Makefile.in at-3.1.8.pld/Makefile.in
+--- at-3.1.8/Makefile.in       Sun Sep 28 22:00:38 1997
++++ at-3.1.8.pld/Makefile.in   Thu Dec 31 12:29:41 1998
+@@ -87,35 +87,33 @@
+       $(CC) -c $(CFLAGS) $(DEFS) $*.c
+ install: all
+-      $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(etcdir)
+-      $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(bindir)
+-      $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(sbindir)
+-      $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(docdir)
+-      $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(atdocdir)
++      $(INSTALL) -m 755 -d $(IROOT)$(etcdir)
++      $(INSTALL) -m 755 -d $(IROOT)$(bindir)
++      $(INSTALL) -m 755 -d $(IROOT)$(sbindir)
++      $(INSTALL) -m 755 -d $(IROOT)$(docdir)
++      $(INSTALL) -m 755 -d $(IROOT)$(atdocdir)
+       $(INSTALL) -m 755 -d $(IROOT)$(ATJOB_DIR)
+-      $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 755 -d $(IROOT)$(ATSPOOL_DIR)
++      $(INSTALL) -m 755 -d $(IROOT)$(ATSPOOL_DIR)
+       chmod 700 $(IROOT)$(ATJOB_DIR) $(IROOT)$(ATSPOOL_DIR)
+-      chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(IROOT)$(ATJOB_DIR) $(IROOT)$(ATSPOOL_DIR)
+       touch $(IROOT)$(LFILE)
+       chmod 600 $(IROOT)$(LFILE)
+-      chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(IROOT)$(LFILE)
+-      test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) -o root -m 600 at.deny $(IROOT)$(etcdir)/
+-      $(INSTALL) -g root -o root -m 4755 -s at $(IROOT)$(bindir)
++      test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) -m 600 at.deny $(IROOT)$(etcdir)/
++      $(INSTALL) -m 4755 -s at $(IROOT)$(bindir)
+       $(LN_S) -f at $(IROOT)$(bindir)/atq
+       $(LN_S) -f at $(IROOT)$(bindir)/atrm
+-      $(INSTALL) -g root -o root -m 755 batch $(IROOT)$(bindir)
+-      $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man1dir)
+-      $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man5dir)
+-      $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man8dir)
+-      $(INSTALL) -g root -o root -m 755 -s atd $(IROOT)$(sbindir)
+-      $(INSTALL) -g root -o root -m 755 atrun $(IROOT)$(sbindir)
+-      $(INSTALL) -g root -o root -m 644 at.1 $(IROOT)$(man1dir)/
++      $(INSTALL) -m 755 batch $(IROOT)$(bindir)
++      $(INSTALL) -m 755 -d $(IROOT)$(man1dir)
++      $(INSTALL) -m 755 -d $(IROOT)$(man5dir)
++      $(INSTALL) -m 755 -d $(IROOT)$(man8dir)
++      $(INSTALL) -m 755 -s atd $(IROOT)$(sbindir)
++      $(INSTALL) -m 755 atrun $(IROOT)$(sbindir)
++      $(INSTALL) -m 644 at.1 $(IROOT)$(man1dir)/
+       cd $(IROOT)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1
+-      $(INSTALL) -g root -o root -m 644 atd.8 $(IROOT)$(man8dir)/
+-      $(INSTALL) -g root -o root -m 644 atrun.8 $(IROOT)$(man8dir)/
+-      $(INSTALL) -g root -o root -m 644 at_allow.5 $(IROOT)$(man5dir)/
++      $(INSTALL) -m 644 atd.8 $(IROOT)$(man8dir)/
++      $(INSTALL) -m 644 atrun.8 $(IROOT)$(man8dir)/
++      $(INSTALL) -m 644 at_allow.5 $(IROOT)$(man5dir)/
+       cd $(IROOT)$(man5dir) && $(LN_S) -f at_allow.5 at_deny.5 
+-      $(INSTALL) -g root -o root -m 644 $(DOCS) $(IROOT)$(atdocdir)
++      $(INSTALL) -m 644 $(DOCS) $(IROOT)$(atdocdir)
+       rm -f $(IROOT)$(mandir)/cat1/at.1* $(IROOT)$(mandir)/cat1/batch.1* \
+               $(IROOT)$(mandir)/cat1/atq.1*
+       rm -f $(IROOT)$(mandir)/cat1/atd.8*
diff --git a/at-lockfile.patch b/at-lockfile.patch
new file mode 100644 (file)
index 0000000..9ded2a7
--- /dev/null
@@ -0,0 +1,12 @@
+diff -Nur at-3.1.8/at.c at-3.1.8.pld/at.c
+--- at-3.1.8/at.c      Sun Sep 28 22:00:37 1997
++++ at-3.1.8.pld/at.c  Thu Dec 31 11:31:39 1998
+@@ -199,7 +199,7 @@
+       fscanf(fid, "%5lx", &jobno);
+       rewind(fid);
+     } else {
+-      fid = fopen(ATJOB_DIR "/.SEQ", "w");
++      fid = fopen(LFILE, "w");
+       if (fid == NULL)
+           return EOF;
+     }
diff --git a/at-man.patch b/at-man.patch
new file mode 100644 (file)
index 0000000..bf614b0
--- /dev/null
@@ -0,0 +1,80 @@
+diff -Nur at-3.1.8/at.1.in at-3.1.8.pld/at.1.in
+--- at-3.1.8/at.1.in   Sun Sep 28 22:00:38 1997
++++ at-3.1.8.pld/at.1.in       Thu Dec 31 11:49:43 1998
+@@ -117,7 +117,7 @@
+ .B at 1am tomorrow.
+ .PP
+ The exact definition of the time specification can be found in
+-.IR @prefix@/doc/at/timespec .
++.IR /usr/doc/at-3.1.8/timespec .
+ .PP
+ For both
+ .BR at " and " batch ,
+diff -Nur at-3.1.8/at_allow.5 at-3.1.8.pld/at_allow.5
+--- at-3.1.8/at_allow.5        Sun Sep 28 22:00:38 1997
++++ at-3.1.8.pld/at_allow.5    Thu Dec 31 11:52:46 1998
+@@ -4,9 +4,9 @@
+ at.acess, at.deny \- determine who can submit jobs via at or batch
+ .SH DESCRIPTION
+ The
+-.I /etc/at.access
++.I /etc/at/at.access
+ and
+-.I /etc/at.deny
++.I /etc/at/at.deny
+ files determine which user can submit commands for later execution via
+ .B at(1)
+ or
+@@ -19,14 +19,14 @@
+ .BR at .
+ .PP
+ If the file
+-.I /etc/at.allow
++.I /etc/at/at.allow
+ exists, only usernames mentioned in it are allowed to use
+ .BR at .
+ .PP
+ If
+-.I /etc/at.allow
++.I /etc/at/at.allow
+ does not exist,
+-.I /etc/at.deny
++.I /etc/at/at.deny
+ is checked.
+ .SH "SEE ALSO"
+ at(1), atrun(1), cron(1), crontab(1), atd(8)
+diff -Nur at-3.1.8/atd.8.in at-3.1.8.pld/atd.8.in
+--- at-3.1.8/atd.8.in  Sun Sep 28 22:00:38 1997
++++ at-3.1.8.pld/atd.8.in      Thu Dec 31 11:53:59 1998
+@@ -44,7 +44,7 @@
+ A script invoking
+ .B "atd -s"
+ is installed as
+-.B @prefix@/sbin/atrun
++.B /usr/sbin/atrun
+ for backward compatibility.
+ .SH FILES
+ .I @ATJBD@
+@@ -55,8 +55,8 @@
+ The direcotry for storing output; this should be mode 700, owner
+ @DAEMON_USERNAME@.
+ .PP
+-.IR /etc/at.allow ,
+-.IR /etc/at.deny
++.IR /etc/at/at.allow ,
++.IR /etc/at/at.deny
+ determine who can use the
+ .B at
+ system.
+diff -Nur at-3.1.8/atrun.8.in at-3.1.8.pld/atrun.8.in
+--- at-3.1.8/atrun.8.in        Sun Sep 28 22:00:38 1997
++++ at-3.1.8.pld/atrun.8.in    Thu Dec 31 11:54:28 1998
+@@ -12,7 +12,7 @@
+ runs jobs queued by
+ .BR at(1) .
+ It is a shell script containing invoking
+-.B @sbindir@/atd
++.B /usr/sbin/atd
+ with the
+ .I -s
+ option, and is provided for backward compatibility with older
This page took 0.051558 seconds and 4 git commands to generate.