]> git.pld-linux.org Git - packages/at.git/blob - at.spec
- fixed requires (PR#25)
[packages/at.git] / at.spec
1 Summary:        at job spooler
2 Summary(de):    at-Job-Spooler
3 Summary(fr):    Gestionnaire de taches at.
4 Summary(pl):    Demon kontroli zadañ
5 Summary(tr):    þ düzenleyici
6 Name:           at
7 Version:        3.1.8
8 Release:        8
9 Copyright:      GPL
10 Group:          Daemons
11 Group(pl):      Serwery
12 Url:            ftp://jurix.jura.uni-sb.de/pub/linux/sources/system/daemons
13 Source0:        %{name}-%{version}.tar.gz
14 Source1:        atd.init
15 Source2:        at.sysconfig
16 Patch0:         at-lockfile.patch
17 Patch1:         at-install.patch
18 Patch2:         at-man.patch
19 Patch3:         at.patch
20 Prereq:         fileutils
21 Prereq:         /sbin/chkconfig
22 Requires:       mailx
23 Requires:       rc-scripts
24 Buildroot:      /tmp/%{name}-%{version}-root
25
26 %description
27 at and batch read commands from standard input or a specified file
28 which are to be executed at a later time, using /bin/sh.
29
30 %description -l de
31 Stapelverarbeitung von Lesebefehlen von einer Standard- oder einer 
32 genannten Datei zu einem späteren Zeitpunkt unter Verwendung von /bin/sh.
33
34 %description -l fr
35 at et batch lisent, sur l'entrée standard ou dans un fichier, des
36 commandes qui doivent être exécutées plus tard en utilisant /bin/sh.
37
38 %description -l pl
39 At i batch czytaj± komendy ze standardowego wej¶cia lub specyficznego pliku,
40 które s± nastêpnie wykonywane o okre¶lonej godzinie, przy pomocy /bin/sh.
41
42 %description -l tr
43 at ve batch /bin/sh kabuðunu kullanarak, belli bir saatte çalýþtýrmak üzere
44 standart giriþden ya da bir dosyadan komut okur.
45
46 %prep
47 %setup -q
48 %patch0 -p1 
49 %patch1 -p1 
50 %patch2 -p1 
51 %patch3 -p1 
52
53 %build
54 aclocal && autoconf
55 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
56     ./configure \
57         --with-atspool=/var/spool/at/spool \
58         --with-jobdir=/var/spool/at \
59         --with-etcdir=/etc/at \
60         --with-daemon_username=root \
61         --with-daemon_groupname=root \
62         --mandir=%{_mandir} %{_target_platform}
63 make 
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
69
70 make \
71     IROOT=$RPM_BUILD_ROOT \
72     install
73
74 install at.deny $RPM_BUILD_ROOT/etc/at
75
76 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/atd
77 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/at
78
79 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{atq,atrm,batch}.1
80 rm -f $RPM_BUILD_ROOT%{_mandir}/man5/at_deny.5
81
82 echo .so at.1 > $RPM_BUILD_ROOT%{_mandir}/man1/atq.1
83 echo .so at.1 > $RPM_BUILD_ROOT%{_mandir}/man1/atrm.1
84 echo .so at.1 > $RPM_BUILD_ROOT%{_mandir}/man1/batch.1
85
86 echo .so at_allow.5 > $RPM_BUILD_ROOT%{_mandir}/man5/at_deny.5
87 echo .so at_allow.5 > $RPM_BUILD_ROOT%{_mandir}/man5/at_acces.5
88
89 touch $RPM_BUILD_ROOT/var/spool/at/.SEQ
90
91 gzip -9fn $RPM_BUILD_ROOT%{_mandir}/man[158]/* \
92         ChangeLog README
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post
98 /sbin/chkconfig --add atd
99 if [ -f /var/lock/subsys/atd ]; then
100         /etc/rc.d/init.d/atd restart >&2
101 else
102         echo "Run \"/etc/rc.d/init.d/atd start\" to start atd daemon."
103 fi
104
105 %preun
106 if [ "$1" = "0" ] ; then
107         /sbin/chkconfig --del atd
108         /etc/rc.d/init.d/atd stop >&2
109 fi
110
111 %files
112 %defattr(644,root,root,755) 
113 %doc {ChangeLog,README}.gz
114
115 %attr(750,root,root) %dir /etc/at
116 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/at/*
117 %attr(640,root,root) %config %verify(not size mtime md5) /etc/sysconfig/*
118
119 %attr(755,root,root) /etc/rc.d/init.d/atd
120 %attr(755,root,root) %{_sbindir}/*
121
122 %attr(4711,root,root) %{_bindir}/at
123
124 %attr(755,root,root) %{_bindir}/atq
125 %attr(755,root,root) %{_bindir}/atrm
126 %attr(755,root,root) %{_bindir}/batch
127
128 %{_mandir}/man[158]/*
129
130 %attr(750,root,root) %dir /var/spool/at
131 %attr(750,root,root) %dir /var/spool/at/spool
132 %attr(600,root,root) %ghost /var/spool/at/.SEQ
This page took 0.117773 seconds and 3 git commands to generate.