]> git.pld-linux.org Git - packages/at.git/blob - at.spec
misc changes for correct build and FHS 2.0
[packages/at.git] / at.spec
1 Summary:        at job spooler
2 Summary(de):    at-Job-Spooler
3 Summary(fr):    Gestionnaire de taches at.
4 Summary(pl):    Demon kontroli zadañ
5 Summary(tr):    þ düzenleyici
6 Name:           at
7 Version:        3.1.8
8 Release:        8
9 Copyright:      GPL
10 Group:          Daemons
11 Group(pl):      Serwery
12 Url:            ftp://jurix.jura.uni-sb.de/pub/linux/sources/system/daemons
13 Source0:        %{name}-%{version}.tar.gz
14 Source1:        atd.init
15 Source2:        at.sysconfig
16 Patch0:         at-lockfile.patch
17 Patch1:         at-install.patch
18 Patch2:         at-man.patch
19 Patch3:         at.patch
20 Prereq:         fileutils
21 Prereq:         /sbin/chkconfig
22 Requires:       mailx
23 Buildroot:      /tmp/%{name}-%{version}-root
24
25 %description
26 at and batch read commands from standard input or a specified file
27 which are to be executed at a later time, using /bin/sh.
28
29 %description -l de
30 Stapelverarbeitung von Lesebefehlen von einer Standard- oder einer 
31 genannten Datei zu einem späteren Zeitpunkt unter Verwendung von /bin/sh.
32
33 %description -l fr
34 at et batch lisent, sur l'entrée standard ou dans un fichier, des
35 commandes qui doivent être exécutées plus tard en utilisant /bin/sh.
36
37 %description -l pl
38 At i batch czytaj± komendy ze standardowego wej¶cia lub specyficznego pliku,
39 które s± nastêpnie wykonywane o okre¶lonej godzinie, przy pomocy /bin/sh.
40
41 %description -l tr
42 at ve batch /bin/sh kabuðunu kullanarak, belli bir saatte çalýþtýrmak üzere
43 standart giriþden ya da bir dosyadan komut okur.
44
45 %prep
46 %setup -q
47 %patch0 -p1 
48 %patch1 -p1 
49 %patch2 -p1 
50 %patch3 -p1 
51
52 %build
53 aclocal && autoconf
54 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
55     ./configure \
56         --with-atspool=/var/spool/at/spool \
57         --with-jobdir=/var/spool/at \
58         --with-etcdir=/etc/at \
59         --with-daemon_username=root \
60         --with-daemon_groupname=root \
61         --mandir=%{_mandir} %{_target_platform}
62 make 
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
68
69 make \
70     IROOT=$RPM_BUILD_ROOT \
71     install
72
73 install at.deny $RPM_BUILD_ROOT/etc/at
74
75 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/atd
76 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/at
77
78 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{atq,atrm,batch}.1
79 rm -f $RPM_BUILD_ROOT%{_mandir}/man5/at_deny.5
80
81 echo .so at.1 > $RPM_BUILD_ROOT%{_mandir}/man1/atq.1
82 echo .so at.1 > $RPM_BUILD_ROOT%{_mandir}/man1/atrm.1
83 echo .so at.1 > $RPM_BUILD_ROOT%{_mandir}/man1/batch.1
84
85 echo .so at_allow.5 > $RPM_BUILD_ROOT%{_mandir}/man5/at_deny.5
86 echo .so at_allow.5 > $RPM_BUILD_ROOT%{_mandir}/man5/at_acces.5
87
88 touch $RPM_BUILD_ROOT/var/spool/at/.SEQ
89
90 gzip -9fn $RPM_BUILD_ROOT%{_mandir}/man[158]/* \
91         ChangeLog README
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post
97 /sbin/chkconfig --add atd
98 if [ -f /var/lock/subsys/atd ]; then
99         /etc/rc.d/init.d/atd restart >&2
100 else
101         echo "Run \"/etc/rc.d/init.d/atd start\" to start atd daemon."
102 fi
103
104 %preun
105 if [ "$1" = "0" ] ; then
106         /sbin/chkconfig --del atd
107         /etc/rc.d/init.d/atd stop >&2
108 fi
109
110 %files
111 %defattr(644,root,root,755) 
112 %doc {ChangeLog,README}.gz
113
114 %attr(750,root,root) %dir /etc/at
115 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/at/*
116 %attr(640,root,root) %config %verify(not size mtime md5) /etc/sysconfig/*
117
118 %attr(755,root,root) /etc/rc.d/init.d/atd
119 %attr(755,root,root) %{_sbindir}/*
120
121 %attr(4711,root,root) %{_bindir}/at
122
123 %attr(755,root,root) %{_bindir}/atq
124 %attr(755,root,root) %{_bindir}/atrm
125 %attr(755,root,root) %{_bindir}/batch
126
127 %{_mandir}/man[158]/*
128
129 %attr(750,root,root) %dir /var/spool/at
130 %attr(750,root,root) %dir /var/spool/at/spool
131 %attr(600,root,root) %ghost /var/spool/at/.SEQ
132
133 %changelog
134 * Tue Jun 01 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
135 -  misc changes -- FHS 2.0 ready
136
137 * Sun May  9 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
138   [3.1.8-7]
139 - now package is FHS 2.0 compliant,
140 - recompiled on new rpm.
141
142 * Thu Mar 25 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
143   [3.1.7-6]
144 - added at.patch adopted from latest Debian source which fix man pages,
145   lex relayted bugs, displaing corectly dates in am/pm format and fiew
146   others,
147 - modifications %post, %preun for standarizing this section; this allow stop
148   service on uninstall and automatic restart on upgrade,
149 - changed permission (to more liberal).
150
151 * Sun Sep 13 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
152   [3.1.7-5d]
153 - build against glibc-2.1,
154 - translation modified for pl,
155 - fixed files permissions,
156 - macro %%{name}-%%{version} in Source,
157 - macro %%{name}-%%{version} in Patch,
158 - removed conflicts: crontabs <= 1.5,
159 - added %ghost /var/spool/at/.SEQ,
160 - added %defattr and %doc, 
161 - minor modifications of spec file.
162
163 * Thu Sep  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
164   [3.1.7-5]
165 - added -q %setup parameter,
166 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
167 - added using %%{name} and %%{version} in Source,
168 - added using $RPM_OPT_FLAGS during compile,
169 - atq(1), atrm(1), batch(1) man pages are now maked as nroff include to at(1)
170   instead making sym link to at.1 (this allow compress man pages in future),
171 - added using %{SOURCE#} macro in %install,
172 - smarter instaling %doc,
173 - changed permission on some executables.
174 - added %attr and %defattr macros in %files (allow build package from
175   non-root account),
176 - start at RH spec.
This page took 0.068684 seconds and 3 git commands to generate.