]> git.pld-linux.org Git - packages/at.git/blob - at.spec
- and next bunch fixes s/allow build package/allows build package/.
[packages/at.git] / at.spec
1 Summary:     at job spooler
2 Summary(de): at-Job-Spooler
3 Summary(fr): Gestionnaire de taches at.
4 Summary(tr): Ýþ düzenleyici
5 Name:        at
6 Version:     3.1.7
7 Release:     6
8 Copyright:   GPL
9 Group:       Daemons
10 Source0:     ftp://tsx-11.mit.edu/pub/linux/sources/usr.bin/at-3.1.7.tar.gz
11 Source1:     atd.init
12 Patch0:      at-3.1.7-lockfile.patch
13 Patch1:      at-3.1.7-paths.patch
14 Patch2:      at-makefile.patch
15 Buildroot:   /tmp/%{name}-%{version}-root
16 Prereq:      fileutils chkconfig
17
18 %description
19 at and batch read commands from standard input or a specified file
20 which are to be executed at a later time, using /bin/sh.
21
22 %description -l de
23 Stapelverarbeitung von Lesebefehlen von einer Standard- oder einer 
24 genannten Datei zu einem späteren Zeitpunkt unter Verwendung von /bin/sh.
25
26 %description -l fr
27 at et batch lisent, sur l'entrée standard ou dans un fichier, des
28 commandes qui doivent être exécutées plus tard en utilisant /bin/sh.
29
30 %description -l tr
31 at ve batch /bin/sh kabuðunu kullanarak, belli bir saatte çalýþtýrmak üzere
32 standart giriþden ya da bir dosyadan komut okur.
33
34 %prep
35 %setup -q
36 %patch0 -p1 -b .lockfile
37 # The next path is a brute-force fix that will have to be updated
38 # when new versions of at are released.
39 %patch1 -p1 -b .paths
40 %patch2 -p1 -b .makefile
41
42 %build
43 CFLAGS=$RPM_OPT_FLAGS ./configure \
44         --with-atspool=/var/spool/at/spool \
45         --with-jobdir=/var/spool/at
46 make
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
51
52 make install IROOT=$RPM_BUILD_ROOT
53
54 echo > $RPM_BUILD_ROOT/etc/at.deny
55 mv $RPM_BUILD_ROOT/usr/doc/at $RPM_BUILD_ROOT/usr/doc/%{name}-%{version}
56
57 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/atd
58
59 rm -f $RPM_BUILD_ROOT/usr/man/man1/{atq,atrm,batch}.1
60 echo ".so at.1" > $RPM_BUILD_ROOT/usr/man/man1/atq.1
61 echo ".so at.1" > $RPM_BUILD_ROOT/usr/man/man1/atrm.1
62 echo ".so at.1" > $RPM_BUILD_ROOT/usr/man/man1/batch.1
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 touch /var/spool/at/.SEQ
69 chmod 600 /var/spool/at/.SEQ
70 chown daemon.daemon /var/spool/at/.SEQ
71 /sbin/chkconfig --add atd
72
73 %preun
74 if [ "$1" = 0 ] ; then
75   /sbin/chkconfig --del atd
76 fi
77
78 %files
79 %attr(644, root, root, 755) %doc /usr/doc/%{name}-%{version}
80 %attr(600, root, root) %config /etc/at.deny
81 %attr(500, root, root) %config /etc/rc.d/init.d/atd
82 %attr(500, root, root) /usr/sbin/*
83 %attr(4711, root, root) /usr/bin/at
84 %attr(   -, root, root) /usr/bin/atq
85 %attr(   -, root, root) /usr/bin/atrm
86 %attr(755, root, root) /usr/bin/batch
87 %attr(644, root,  man) /usr/man/man[18]/*
88 %attr(700, daemon, daemon) %dir /var/spool/at
89 %attr(700, daemon, daemon) %dir /var/spool/at/spool
90 %attr(600, daemon, daemon) %ghost /var/spool/at/.SEQ
91
92 %changelog
93 * Sat Nov 21 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
94   [3.1.7-6]
95 - removed "Conflicts: crontabs <= 1.5".
96
97 * Thu Sep  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
98   [3.1.7-5]
99 - added -q %setup parameter,
100 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
101 - added using %%{name} and %%{version} in Source,
102 - added using $RPM_OPT_FLAGS during compile,
103 - atq(1), atrm(1), batch(1) man pages are now maked as nroff include to at(1)
104   instead making sym link to at.1 (this allow compress man pages in future),
105 - added using %{SOURCE#} macro in %install,
106 - smarter instaling %doc,
107 - changed permission on some executables.
108 - added %attr and %defattr macros in %files (allows build package from
109   non-root account).
110
111 * Tue May 05 1998 Prospector System <bugs@redhat.com>
112 - translations modified for de, fr, tr
113
114 * Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
115 - enhanced initscript
116
117 * Sun Nov 09 1997 Michael K. Johnson <johnsonm@redhat.com>
118 - learned to spell
119
120 * Wed Oct 22 1997 Michael K. Johnson <johnsonm@redhat.com>
121 - updated to at version 3.1.7
122 - updated lock and sequence file handling with %ghost
123 - Use chkconfig and atd, now conflicts with old crontabs packages
124
125 * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
126 - built against glibc
This page took 0.031768 seconds and 3 git commands to generate.