]> git.pld-linux.org Git - packages/asymptote.git/blobdiff - asymptote.spec
Up to 2.23
[packages/asymptote.git] / asymptote.spec
index c18421d987a00968620548288893696baad37978..68c8f7d9f082eb40e6d5f449de124a63620b7f67 100644 (file)
@@ -2,26 +2,43 @@ Summary:      Asymptote is a powerful descriptive vector graphics language for techni
 Summary(hu.UTF-8):     Asymptote egy leíró vektorgrafikus nyelv technikai rajzokhoz
 Summary(pl.UTF-8):     Język opisu grafiki wektorowej do rysunków technicznych
 Name:          asymptote
-Version:       1.76
+Version:       2.23
 Release:       1
 License:       GPL v3
 Group:         Applications/Science
-Source0:       http://dl.sourceforge.net/asymptote/%{name}-%{version}.src.tgz
-# Source0-md5: a0932f65baaadb43b651dce64b58e795
+Source0:       http://downloads.sourceforge.net/asymptote/%{name}-%{version}.src.tgz
+# Source0-md5: b6e5a8e6c24e27eff42d5476072218bc
+Patch0:                %{name}-memrchr.patch
 URL:           http://asymptote.sourceforge.net/
+#BuildRequires:        Mesa-libglapi-devel
 BuildRequires: autoconf
+BuildRequires: fftw3-devel
 BuildRequires: gc-devel >= 7.0
+BuildRequires: gc-c++-devel >= 7.0
+BuildRequires: ghostscript
 BuildRequires: gsl-devel >= 1.7
+BuildRequires: libstdc++-devel
 BuildRequires: ncurses-devel
 BuildRequires: python
 BuildRequires: readline-devel
 BuildRequires: rpm-pythonprov
 BuildRequires: texinfo-texi2dvi
 BuildRequires: texlive-dvips
+BuildRequires: texlive-fonts-ams
+BuildRequires: texlive-format-pdflatex
 BuildRequires: texlive-latex
-BuildRequires: texlive-tex-babel
+BuildRequires: texlive-latex-ams
+#BuildRequires:        texlive-tex-babel
+BuildRequires: zlib-devel
+Suggests:      ImageMagick-coder-dot
+Suggests:      ImageMagick-coder-jpeg
+Suggests:      ImageMagick-coder-png
+# e.g. "label" command needs latex
+Suggests:      texlive-latex
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define texmfdist %{_datadir}/texmf-dist
+
 %description
 Asymptote is a powerful descriptive vector graphics language for
 technical drawing, inspired by MetaPost but with an improved C++-like
@@ -45,6 +62,7 @@ Summary(hu.UTF-8):    GUI asymptote-hoz
 Summary(pl.UTF-8):     Graficzny interfejs do asymptote
 Group:         Applications/Science
 Requires:      %{name} = %{version}-%{release}
+Requires:      python-tkinter
 
 %description gui
 GUI for asymptote.
@@ -106,6 +124,8 @@ Style LaTeXa.
 %package context
 Summary:       ConTeXt color macros
 Group:         Applications/Publishing/TeX
+Requires(post,postun): %{_bindir}/texhash
+Requires:      texlive-context
 
 %description context
 ConTeXt color macros.
@@ -123,23 +143,30 @@ Vim syntax fájl asy fájlokhoz.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__autoheader}
 %{__autoconf}
 %configure \
-       CPPFLAGS=-I/usr/include/gc \
-       --disable-static \
-       --enable-gc=%{_includedir}/gc \
+       --enable-gc \
        --with-docdir=%{_docdir}/%{name}-doc
-cd doc && for i in %{_datadir}/texmf/tex/texinfo/*; do ln -s $i; done && cd ..
 
+%ifarch ppc
+%{__make} asy
+%{__make} faq
+%else
 %{__make} all
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
+%ifarch ppc
+%{__make} install-asy \
+%else
 %{__make} install \
+%endif
        DESTDIR=$RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}
@@ -148,6 +175,13 @@ mv $RPM_BUILD_ROOT%{_docdir}/%{name}-doc/examples $RPM_BUILD_ROOT%{_examplesdir}
 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
 %{__mv} $RPM_BUILD_ROOT%{_datadir}/{asymptote/asy.vim,vim/vimfiles/syntax}
 %{__mv} $RPM_BUILD_ROOT%{_datadir}/texmf{,-dist}
+%{__mv} $RPM_BUILD_ROOT%{texmfdist}/tex/context/{third,}/asymptote
+%{__rm} -r $RPM_BUILD_ROOT%{texmfdist}/tex/context/third
+
+%ifnarch ppc
+%{__mv} $RPM_BUILD_ROOT%{_infodir}/{asymptote/*,}
+%{__rm} -r $RPM_BUILD_ROOT%{_infodir}/asymptote
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -161,10 +195,15 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README TODO BUGS
+%ifnarch ppc
+%{_infodir}/*.info*
+%endif
 %attr(755,root,root) %{_bindir}/asy
 %{_datadir}/%{name}
 %exclude %{_datadir}/%{name}/GUI
+%ifnarch ppc
 %{_mandir}/man1/asy.1*
+%endif
 
 %files gui
 %defattr(644,root,root,755)
@@ -172,11 +211,28 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/%{name}/GUI
 %attr(755,root,root) %{_datadir}/%{name}/GUI/xasy.py
 %{_datadir}/%{name}/GUI/[!x]*.py
+%{_datadir}/%{name}/GUI/xasy2asy.py
+%{_datadir}/%{name}/GUI/xasyActions.py
+%{_datadir}/%{name}/GUI/xasyBezierEditor.py
+%{_datadir}/%{name}/GUI/xasyCodeEditor.py
+%{_datadir}/%{name}/GUI/xasyColorPicker.py
+%{_datadir}/%{name}/GUI/xasyFile.py
+%{_datadir}/%{name}/GUI/xasyGUIIcons.py
+%{_datadir}/%{name}/GUI/xasyMainWin.py
+%{_datadir}/%{name}/GUI/xasyOptions.py
+%{_datadir}/%{name}/GUI/xasyOptionsDialog.py
+%{_datadir}/%{name}/GUI/xasyVersion.py
+%ifnarch ppc
 %{_mandir}/man1/xasy.1*
+%endif
 
+%ifarch ppc
+# What should we do?
+%else
 %files doc
 %defattr(644,root,root,755)
 %{_docdir}/%{name}-doc
+%endif
 
 %files examples
 %defattr(644,root,root,755)
@@ -184,11 +240,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files latex
 %defattr(644,root,root,755)
-%{_datadir}/texmf-dist/tex/latex/asymptote
+%{texmfdist}/tex/latex/asymptote
 
 %files context
 %defattr(644,root,root,755)
-%{_datadir}/texmf-dist/tex/context/third/asymptote/colo-asy.tex
+# should be in texlive.spec
+%dir %{texmfdist}/tex/context
+%{texmfdist}/tex/context/asymptote
 
 %files -n vim-syntax-asymptote
 %defattr(644,root,root,755)
This page took 0.086638 seconds and 4 git commands to generate.