]> git.pld-linux.org Git - packages/aspseek.git/blame - aspseek.spec
- converted to UTF-8
[packages/aspseek.git] / aspseek.spec
CommitLineData
08326d23
AM
1# TODO:
2# - split into indexer and client?
3# - running indexer from cron?
625d9c47 4%define apxs /usr/sbin/apxs
e92f949b 5Summary: Advanced Internet search engine
135253a1 6Summary(pl.UTF-8): Silnik zaawansowanej wyszukiwarki Internetowej
e92f949b
AM
7Name: aspseek
8Version: 1.2.8
0a4a4e9d 9Release: 7
e92f949b
AM
10License: GPL
11Group: Networking/Utilities
e92f949b 12Source0: http://www.aspseek.org/pkg/src/1.2.8/%{name}-%{version}.tar.gz
875aed1f 13# Source0-md5: 0660b6b0d45d37c7a53c7e1c40cae002
08326d23
AM
14Source1: %{name}-mod_aspseek.conf
15Source2: %{name}.init
cc648b24 16Patch0: %{name}-types.patch
e92f949b 17URL: http://www.aspseek.org/
08326d23 18BuildRequires: apache(EAPI)-devel
e92f949b 19BuildRequires: libstdc++-devel
7e7033d7 20BuildRequires: mysql-devel
21BuildRequires: openssl-devel >= 0.9.7d
40bd6cca 22BuildRequires: rpmbuild(macros) >= 1.268
08326d23 23BuildRequires: zlib-devel
5029daf9 24Requires(post): fileutils
5029daf9 25Requires(post,postun): /sbin/ldconfig
40bd6cca
ER
26Requires(post,preun): /sbin/chkconfig
27Requires(postun): /usr/sbin/userdel
28Requires(pre): /bin/id
29Requires(pre): /usr/sbin/useradd
5029daf9 30Requires: %{name}-db-%{version}
40bd6cca 31Requires: webserver
7937dc92 32Provides: user(aspseek)
becae7d1 33Obsoletes: mnogosearch
40bd6cca 34Obsoletes: swish++
e92f949b
AM
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%define _sysconfdir /etc/%{name}
38%define _bindir /home/httpd/cgi-bin
40bd6cca 39%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
e92f949b
AM
40
41%description
42ASPSeek is an Internet search engine, written in C++ using the STL
43library. It consists of an indexing robot, a search daemon, and a CGI
44search frontend. It can index as many as a few million URLs and search
45for words and phrases, use wildcards, and do a Boolean search. Search
46results can be limited to time period given, site or Web space (set of
47sites) and sorted by relevance (some cool techniques are used) or
48date.
49
50ASPSeek is optimized for multiple sites (threaded index, async DNS
51lookups, grouping results by site, Web spaces), but can be used for
52searching one site as well. ASPSeek can work with multiple
53languages/encodings at once (including multibyte encodings such as
54Chinese) due to Unicode storage mode. Other features include stopwords
55and ispell support, a charset and language guesser, HTML templates for
56search results, excerpts, and query words highlighting.
57
135253a1 58%description -l pl.UTF-8
e92f949b 59ASPSeek jest silnikiem wyszukiwarki Internetowej, napisany w C++ z
135253a1
JR
60użyciem biblioteki STL. Zawiera robota indeksującego, daemon
61wyszukujący oraz interfejs w postaci skryptu CGI. ASPSeek może
62indeksować miliony adresów oraz wyszukiwać słowa oraz zwroty, używać
63znaków globalnych jak również stosować operatory logiczne. Rezultaty
64wyszukiwania mogą być ograniczane do określonego okresu czasu,
65serwera, zbioru serwerów oraz sortowane wg. aktualności (określane za
66pomocą pewnych specjalnych technik) lub daty.
e92f949b 67
135253a1
JR
68ASPSeek jest zoptymalizowany dla wielu serwerów (wątkowane
69indeksowanie, asynchroniczne zapytania DNS, grupowanie rezultatów wg
70serwera, grupy serwerów), ale może być również używany do obsługi
71jednego serwera. ASPSeek może pracować z wieloma językami/kodowaniami
72równocześnie (włączając w to wielobajtowe kodowania używane np. dla
73języka Chińskiego) dzięki trybowi zapisu w Unikodzie. Inne możliwości
74to blokowanie określonych słów, wsparcie dla ispella, zgadywarka
75kodowania oraz języka, wzorce HTML dla rezultatów wyszukiwania,
76podświetlanie wyszukiwanych słów.
e92f949b
AM
77
78%package db-mysql
79Summary: MySQL backend driver for ASPSeek
135253a1 80Summary(pl.UTF-8): Obsługa MySQL dla ASPSeek
e92f949b 81Group: Networking/Utilities
5029daf9 82Requires(post): /sbin/ldconfig
a4534fd4 83Requires: %{name} = %{version}-%{release}
40bd6cca 84Provides: %{name}-db-%{version}
e92f949b
AM
85
86%description db-mysql
87This driver acts as a database backend for ASPSeek, so ASPSeek will
88store its data in MySQL database.
89
135253a1
JR
90%description db-mysql -l pl.UTF-8
91Ten driver działa jako bazodanowy backend dla ASPSeek, tak, że ASPSeek
92będzie zapisywał swoje dane w bazie MySQL.
e92f949b 93
08326d23 94%package -n apache-mod_aspseek
e92f949b 95Summary: Apache module: ASPSeek search engine
135253a1 96Summary(pl.UTF-8): Moduł Apache: Silnik wyszukiwania ASPSeek
e92f949b 97Group: Networking/Daemons
5029daf9 98Requires(post,preun): %{apxs}
c40c3c72
JB
99Requires(post,preun): grep
100Requires(preun): fileutils
08326d23 101Requires: apache(EAPI)
40bd6cca 102Requires: aspseek
e92f949b
AM
103
104%description -n apache-mod_aspseek
105ASPSeek Apache module.
106
135253a1
JR
107%description -n apache-mod_aspseek -l pl.UTF-8
108Moduł Apache ASPSeek.
e92f949b
AM
109
110%prep
111%setup -q
a75819f9 112%patch0 -p1
e92f949b
AM
113
114%build
115%configure2_13 \
116 --enable-charset-guesser \
117 --enable-font-size \
118 --enable-apache-module \
119 --with-openssl \
08326d23 120 --with-mysql \
a016ddc3 121 --enable-unicode \
08326d23 122 --localstatedir=/var/spool
e92f949b
AM
123%{__make}
124
125%install
126rm -rf $RPM_BUILD_ROOT
cd747aa5 127install -d $RPM_BUILD_ROOT{/etc/{httpd,rc.d/init.d},/home/httpd/icons}
08326d23 128install -d $RPM_BUILD_ROOT/var/{spool/aspseek,log}
e92f949b
AM
129
130%{__make} install \
131 DESTDIR=$RPM_BUILD_ROOT
132
08326d23
AM
133mv -f $RPM_BUILD_ROOT%{_sysconfdir}/img/* $RPM_BUILD_ROOT/home/httpd/icons
134install %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/mod_aspseek.conf
135sed -e "s#/img/#/icons/#g" $RPM_BUILD_ROOT%{_sysconfdir}/s.htm-dist > \
136 $RPM_BUILD_ROOT%{_sysconfdir}/s.htm
137install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
138touch $RPM_BUILD_ROOT/var/log/aspseek.log
139
e92f949b
AM
140%clean
141rm -rf $RPM_BUILD_ROOT
142
203fc1d2 143%pre
b1bf9149 144%useradd -u 50 -d /srv/aspseek -s /bin/false -c "ASPSEEK User" -g root aspseek
203fc1d2 145
08326d23
AM
146%post
147/sbin/ldconfig
03f55577 148/sbin/chkconfig --add %{name}
24029235
JB
149touch /var/log/aspseek.log
150chown aspseek:root /var/log/aspseek.log
7937dc92 151# create $HOME if possible, we are not allowed to remove it later
152if [ ! -d /srv/aspseek ]; then
153 if mkdir /srv/aspseek; then
154 chown aspseek:root /srv/aspseek
155 chmod 755 /srv/aspseek
156 fi
157fi
08326d23
AM
158
159%preun
160if [ "$1" = "0" ]; then
40bd6cca 161 %service %{name} stop
e568d047 162 /sbin/chkconfig --del %{name}
08326d23 163fi
e92f949b 164
08326d23
AM
165%postun
166/sbin/ldconfig
203fc1d2 167if [ "$1" = "0" ]; then
7937dc92 168 %userremove aspseek
203fc1d2 169fi
e92f949b 170
08326d23
AM
171%post db-mysql
172/sbin/ldconfig
5029daf9 173echo "Remember to run %{_sbindir}/aspseek-mysql-postinstall."
08326d23
AM
174
175%postun db-mysql -p /sbin/ldconfig
e92f949b
AM
176
177%post -n apache-mod_aspseek
41fe1ac2 178%{apxs} -e -a -n aspseek %{_pkglibdir}/mod_aspseek.so 1>&2
08326d23 179if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*mod_aspseek.conf" /etc/httpd/httpd.conf; then
c40c3c72 180 echo "Include /etc/httpd/mod_aspseek.conf" >> /etc/httpd/httpd.conf
08326d23 181fi
40bd6cca 182%service -q httpd restart
e92f949b
AM
183
184%preun -n apache-mod_aspseek
185if [ "$1" = "0" ]; then
c40c3c72
JB
186 %{apxs} -e -A -n aspseek %{_pkglibdir}/mod_aspseek.so 1>&2
187 umask 027
188 grep -v "^Include.*mod_aspseek.conf" /etc/httpd/httpd.conf > \
189 /etc/httpd/httpd.conf.tmp
190 mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
40bd6cca 191 %service -q httpd restart
e92f949b
AM
192fi
193
194%files
195%defattr(644,root,root,755)
5029daf9 196%doc AUTHOR* FAQ* NEWS* README* RELEASE* THANKS* TODO* doc/*.txt
e92f949b 197%attr(755,root,root) %{_bindir}/s.cgi
08326d23
AM
198%attr(755,root,root) %{_sbindir}/index
199%attr(755,root,root) %{_sbindir}/searchd
200%attr(755,root,root) %{_libdir}/libaspseek*.so.*
201/home/httpd/icons/*.*
e92f949b
AM
202%{_mandir}/man5/aspseek.conf*
203%{_mandir}/man5/s*
204%{_mandir}/man1/*
205%{_mandir}/man7/*
08326d23
AM
206%dir %{_sysconfdir}
207%{_sysconfdir}/langmap
208%dir %{_sysconfdir}/sql
209%{_sysconfdir}/stopwords
210%{_sysconfdir}/tables
cc648b24 211%attr(754,root,root) /etc/rc.d/init.d/aspseek
08326d23 212%attr(750,aspseek,root) %dir /var/spool/aspseek
a919e2b9
ER
213%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
214%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.htm
08326d23 215%ghost /var/log/aspseek.log
e92f949b
AM
216
217%files db-mysql
218%defattr(644,root,root,755)
219%attr(755,root,root) %{_sbindir}/aspseek-mysql-postinstall
08326d23
AM
220%attr(755,root,root) %{_libdir}/libmysql*.so*
221%{_sysconfdir}/sql/mysql
e92f949b
AM
222%{_mandir}/man5/aspseek-sql*
223
224%files -n apache-mod_aspseek
225%defattr(644,root,root,755)
5029daf9 226%doc README.APACHE_MODULE
08326d23 227%attr(755,root,root) %{_pkglibdir}/*.so
a919e2b9 228%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/httpd/mod_*.conf
This page took 0.061719 seconds and 4 git commands to generate.