]> git.pld-linux.org Git - packages/ash.git/commitdiff
- fixed BOOT package - memout patch is applied in build, as it breaks
authorklakier <klakier@pld-linux.org>
Mon, 21 May 2001 18:28:01 +0000 (18:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  building with memory buffers disabled

Changed files:
    ash.spec -> 1.39

ash.spec

index 92d44209e8a891a47ac2d97f99c4656e4002ce60..33dd3f765b61783b347f5003d90416cfaebb9c71 100644 (file)
--- a/ash.spec
+++ b/ash.spec
@@ -38,7 +38,9 @@ Prereq:               grep
 BuildRequires: glibc-static
 BuildRequires: flex
 BuildRequires: byacc
-%{?BOOT:BuildRequires: uClibc-devel-BOOT}
+%if %{?BOOT:1}%{!?BOOT:0}
+BuildRequires: uClibc-devel-BOOT >= 20000521
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Conflicts:     mkinitrd <= 1.7
 
@@ -136,7 +138,7 @@ Version for bootdisk
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-%patch10 -p1
+#%patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
@@ -151,6 +153,9 @@ Version for bootdisk
 %build
 # BOOT
 %if %{?BOOT:1}%{!?BOOT:0}
+# some of this utilities does not compile with uClibc
+# and it is not necessary
+%{__make} mksignames mkbuiltins mknodes mksignames mksyntax mktokens
 %{__make} \
        OPT_FLAGS="-I/usr/lib/bootdisk%{_includedir} -Os" \
        LDFLAGS="-nostdlib %{rpmldflags}" \
@@ -159,6 +164,9 @@ mv -f sh ash.BOOT
 %{__make} clean
 %endif
 
+# this patch imposes memory buffers - uClibc lacks them
+patch -p1 <%{PATCH10}
+
 # other
 %{__make} OPT_FLAGS="%{rpmcflags}" LDFLAGS="-static %{rpmldflags}"
 mv -f sh ash.static
@@ -170,7 +178,7 @@ rm -rf $RPM_BUILD_ROOT
 # BOOT
 %if %{?BOOT:1}%{!?BOOT:0}
 install -d $RPM_BUILD_ROOT/usr/lib/bootdisk/bin
-install ash.BOOT $RPM_BUILD_ROOT/usr/lib/bootdisk/bin/ash
+install -s ash.BOOT $RPM_BUILD_ROOT/usr/lib/bootdisk/bin/ash
 ln -sf ash $RPM_BUILD_ROOT/usr/lib/bootdisk/bin/sh
 %endif
 
This page took 0.096218 seconds and 4 git commands to generate.