]> git.pld-linux.org Git - packages/asdcplib.git/commitdiff
- new auto/th/asdcplib-1.12.60-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 4 Apr 2015 16:24:40 +0000 (18:24 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 4 Apr 2015 16:24:40 +0000 (18:24 +0200)
asdcplib-link.patch [new file with mode: 0644]
asdcplib.spec [new file with mode: 0644]

diff --git a/asdcplib-link.patch b/asdcplib-link.patch
new file mode 100644 (file)
index 0000000..e93fddd
--- /dev/null
@@ -0,0 +1,88 @@
+--- asdcplib-1.12.60/m4/ax_lib_expat.m4.orig   2009-11-07 01:11:58.000000000 +0100
++++ asdcplib-1.12.60/m4/ax_lib_expat.m4        2015-04-04 17:34:57.122615887 +0200
+@@ -101,6 +101,7 @@
+     EXPAT_CFLAGS=""
+     EXPAT_LDFLAGS=""
++    EXPAT_LIBS=""
+     EXPAT_VERSION=""
+     dnl
+@@ -110,7 +111,6 @@
+     if test -n "$expat_prefix"; then
+         expat_include_dir="$expat_prefix/include"
+-        expat_lib_flags="-L$expat_prefix/lib64 -L$expat_prefix/lib -lexpat"
+         run_expat_test="yes"
+     elif test "$expat_requested" = "yes"; then
+         if test -n "$expat_include_dir" -a -n "$expat_lib_flags"; then
+@@ -131,6 +131,9 @@
+         saved_LDFLAGS="$LDFLAGS"
+         LDFLAGS="$LDFLAGS $expat_lib_flags"
++        saved_LIBS="$LIBS"
++        LIBS="$LIBS -lexpat"
++
+         dnl
+         dnl Check Expat headers
+         dnl
+@@ -177,6 +180,7 @@
+                 )],
+                 [
+                 EXPAT_LDFLAGS="$expat_lib_flags"
++                EXPAT_LIBS="-lexpat"
+                 expat_lib_found="yes"
+                 AC_MSG_RESULT([found])
+                 ],
+@@ -190,6 +194,7 @@
+         CPPFLAGS="$saved_CPPFLAGS"
+         LDFLAGS="$saved_LDFLAGS"
++        LIBS="$saved_LIBS"
+     fi
+     AC_MSG_CHECKING([for Expat XML Parser])
+@@ -199,6 +204,7 @@
+             AC_SUBST([EXPAT_CFLAGS])
+             AC_SUBST([EXPAT_LDFLAGS])
++            AC_SUBST([EXPAT_LIBS])
+             HAVE_EXPAT="yes"
+         else
+@@ -277,5 +283,6 @@
+     if test "$HAVE_EXPAT" = "yes"; then
+         CPPFLAGS="$CPPFLAGS $EXPAT_CFLAGS -DHAVE_EXPAT=1"
+         LDFLAGS="$LDFLAGS $EXPAT_LDFLAGS"
++        LIBS="$LIBS $EXPAT_LIBS"
+     fi
+ ])
+--- asdcplib-1.12.60/m4/ax_lib_openssl.m4.orig 2009-11-07 01:11:58.000000000 +0100
++++ asdcplib-1.12.60/m4/ax_lib_openssl.m4      2015-04-04 17:46:23.155934920 +0200
+@@ -113,7 +113,7 @@
+     if test -n "$openssl_prefix"; then
+         openssl_include_dir="$openssl_prefix/include"
+-        openssl_ldflags="-L$openssl_prefix/lib64 -L$openssl_prefix/lib"
++        openssl_ldflags=""
+         run_openssl_test="yes"
+     elif test "$openssl_requested" = "yes"; then
+         if test -n "$openssl_include_dir" -a -n "$openssl_lib_flags"; then
+@@ -237,7 +237,7 @@
+                 if test -f "$openssl_include_dir/openssl/opensslv.h"; then
+                     OPENSSL_VERSION=`grep OPENSSL_VERSION_TEXT $openssl_include_dir/openssl/opensslv.h \
+-                                    | grep -v fips | grep -v PTEXT | cut -f 2 | tr -d \"`
++                                    | grep -v fips | grep -v PTEXT | sed -e 's/.*"\([^"]*\)"$/\1/'`
+                     AC_SUBST([OPENSSL_VERSION])
+                     dnl Decompose required version string and calculate numerical representation
+@@ -259,7 +259,7 @@
+                                                \+ $((0xf))`
+                     dnl Calculate numerical representation of detected version
+-                    openssl_version_number=`expr $(($(grep OPENSSL_VERSION_NUMBER $openssl_include_dir/openssl/opensslv.h | cut -f 2 | tr -d L)))`
++                    openssl_version_number=`expr $(($(grep OPENSSL_VERSION_NUMBER $openssl_include_dir/openssl/opensslv.h | sed -e 's/.*\(0x.*\)L.*/\1/') ))`
+                     openssl_version_check=`expr $openssl_version_number \>\= $openssl_version_req_number`
+                     if test "$openssl_version_check" = "1"; then
diff --git a/asdcplib.spec b/asdcplib.spec
new file mode 100644 (file)
index 0000000..82c6f87
--- /dev/null
@@ -0,0 +1,119 @@
+# TODO: python (missing sources, specified as nodist???)
+Summary:       The ASDCP library
+Summary(pl.UTF-8):     Biblioteka ASDCP
+Name:          asdcplib
+Version:       1.12.60
+Release:       1
+License:       BSD
+Group:         Libraries
+# note: download URL shows more recent versions than document at download directory
+#Source0Download: http://www.cinecert.com/asdcplib/download/
+Source0:       http://download.cinecert.com/asdcplib/%{name}-%{version}.tar.gz
+# Source0-md5: 3bb2754744a629813e4db816e081e114
+Patch0:                %{name}-link.patch
+URL:           http://www.cinecert.com/asdcplib/
+BuildRequires: autoconf >= 2.59
+BuildRequires: automake >= 1:1.9
+BuildRequires: expat-devel >= 1.95
+BuildRequires: libtool
+BuildRequires: openssl-devel >= 0.9.7
+#BuildRequires:        python-devel >= 2.3
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+The asdcplib library is a set of objects that offer simplified access
+to files conforming to the sound and picture track file formats
+developed by the SMPTE Working Group DC28.20 (now TC 21DC).
+
+%description -l pl.UTF-8
+Biblioteka asdcplib to zbiór obiektów oferujących uproszczony dostęp
+do plików zgodnych z formatami plików ścieżek dźwięku i obrazu
+opracowanych przez grupę roboczą SMPTE DC28.20 (obecnie TC 21DC).
+
+%package devel
+Summary:       Header files for ASDCP library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki ASDCP
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      openssl-devel >= 0.9.7
+
+%description devel
+Header files for ASDCP library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki ASDCP.
+
+%package static
+Summary:       Static ASDCP libraries
+Summary(pl.UTF-8):     Statyczne biblioteki ASDCP
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static ASDCP libraries.
+
+%description static -l pl.UTF-8
+Statyczne biblioteki ASDCP.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__automake}
+%configure \
+       --with-expat=/usr \
+       --with-openssl=/usr
+#      --with-python is broken (required files missing in tarball)
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc COPYING README
+%attr(755,root,root) %{_bindir}/asdcp-info
+%attr(755,root,root) %{_bindir}/asdcp-test
+%attr(755,root,root) %{_bindir}/asdcp-unwrap
+%attr(755,root,root) %{_bindir}/asdcp-util
+%attr(755,root,root) %{_bindir}/asdcp-wrap
+%attr(755,root,root) %{_bindir}/blackwave
+%attr(755,root,root) %{_bindir}/j2c-test
+%attr(755,root,root) %{_bindir}/klvsplit
+%attr(755,root,root) %{_bindir}/klvwalk
+%attr(755,root,root) %{_bindir}/kmfilegen
+%attr(755,root,root) %{_bindir}/kmrandgen
+%attr(755,root,root) %{_bindir}/kmuuidgen
+%attr(755,root,root) %{_bindir}/wavesplit
+%attr(755,root,root) %{_libdir}/libasdcp-%{version}.so
+%attr(755,root,root) %{_libdir}/libkumu-%{version}.so
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libasdcp.so
+%attr(755,root,root) %{_libdir}/libkumu.so
+%{_includedir}/AS_DCP.h
+%{_includedir}/KM_*.h
+%{_pkgconfigdir}/asdcplib.pc
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libasdcp.a
+%{_libdir}/libkumu.a
This page took 0.161524 seconds and 4 git commands to generate.