]> git.pld-linux.org Git - packages/asciinema.git/blob - asciinema.spec
Release 7 (by relup.sh)
[packages/asciinema.git] / asciinema.spec
1 %define         module          asciinema
2 %define         egg_name        asciinema
3 %define         pypi_name       asciinema
4 Summary:        Command line client (terminal recorder) for asciinema.org service
5 Name:           asciinema
6 Version:        1.4.0
7 Release:        2
8 License:        GPL v3
9 Group:          Applications/Networking
10 #Source0:       https://github.com/asciinema/asciinema/archive/v%{version}/%{name}-%{version}.tar.gz
11 Source0:        https://files.pythonhosted.org/packages/source/a/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
12 # Source0-md5:  507ec769e1e9f8d5146b8c32c5ed54ac
13 URL:            http://asciinema.org/docs
14 BuildRequires:  python3-modules
15 BuildRequires:  python3-setuptools
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 Requires:       python3-setuptools
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Asciinema is a free and open source solution for recording the
24 terminal sessions and sharing them on the web.
25
26 %prep
27 %setup -q
28
29 # Remove bundled egg-info
30 %{__rm} -r %{egg_name}.egg-info
31
32 %build
33 %py3_build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 %py3_install
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %attr(755,root,root) %{_bindir}/asciinema
45 %{py3_sitescriptdir}/%{module}
46 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.082443 seconds and 3 git commands to generate.