]> git.pld-linux.org Git - packages/asciidoc.git/blame - asciidoc.spec
R: /usr/bin/pygmentize
[packages/asciidoc.git] / asciidoc.spec
CommitLineData
742e5897 1# TODO: package the vim syntax file.
86d6172c 2Summary: A tool for converting text files to various formats
465ba125 3Summary(pl.UTF-8): Narzędzie do konwersji plików tekstowych do różnych formatów
86d6172c 4Name: asciidoc
0f7453d4 5Version: 9.1.0
73dee59c 6Release: 1
5675ed0e 7License: GPL v2+
86d6172c 8Group: Applications/System
04c9364e 9#Source0Download: https://github.com/asciidoc/asciidoc/releases
0f7453d4
JP
10Source0: https://github.com/asciidoc-py/asciidoc-py/archive/%{version}/%{name}-%{version}.tar.gz
11# Source0-md5: 52fc3849e1f48d8764337ce2b355b2ff
12URL: https://asciidoc.org/
04c9364e 13BuildRequires: autoconf >= 2.50
d62a141d 14BuildRequires: rpm-pythonprov
d0e0c459 15BuildRequires: sed >= 4.0
450f30e1 16Requires: /usr/bin/pygmentize
3e9cc59f 17Requires: docbook-dtd45-xml
0f7453d4
JP
18Requires: python3 >= 1:3.5
19Requires: python3-modules >= 1:3.5
29d5dcd1 20Requires: xmlto
86d6172c 21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
04c9364e 24%define pkgconfdir %{_sysconfdir}/asciidoc
86d6172c 25
26%description
fd5d72cd
JB
27AsciiDoc is a text document format for writing short documents,
28articles, books and UNIX man pages. AsciiDoc files can be translated
29to HTML (with or without stylesheets), DocBook and LinuxDoc markup
30using the asciidoc(1) command. AsciiDoc is highly configurable: both
31the AsciiDoc source file syntax and the backend output markups (which
32can be almost any type of SGML/XML markup) can be customized and
33extended by the user.
86d6172c 34
3dc03438
JR
35%description -l pl.UTF-8
36AsciiDoc jest formatem dokumentów tekstowych do pisania krótkich
37dokumentów, artykułów, książek i podręczników systemu UNIX. Pliki
38AsciiDoc mogą być tłumaczone do HTML-a (z lub bez CSS), DocBooka i
39LinuxDoca używając polecenia asciidoc(1). AsciiDoc jest wysoce
40konfigurowalny: zarówno składnia plików źródłowych, jak i znaczniki
41backendów (które mogą być dowolnego typu SGML/XML) mogą być
42dostosowywane i rozszerzane przez użytkownika.
86d6172c 43
44%prep
0f7453d4 45%setup -q -n %{name}-py-%{version}
8eb1c8a9 46
0f7453d4 47%{__sed} -i -e '1s|^#!/usr/bin/env python3\?|#!%{__python3}|' asciidoc.py a2x.py \
c496920f 48 filters/code/code-filter.py \
04c9364e 49 filters/latex/latex2img.py \
c496920f 50 filters/music/music2png.py \
0f7453d4
JP
51 filters/graphviz/graphviz2png.py \
52 filters/unwraplatex.py
86d6172c 53
d0e0c459 54%build
04c9364e 55%{__autoconf}
8eb1c8a9
JB
56%configure
57
58%{__make}
d0e0c459 59
86d6172c 60%install
61rm -rf $RPM_BUILD_ROOT
86d6172c 62
04c9364e
JB
63%{__make} install \
64 DESTDIR=$RPM_BUILD_ROOT
86d6172c 65
04c9364e
JB
66# install directly instead of symlinks to .py
67%{__mv} $RPM_BUILD_ROOT%{_bindir}/a2x{.py,}
68%{__mv} $RPM_BUILD_ROOT%{_bindir}/asciidoc{.py,}
69# move constant data to /usr
70install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
71%{__mv} $RPM_BUILD_ROOT%{pkgconfdir}/{images,javascripts} $RPM_BUILD_ROOT%{_datadir}/%{name}
72ln -sf %{_datadir}/%{name}/images $RPM_BUILD_ROOT%{pkgconfdir}/images
73ln -sf %{_datadir}/%{name}/javascripts $RPM_BUILD_ROOT%{pkgconfdir}/javascripts
742e5897 74
0f7453d4
JP
75%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/testasciidoc.1
76
742e5897 77# if [ -d $VIM_RPM_BUILD_ROOT%{sysconfdir} ]; then
78# install -d $VIM_RPM_BUILD_ROOT%{sysconfdir}/syntax
79# install -m 644 vim/syntax/asciidoc.vim \
80# $VIM_RPM_BUILD_ROOT%{sysconfdir}/syntax/asciidoc.vim
81# install -d $VIM_RPM_BUILD_ROOT%{sysconfdir}/ftdetect
82# install -m 644 vim/ftdetect/asciidoc_filetype.vim \
83# $VIM_RPM_BUILD_ROOT%{sysconfdir}/ftdetect/asciidoc_filetype.vim
84# fi
ebdc84fb 85
86d6172c 86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(644,root,root,755)
0f7453d4 91%doc BUGS.txt CHANGELOG.txt COPYRIGHT README.asciidoc doc/asciidoc.txt
5675ed0e
JB
92%attr(755,root,root) %{_bindir}/a2x
93%attr(755,root,root) %{_bindir}/asciidoc
04c9364e
JB
94%dir %{pkgconfdir}
95%config(noreplace) %verify(not md5 mtime size) %{pkgconfdir}/*.conf
96%dir %{pkgconfdir}/dblatex
97%{pkgconfdir}/dblatex/*.sty
98%{pkgconfdir}/dblatex/*.xsl
99%dir %{pkgconfdir}/docbook-xsl
100%{pkgconfdir}/docbook-xsl/*.xsl
101%dir %{pkgconfdir}/filters
102%dir %{pkgconfdir}/filters/code
103%config(noreplace) %verify(not md5 mtime size) %{pkgconfdir}/filters/code/code-filter.conf
104%attr(755,root,root) %{pkgconfdir}/filters/code/code-filter.py
105%dir %{pkgconfdir}/filters/graphviz
106%config(noreplace) %verify(not md5 mtime size) %{pkgconfdir}/filters/graphviz/graphviz-filter.conf
107%attr(755,root,root) %{pkgconfdir}/filters/graphviz/graphviz2png.py
108%dir %{pkgconfdir}/filters/music
109%config(noreplace) %verify(not md5 mtime size) %{pkgconfdir}/filters/music/music-filter.conf
110%attr(755,root,root) %{pkgconfdir}/filters/music/music2png.py
111%dir %{pkgconfdir}/filters/source
112%config(noreplace) %verify(not md5 mtime size) %{pkgconfdir}/filters/source/source-highlight-filter.conf
113%dir %{pkgconfdir}/filters/latex
114%config(noreplace) %verify(not md5 mtime size) %{pkgconfdir}/filters/latex/latex-filter.conf
115%attr(755,root,root) %{pkgconfdir}/filters/latex/latex2img.py
0f7453d4 116%attr(755,root,root) %{pkgconfdir}/filters/unwraplatex.py
04c9364e
JB
117%{pkgconfdir}/images
118%{pkgconfdir}/javascripts
119%dir %{pkgconfdir}/stylesheets
120%{pkgconfdir}/stylesheets/*.css
121%{pkgconfdir}/themes
5675ed0e
JB
122%{_datadir}/%{name}
123%{_mandir}/man1/a2x.1*
124%{_mandir}/man1/asciidoc.1*
This page took 0.193466 seconds and 4 git commands to generate.