]> git.pld-linux.org Git - packages/as31.git/blob - as31.spec
- tabs in preamble
[packages/as31.git] / as31.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk     # with GTK+ interface (you probably don't want this)
4 #
5 Summary:        An Intel 8031/8051 assembler
6 Summary(pl.UTF-8):      Asembler dla procesorów Intel 8031/8051
7 Name:           as31
8 Version:        2.0
9 Release:        1.beta3
10 License:        GPL
11 Group:          Development/Languages
12 Source0:        http://www.pjrc.com/tech/8051/%{name}_beta3.tar.gz
13 # Source0-md5:  24e2d74747e0b3672cdb581138e50d8f
14 Patch0:         %{name}-nostrip.patch
15 URL:            http://www.pjrc.com/tech/8051/#as31_assembler
16 BuildRequires:  bison
17 %{?with_gtk:BuildRequires:      gtk+-devel}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 An Intel 8031/8051 assembler.
22
23 %description -l pl.UTF-8
24 Asembler dla procesorów Intel 8031/8051.
25
26 %prep
27 %setup -q -n %{name}
28 %patch0 -p1
29
30 %build
31 %{__make} \
32         CFLAGS="%{rpmcflags}" \
33         LDFLAGS="%{rpmldflags}" \
34         as31 %{?with_gtk:as31_gtk}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
39
40 install %{name}         $RPM_BUILD_ROOT%{_bindir}
41 %{?with_gtk:install %{name}_gtk $RPM_BUILD_ROOT%{_bindir}}
42 install %{name}.1       $RPM_BUILD_ROOT%{_mandir}/man1
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc README
50 %attr(755,root,root) %{_bindir}/*
51 %{_mandir}/man?/*
This page took 0.059089 seconds and 3 git commands to generate.