]> git.pld-linux.org Git - packages/arts.git/commitdiff
- adjusted kde-am patch to support also automake 1.12 through 1.14 master
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 8 Feb 2014 14:35:13 +0000 (15:35 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 8 Feb 2014 14:35:13 +0000 (15:35 +0100)
- ported extension_loader patch to boost::filesystem v3
- somespec cleanups

arts-extension_loader.patch
arts.spec
kde-am.patch

index 3824573e69505446ecae1140e6cf06991f42dda0..647ea5592012528e401d9db96ce3752f982e5567 100644 (file)
@@ -35,7 +35,7 @@
 +                      i != boost::filesystem::directory_iterator(); ++i )
 +              {
 +                      boost::smatch m;
-+                      if ( boost::regex_match( i->string(), m, re ) )
++                      if ( boost::regex_match( i->path().string(), m, re ) )
 +                              return m.str();
 +              }
 +              return ( p + ".la" );
@@ -58,7 +58,7 @@
 +      {
 +              boost::filesystem::path p( filename );
 +              if ( p.has_root_directory() )
-+                      dlfilename = makeLibraryName( p.branch_path().string(), p.leaf() );
++                      dlfilename = makeLibraryName( p.branch_path().string(), p.filename().string() );
 +      }
 +      catch ( boost::filesystem::filesystem_error const& )
 +      {
index c1996d86c44fded433ef894b4ee943be7cfcb16d..cf46329915a6075cd94c5e7ab2ce2649f7601fd1 100644 (file)
--- a/arts.spec
+++ b/arts.spec
@@ -1,10 +1,10 @@
 #
 # Conditional build:
-%bcond_without alsa    # disable ALSA support
-%bcond_with    nas     # enable NAS support
-%bcond_with    arts                    # build with aRts support
-%bcond_without esd     # disable esound support
-%bcond_without hidden_visibility       # pass '--fvisibility=hidden' & '--fvisibility-inlines-hidden' to g++
+%bcond_without alsa                    # ALSA support
+%bcond_with    nas                     # NAS support
+%bcond_with    arts                    # aRts support (i.e. actually build this package)
+%bcond_without esd                     # EsounD support
+%bcond_without hidden_visibility       # '--fvisibility=hidden' & '--fvisibility-inlines-hidden' g++ opts
 
 %define                _state          stable
 %define                _kdever         3.5.10
@@ -208,7 +208,7 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
-rm -f $RPM_BUILD_ROOT%{_libdir}/libx11globalcomm.{la,so}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libx11globalcomm.{la,so}
 
 # remove unwanted boost deps from .la
 sed -i 's:-lboost_filesystem -lboost_regex::' $RPM_BUILD_ROOT%{_libdir}/*.la
index 5a23f3aefde29995685f7fadf14cc44d2eb739f9..1d412a534186dcde5b2783da2753ff301395bdf6 100644 (file)
@@ -5,7 +5,16 @@
      exit 1
      ;;
 -  automake*1.6.* | automake*1.7* | automake*1.8* | automake*1.9* | automake*1.10*)
-+  automake*1.6.* | automake*1.7* | automake*1.8* | automake*1.9* | automake*1.10* | automake*1.11*)
++  automake*1.6.* | automake*1.7* | automake*1.8* | automake*1.9* | automake*1.1[01234]*)
      echo "*** $AUTOMAKE_STRING found."
      UNSERMAKE=no
      ;;
+@@ -135,7 +135,7 @@
+ fi
+ echo "*** Creating Makefile templates"
+-$AUTOMAKE || exit 1
++$AUTOMAKE --add-missing --copy || exit 1
+ if test "$UNSERMAKE" = no; then
+   echo "*** Postprocessing Makefile templates"
This page took 0.048561 seconds and 4 git commands to generate.