]> git.pld-linux.org Git - packages/arts.git/blobdiff - arts.spec
- merged from DEVEL; changelog cut down
[packages/arts.git] / arts.spec
index 531fdeebaf75293fb3a6e1fcd1068f1edbf4b8bc..a22afa86c6865cb85ccc91204cb7a5d9ae814d06 100644 (file)
--- a/arts.spec
+++ b/arts.spec
@@ -1,53 +1,64 @@
 #
-# TODO: consider:
-# - separating artsc and its -devel? (but what are artsc deps?)
-#
 # Conditional build:
 %bcond_without alsa    # disable ALSA support
 %bcond_with    nas     # enable NAS support
+%bcond_without esd     # disable esound support
 #
 
-%define                _state          snapshots
-%define                _ver            1.2.0
-%define                _snap           040104
+%define                _state          stable
+%define                _kdever         3.4.0
+%define                _ver            1.4.0
 
 Summary:       aRts sound server
 Summary(pl):   Serwer d¼wiêku
 Summary(pt_BR):        Servidor de sons usado pelo KDE
 Name:          arts
-Version:       %{_ver}.%{_snap}
-Release:       1
-Epoch:         12
+Version:       %{_ver}
+Release:       0.1
+Epoch:         13
 License:       LGPL
 Group:         Libraries
-#Source0:      ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
-Source0:       http://ep09.pld-linux.org/~djurban/kde/%{name}-%{_snap}.tar.bz2
-# Source0-md5: 36606412608b4c1683d0f583dfd8e3c6
-Patch0:                kde-common-am18.patch
-Patch1:         kde-common-libltdl-am18.patch
-URL:           http://www.kde.org/
+Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
+# Source0-md5: a155bb00f56c71bc475890249e2dcaa9
+URL:           http://www.arts-project.org/
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 BuildRequires: audiofile-devel
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: docbook-dtd41-sgml
 BuildRequires: docbook-utils >= 0.6.13-3
-BuildRequires: esound-devel
+%{?with_esd:BuildRequires:     esound-devel}
 BuildRequires: glib2-devel >= 2.0.0
+BuildRequires: jack-audio-connection-kit-devel
 BuildRequires: libmad-devel
 BuildRequires: libtool >= 2:1.5-2
 BuildRequires: libvorbis-devel
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: pkgconfig
 BuildRequires: qt-devel >= 6:3.2.1-4
+#BuildRequires:        unsermake >= 040805-1
 Obsoletes:     arts-glib
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-aRts sound server.
+The Analog Real-Time Synthesizer, or aRts, is a modular system for
+synthesizing sound and music on a digital computer. Using small
+building blocks called modules, the user can easily build complex
+audio processing tools. Modules typically provide functions such as
+sound waveform generators, filters, audio effects, mixing, and
+playback of digital audio in different file formats. The artsd sound
+server mixes audio from several sources in real time, allowing
+multiple sound applications to transparently share access to sound
+hardware.
 
 %description -l pl
-Serwer d¼wiêku aRts.
+Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
+obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
+mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
+d¼wiêku. Modu³y umo¿liwiaj± generacjê kszta³tu fali, filtrowanie,
+efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
+formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
+odtwarzanie d¼wiêku z wielu ¼róde³.
 
 %description -l pt_BR
 O aRts é um sintetizador analógico em tempo real que é completamente
@@ -70,6 +81,7 @@ Requires:     %{name} = %{epoch}:%{version}-%{release}
 Requires:      audiofile-devel
 Requires:      esound-devel
 Requires:      glib2-devel >= 2.0.0
+Requires:      jack-audio-connection-kit-devel
 Requires:      libmad-devel
 Requires:      libvorbis-devel
 %{?with_nas:Requires:  nas-devel}
@@ -86,8 +98,8 @@ Arquivos para desenvolvimento com o o aRts.
 
 # separate from arts-devel because they are mostly independent and have very
 # different deps
-# there is no artsc base - it would be small and would require arts - so there
-# is no reason to separate
+# there is no artsc base - it would be small and would require arts - so
+# there is no reason to separate
 %package -n artsc-devel
 Summary:       Development files for artsc libraries
 Summary(pl):   Pliki programistyczne bibliotek artsc
@@ -117,17 +129,17 @@ X11 dependent part of aRts (x11globalcomm module).
 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
 
 %package qt
-Summary:       QT dependend part of aRts
-Summary(pl):   Czê¶æ aRts wymagaj±ca QT
+Summary:       Qt dependend part of aRts
+Summary(pl):   Czê¶æ aRts wymagaj±ca Qt
 Group:         X11/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      qt >= 6:3.2.1-4
 
 %description qt
-QT dependend part of aRts (qtmcop library).
+Qt dependend part of aRts (qtmcop library).
 
 %description qt -l pl
-Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
+Czê¶æ aRts wymagaj±ca Qt (biblioteka qtmcop).
 
 %package qt-devel
 Summary:       Development files for qtmcop library
@@ -144,18 +156,22 @@ Development files for qtmcop library.
 Pliki programistyczne dla biblioteki qtmcop.
 
 %prep
-%setup -q -n %{name}-%{_snap}
-%patch0 -p0
-%patch1 -p0
+%setup -q
 
 %build
-cp /usr/share/automake/config.sub admin
+cp -f /usr/share/automake/config.sub admin
+
+#export UNSERMAKE=/usr/share/unsermake/unsermake
+
 %{__make} -f admin/Makefile.common cvs
 
 %configure \
        %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
-       --%{?debug:en}%{!?debug:dis}able-debug \
-       --disable-rpath \
+%if "%{_lib}" == "lib64"
+       --enable-libsuffix=64 \
+%endif
+       --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
+       %{!?debug:--disable-rpath} \
        --enable-final \
        --with-qt-libraries=%{_libdir} \
        --with%{!?with_alsa:out}-alsa
@@ -170,7 +186,7 @@ rm -rf $RPM_BUILD_ROOT
 
 # Debian manpages
 install -d $RPM_BUILD_ROOT%{_mandir}/man1
-cd debian
+cd debian/man
 for f in *.sgml ; do
        base="$(basename $f .sgml)"
        upper="$(echo ${base} | tr a-z A-Z)"
This page took 0.039901 seconds and 4 git commands to generate.