]> git.pld-linux.org Git - packages/arts.git/blobdiff - arts.spec
- the official release is next monday, till this time please test it.
[packages/arts.git] / arts.spec
index af90cea37fb28a2ca6489762b1927198c7ea3717..535251970eaf3a8fcee73ad1f2ad895daabb0eb3 100644 (file)
--- a/arts.spec
+++ b/arts.spec
@@ -1,39 +1,45 @@
 #
-# _with_nas            - enable NAS audio support
-# _without_alsa                - disable ALSA support
+# Conditional build:
+%bcond_without alsa    # disable ALSA support
+%bcond_with    nas     # enable NAS support
+#
+%define                _state          stable
+%define                _ver            1.2.3
+#%%define              _snap           040110
+%define                _kdever         3.2.3
 #
-%ifarch sparc sparcv9 sparc64
-%define                _without_alsa   1
-%endif
 Summary:       aRts sound server
 Summary(pl):   Serwer d¼wiêku
 Summary(pt_BR):        Servidor de sons usado pelo KDE
 Name:          arts
-Version:       1.1.3
-Release:       1
-Epoch:         12
+Version:       %{_ver}
+Release:       0.1
+Epoch:         13
 License:       LGPL
-Vendor:                The KDE Team
 Group:         Libraries
-Source0:       ftp://ftp.kde.org/pub/kde/stable/3.1.2/src/%{name}-%{version}.tar.bz2
-# Source0-md5: f04eb6ef387d63741561ab6623696322
+#Source0:      http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
+Source0:        http://ep09.pld-linux.org/~djurban/kde/%{name}-%{version}.tar.bz2
+# Source0-md5: fca8a9ec7538c4fe8e4c79767bb2a7e8
+# http://download.kde.org/stable/3.2.1/src/arts-1.2.1.tar.bz2
 URL:           http://www.kde.org/
-%{!?_without_alsa:BuildRequires:       alsa-lib-devel}
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
 BuildRequires: audiofile-devel
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: docbook-dtd41-sgml
+BuildRequires: docbook-utils >= 0.6.13-3
+BuildRequires: esound-devel
 BuildRequires: glib2-devel >= 2.0.0
-BuildRequires: libjpeg-devel
-BuildRequires: libpng-devel
-BuildRequires: libstdc++-devel
-# not needed, only ./configure check for this
-#BuildRequires:        libvorbis-devel
-#BuildRequires:        mad-devel
-%{?_with_nas:BuildRequires:    nas-devel}
+BuildRequires: libmad-devel
+BuildRequires: libtool >= 2:1.5-2
+BuildRequires: libvorbis-devel
+%{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: pkgconfig
-BuildRequires: qt-devel >= 3.1
+BuildRequires: unsermake >= 040511
+BuildRequires: qt-devel >= 6:3.2.1-4
+Obsoletes:     arts-glib
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _htmldir        /usr/share/doc/kde/HTML
-
 %description
 aRts sound server.
 
@@ -50,82 +56,106 @@ design foi escolhido para permitir que outras aplica
 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
 outros.
 
+%package devel
+Summary:       Sound server - header files
+Summary(pl):   Serwer d¼wiêku - pliki nag³ówkowe
+Summary(pt_BR):        Arquivos para desenvolvimento com o o aRts
+Group:         Development/Libraries
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+# not necessary for all libs (e.g. mcop), but propagated by artsflow
+%{?with_alsa:Requires: alsa-lib-devel}
+Requires:      audiofile-devel
+Requires:      esound-devel
+Requires:      glib2-devel >= 2.0.0
+Requires:      libmad-devel
+Requires:      libvorbis-devel
+%{?with_nas:Requires:  nas-devel}
+
+%description devel
+Header files required to compile programs using arts.
+
+%description devel -l pl
+Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
+arts.
+
+%description devel -l pt_BR
+Arquivos para desenvolvimento com o o aRts.
+
+# separate from arts-devel because they are mostly independent and
+# have very # different deps there is no artsc base - it would be
+# small and would require arts - so there is no reason to separate
+%package -n artsc-devel
+Summary:       Development files for artsc libraries
+Summary(pl):   Pliki programistyczne bibliotek artsc
+Group:         Development/Libraries
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      glib2-devel >= 2.0.0
+Conflicts:     arts-devel < 12:1.2.0.031126-2
+
+%description -n artsc-devel
+Development files for artsc libraries (C interface to aRts sound
+system).
+
+%description -n artsc-devel -l pl
+Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
+d¼wiêku aRts).
+
 %package X11
 Summary:       X11 dependent part of aRts
 Summary(pl):   Czê¶æ aRts wymagaj±ca X11
 Group:         X11/Libraries
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description X11
-X11 dependent part of aRts.
+X11 dependent part of aRts (x11globalcomm module).
 
 %description X11 -l pl
-Czê¶æ aRts wymagaj±ca X11.
+Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
 
 %package qt
 Summary:       QT dependend part of aRts
 Summary(pl):   Czê¶æ aRts wymagaj±ca QT
 Group:         X11/Libraries
-Requires:      %{name} >= %{epoch}:%{version}
-Requires:      qt >= 3.1
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      qt >= 6:3.2.1-4
 
 %description qt
-QT dependend part of aRts.
+QT dependend part of aRts (qtmcop library).
 
 %description qt -l pl
-Czê¶æ aRts wymagaj±ca QT.
-
-%package devel
-Summary:       Sound server - header files
-Summary(pl):   Serwer d¼wiêku - pliki nag³ówkowe
-Summary(pt_BR):        Arquivos para desenvolvimento com o o aRts
-Group:         Development/Libraries
-Requires:      qt-devel >= 3.1
-Requires:      %{name} >= %{epoch}:%{version}
-%{?_with_nas:Requires: nas-devel}
-
-%description devel
-Header files required to compile programs using arts.
+Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
 
-%description devel -l pl
-Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
-arts.
-
-%description devel -l pt_BR
-Arquivos para desenvolvimento com o o aRts.
-
-%package glib
-Summary:       GLib dependend part of aRts
-Summary(pl):   Czê¶æ aRts wymagaj±ca GLib
-Group:         X11/Libraries
-Requires:      glib >= 1.2.6
+%package qt-devel
+Summary:       Development files for qtmcop library
+Summary(pl):   Pliki programistyczne dla biblioteki qtmcop
+Group:         X11/Development/Libraries
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+Requires:      %{name}-qt = %{epoch}:%{version}-%{release}
+Requires:      qt-devel >= 6:3.2.1-4
 
-%description glib
-GLib dependend part of aRts.
+%description qt-devel
+Development files for qtmcop library.
 
-%description glib -l pl
-Czê¶æ aRts wymagaj±ca GLib.
+%description qt-devel -l pl
+Pliki programistyczne dla biblioteki qtmcop.
 
 %prep
-%setup -q
+# qboosh leave it this way, 'cause its easier to change to snap later
+%setup -q -n %{name}-%{version}
 
 %build
-kde_htmldir="%{_htmldir}"; export kde_htmldir
-kde_icondir="%{_pixmapsdir}"; export kde_icondir
+cp /usr/share/automake/config.sub admin
+export UNSERMAKE=/usr/share/unsermake/unsermake
+%{__make} -f admin/Makefile.common cvs
 
 %configure \
+       %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
        --%{?debug:en}%{!?debug:dis}able-debug \
        --disable-rpath \
        --enable-final \
-       --with-xinerama \
-       --with%{?_without_alsa:out}-alsa
-
-%if %{!?_with_nas:1}0
-# Cannot patch configure.in because it does not rebuild correctly on ac25
-sed -e 's@#define HAVE_LIBAUDIONAS 1@/* #undef HAVE_LIBAUDIONAS */@' \
-       < config.h \
-       > config.h.tmp
-mv -f config.h{.tmp,}
-%endif
+       --with-qt-libraries=%{_libdir} \
+       --with%{!?with_alsa:out}-alsa
+
 %{__make}
 
 %install
@@ -134,6 +164,19 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# Debian manpages
+install -d $RPM_BUILD_ROOT%{_mandir}/man1
+cd debian/man
+for f in *.sgml ; do
+       base="$(basename $f .sgml)"
+       upper="$(echo ${base} | tr a-z A-Z)"
+       db2man $f
+       install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
+done
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
@@ -143,12 +186,6 @@ rm -rf $RPM_BUILD_ROOT
 %post  qt -p /sbin/ldconfig
 %postun        qt -p /sbin/ldconfig
 
-%post  glib -p /sbin/ldconfig
-%postun        glib -p /sbin/ldconfig
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/artscat
@@ -158,30 +195,90 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/artsrec
 %attr(755,root,root) %{_bindir}/artsshell
 %attr(755,root,root) %{_bindir}/artswrapper
-%attr(755,root,root) %{_bindir}/testdhandle
-%attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*.*.*
-%{_libdir}/lib[!gqx]*.la
+# shared libraries
+%attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
+%attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
+%attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
+%attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
+%attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
+%attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
+%attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
+%attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
+%attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
+# lt_dlopened modules (*.la needed)
+%attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
+%{_libdir}/libartscbackend.la
+%attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
+%{_libdir}/libartsdsp.la
+%attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
+%{_libdir}/libartsdsp_st.la
+%attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
+%{_libdir}/libartsgslplayobject.la
+%attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
+%{_libdir}/libartswavplayobject.la
+#
 %{_libdir}/mcop
+%{_mandir}/man1/artscat.1*
+%{_mandir}/man1/artsd.1*
+%{_mandir}/man1/artsdsp.1*
+%{_mandir}/man1/artsplay.1*
+%{_mandir}/man1/artsrec.1*
+%{_mandir}/man1/artsshell.1*
+%{_mandir}/man1/artswrapper.1*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/artsc-config
 %attr(755,root,root) %{_bindir}/mcopidl
-%{_libdir}/*.so
+%attr(755,root,root) %{_libdir}/libartsflow.so
+%attr(755,root,root) %{_libdir}/libartsflow_idl.so
+%attr(755,root,root) %{_libdir}/libartsgslplayobject.so
+%attr(755,root,root) %{_libdir}/libartswavplayobject.so
+%attr(755,root,root) %{_libdir}/libgmcop.so
+%attr(755,root,root) %{_libdir}/libkmedia2.so
+%attr(755,root,root) %{_libdir}/libkmedia2_idl.so
+%attr(755,root,root) %{_libdir}/libmcop.so
+%attr(755,root,root) %{_libdir}/libmcop_mt.so
+%attr(755,root,root) %{_libdir}/libsoundserver_idl.so
+# it seems to be only (lt_)dlopened, nothing links with it - so not needed
+# %attr(755,root,root) %{_libdir}/libx11globalcomm.so
+# shared libraries
+%{_libdir}/libartsflow.la
+%{_libdir}/libartsflow_idl.la
+%{_libdir}/libgmcop.la
+%{_libdir}/libkmedia2.la
+%{_libdir}/libkmedia2_idl.la
+%{_libdir}/libmcop.la
+%{_libdir}/libmcop_mt.la
+%{_libdir}/libsoundserver_idl.la
+#
 %{_includedir}/arts
+%exclude %{_includedir}/arts/qiomanager.h
+%{_mandir}/man1/mcopidl.1*
+
+%files -n artsc-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/artsc-config
+%attr(755,root,root) %{_libdir}/libartsc.so
+%attr(755,root,root) %{_libdir}/libartscbackend.so
+%attr(755,root,root) %{_libdir}/libartsdsp.so
+%attr(755,root,root) %{_libdir}/libartsdsp_st.so
+%{_libdir}/libartsc.la
 %{_includedir}/artsc
+%{_mandir}/man1/artsc-config.1*
 
 %files X11
 %defattr(644,root,root,755)
+# lt_dlopened module (.la needed)
 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
 %{_libdir}/libx11globalcomm.la
 
-%files glib
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
-%{_libdir}/libgmcop.la
-
 %files qt
 %defattr(644,root,root,755)
+# shared library
 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
+
+%files qt-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libqtmcop.so
 %{_libdir}/libqtmcop.la
+%{_includedir}/arts/qiomanager.h
This page took 0.041911 seconds and 4 git commands to generate.