]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- define kdever
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #
7
8 %define         _state          unstable
9 %define         _kdever         3.3
10 %define         _ver            1.3.0
11
12 Summary:        aRts sound server
13 Summary(pl):    Serwer d¼wiêku
14 Summary(pt_BR): Servidor de sons usado pelo KDE
15 Name:           arts
16 Version:        %{_ver}
17 Release:        0.1
18 Epoch:          13
19 License:        LGPL
20 Group:          Libraries
21 Source0:        http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
22 # Source0-md5:  6a0a03c24a20c43a8e443a5484bb9fef
23 URL:            http://www.kde.org/
24 %{?with_alsa:BuildRequires:     alsa-lib-devel}
25 BuildRequires:  audiofile-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  docbook-dtd41-sgml
29 BuildRequires:  docbook-utils >= 0.6.13-3
30 %{?with_esd:BuildRequires:      esound-devel}
31 BuildRequires:  glib2-devel >= 2.0.0
32 BuildRequires:  libmad-devel
33 BuildRequires:  libtool >= 2:1.5-2
34 BuildRequires:  libvorbis-devel
35 %{?with_nas:BuildRequires:      nas-devel}
36 BuildRequires:  pkgconfig
37 BuildRequires:  qt-devel >= 6:3.2.1-4
38 BuildRequires:  unsermake >= 040805-1
39 Obsoletes:      arts-glib
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 The Analog Real-Time Synthesizer, or aRts, is a modular system for
44 synthesizing sound and music on a digital computer. Using small
45 building blocks called modules, the user can easily build complex
46 audio processing tools. Modules typically provide functions such as
47 sound waveform generators, filters, audio effects, mixing, and
48 playback of digital audio in different file formats. The artsd sound
49 server mixes audio from several sources in real time, allowing
50 multiple sound applications to transparently share access to sound
51 hardware.
52
53 %description -l pl
54 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
55 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
56 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
57 d¼wiêku. Modu³y umo¿liwiaj± generacjê kstza³tu fali, filtrowanie,
58 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
59 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
60 odtwarzanie d¼wiêku z wielu ¼róde³.
61
62 %description -l pt_BR
63 O aRts é um sintetizador analógico em tempo real que é completamente
64 modular. Você pode criar sons e músicas (síntese em tempo real de
65 midi) usando pequenos módulos como oscilador para criar waveforms,
66 vários filtros, mixers, faders, etc. Você pode configurar tudo através
67 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
68 design foi escolhido para permitir que outras aplicações usem o aRts
69 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
70 outros.
71
72 %package devel
73 Summary:        Sound server - header files
74 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
75 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
76 Group:          Development/Libraries
77 Requires:       %{name} = %{epoch}:%{version}-%{release}
78 # not necessary for all libs (e.g. mcop), but propagated by artsflow
79 %{?with_alsa:Requires:  alsa-lib-devel}
80 Requires:       audiofile-devel
81 Requires:       esound-devel
82 Requires:       glib2-devel >= 2.0.0
83 Requires:       libmad-devel
84 Requires:       libvorbis-devel
85 %{?with_nas:Requires:   nas-devel}
86
87 %description devel
88 Header files required to compile programs using arts.
89
90 %description devel -l pl
91 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
92 arts.
93
94 %description devel -l pt_BR
95 Arquivos para desenvolvimento com o o aRts.
96
97 # separate from arts-devel because they are mostly independent and
98 # have very # different deps  there is no artsc base - it would be
99 # small and would require arts - so there is no reason to separate
100 %package -n artsc-devel
101 Summary:        Development files for artsc libraries
102 Summary(pl):    Pliki programistyczne bibliotek artsc
103 Group:          Development/Libraries
104 Requires:       %{name} = %{epoch}:%{version}-%{release}
105 Requires:       glib2-devel >= 2.0.0
106 Conflicts:      arts-devel < 12:1.2.0.031126-2
107
108 %description -n artsc-devel
109 Development files for artsc libraries (C interface to aRts sound
110 system).
111
112 %description -n artsc-devel -l pl
113 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
114 d¼wiêku aRts).
115
116 %package X11
117 Summary:        X11 dependent part of aRts
118 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
119 Group:          X11/Libraries
120 Requires:       %{name} = %{epoch}:%{version}-%{release}
121
122 %description X11
123 X11 dependent part of aRts (x11globalcomm module).
124
125 %description X11 -l pl
126 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
127
128 %package qt
129 Summary:        QT dependend part of aRts
130 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
131 Group:          X11/Libraries
132 Requires:       %{name} = %{epoch}:%{version}-%{release}
133 Requires:       qt >= 6:3.2.1-4
134
135 %description qt
136 QT dependend part of aRts (qtmcop library).
137
138 %description qt -l pl
139 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
140
141 %package qt-devel
142 Summary:        Development files for qtmcop library
143 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
144 Group:          X11/Development/Libraries
145 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
146 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
147 Requires:       qt-devel >= 6:3.2.1-4
148
149 %description qt-devel
150 Development files for qtmcop library.
151
152 %description qt-devel -l pl
153 Pliki programistyczne dla biblioteki qtmcop.
154
155 %prep
156 %setup -q -n %{name}-%{version}
157
158 %build
159 cp /usr/share/automake/config.sub admin
160
161 export UNSERMAKE=/usr/share/unsermake/unsermake
162
163 %{__make} -f admin/Makefile.common cvs
164
165 %configure \
166         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
167         --%{?debug:en}%{!?debug:dis}able-debug \
168         --disable-rpath \
169         --enable-final \
170         --with-qt-libraries=%{_libdir} \
171         --with%{!?with_alsa:out}-alsa
172
173 %{__make}
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177
178 %{__make} install \
179         DESTDIR=$RPM_BUILD_ROOT
180
181 # Debian manpages
182 install -d $RPM_BUILD_ROOT%{_mandir}/man1
183 cd debian/man
184 for f in *.sgml ; do
185         base="$(basename $f .sgml)"
186         upper="$(echo ${base} | tr a-z A-Z)"
187         db2man $f
188         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
189 done
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %post   -p /sbin/ldconfig
195 %postun -p /sbin/ldconfig
196
197 %post   X11 -p /sbin/ldconfig
198 %postun X11 -p /sbin/ldconfig
199
200 %post   qt -p /sbin/ldconfig
201 %postun qt -p /sbin/ldconfig
202
203 %files
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_bindir}/artscat
206 %attr(755,root,root) %{_bindir}/artsd
207 %attr(755,root,root) %{_bindir}/artsdsp
208 %attr(755,root,root) %{_bindir}/artsplay
209 %attr(755,root,root) %{_bindir}/artsrec
210 %attr(755,root,root) %{_bindir}/artsshell
211 %attr(755,root,root) %{_bindir}/artswrapper
212 # shared libraries
213 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
214 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
215 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
216 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
217 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
218 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
219 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
220 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
222 # lt_dlopened modules (*.la needed)
223 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
224 %{_libdir}/libartscbackend.la
225 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
226 %{_libdir}/libartsdsp.la
227 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
228 %{_libdir}/libartsdsp_st.la
229 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
230 %{_libdir}/libartsgslplayobject.la
231 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
232 %{_libdir}/libartswavplayobject.la
233 #
234 %{_libdir}/mcop
235 %{_mandir}/man1/artscat.1*
236 %{_mandir}/man1/artsd.1*
237 %{_mandir}/man1/artsdsp.1*
238 %{_mandir}/man1/artsplay.1*
239 %{_mandir}/man1/artsrec.1*
240 %{_mandir}/man1/artsshell.1*
241 %{_mandir}/man1/artswrapper.1*
242
243 %files devel
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_bindir}/mcopidl
246 %attr(755,root,root) %{_libdir}/libartsflow.so
247 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
248 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
249 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
250 %attr(755,root,root) %{_libdir}/libgmcop.so
251 %attr(755,root,root) %{_libdir}/libkmedia2.so
252 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
253 %attr(755,root,root) %{_libdir}/libmcop.so
254 %attr(755,root,root) %{_libdir}/libmcop_mt.so
255 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
256 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
257 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
258 # shared libraries
259 %{_libdir}/libartsflow.la
260 %{_libdir}/libartsflow_idl.la
261 %{_libdir}/libgmcop.la
262 %{_libdir}/libkmedia2.la
263 %{_libdir}/libkmedia2_idl.la
264 %{_libdir}/libmcop.la
265 %{_libdir}/libmcop_mt.la
266 %{_libdir}/libsoundserver_idl.la
267 #
268 %{_includedir}/arts
269 %exclude %{_includedir}/arts/qiomanager.h
270 %{_mandir}/man1/mcopidl.1*
271
272 %files -n artsc-devel
273 %defattr(644,root,root,755)
274 %attr(755,root,root) %{_bindir}/artsc-config
275 %attr(755,root,root) %{_libdir}/libartsc.so
276 %attr(755,root,root) %{_libdir}/libartscbackend.so
277 %attr(755,root,root) %{_libdir}/libartsdsp.so
278 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
279 %{_libdir}/libartsc.la
280 %{_includedir}/artsc
281 %{_mandir}/man1/artsc-config.1*
282
283 %files X11
284 %defattr(644,root,root,755)
285 # lt_dlopened module (.la needed)
286 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
287 %{_libdir}/libx11globalcomm.la
288
289 %files qt
290 %defattr(644,root,root,755)
291 # shared library
292 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
293
294 %files qt-devel
295 %defattr(644,root,root,755)
296 %attr(755,root,root) %{_libdir}/libqtmcop.so
297 %{_libdir}/libqtmcop.la
298 %{_includedir}/arts/qiomanager.h
This page took 0.070577 seconds and 4 git commands to generate.