]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- fixed _kdever; aren't these 3 macros redundant btw?
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #
7
8 %define         _state          stable
9 %define         _kdever         3.4
10 %define         _ver            1.4.0
11
12 Summary:        aRts sound server
13 Summary(pl):    Serwer d¼wiêku
14 Summary(pt_BR): Servidor de sons usado pelo KDE
15 Name:           arts
16 Version:        %{_ver}
17 Release:        0.1
18 Epoch:          13
19 License:        LGPL
20 Group:          Libraries
21 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
22 # Source0-md5:  a155bb00f56c71bc475890249e2dcaa9
23 URL:            http://www.arts-project.org/
24 %{?with_alsa:BuildRequires:     alsa-lib-devel}
25 BuildRequires:  audiofile-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  docbook-dtd41-sgml
29 BuildRequires:  docbook-utils >= 0.6.13-3
30 %{?with_esd:BuildRequires:      esound-devel}
31 BuildRequires:  glib2-devel >= 2.0.0
32 BuildRequires:  jack-audio-connection-kit-devel
33 BuildRequires:  libmad-devel
34 BuildRequires:  libtool >= 2:1.5-2
35 BuildRequires:  libvorbis-devel
36 %{?with_nas:BuildRequires:      nas-devel}
37 BuildRequires:  pkgconfig
38 BuildRequires:  qt-devel >= 6:3.2.1-4
39 #BuildRequires: unsermake >= 040805-1
40 Obsoletes:      arts-glib
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 The Analog Real-Time Synthesizer, or aRts, is a modular system for
45 synthesizing sound and music on a digital computer. Using small
46 building blocks called modules, the user can easily build complex
47 audio processing tools. Modules typically provide functions such as
48 sound waveform generators, filters, audio effects, mixing, and
49 playback of digital audio in different file formats. The artsd sound
50 server mixes audio from several sources in real time, allowing
51 multiple sound applications to transparently share access to sound
52 hardware.
53
54 %description -l pl
55 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
56 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
57 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
58 d¼wiêku. Modu³y umo¿liwiaj± generacjê kszta³tu fali, filtrowanie,
59 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
60 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
61 odtwarzanie d¼wiêku z wielu ¼róde³.
62
63 %description -l pt_BR
64 O aRts é um sintetizador analógico em tempo real que é completamente
65 modular. Você pode criar sons e músicas (síntese em tempo real de
66 midi) usando pequenos módulos como oscilador para criar waveforms,
67 vários filtros, mixers, faders, etc. Você pode configurar tudo através
68 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
69 design foi escolhido para permitir que outras aplicações usem o aRts
70 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
71 outros.
72
73 %package devel
74 Summary:        Sound server - header files
75 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
76 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
77 Group:          Development/Libraries
78 Requires:       %{name} = %{epoch}:%{version}-%{release}
79 # not necessary for all libs (e.g. mcop), but propagated by artsflow
80 %{?with_alsa:Requires:  alsa-lib-devel}
81 Requires:       audiofile-devel
82 Requires:       esound-devel
83 Requires:       glib2-devel >= 2.0.0
84 Requires:       jack-audio-connection-kit-devel
85 Requires:       libmad-devel
86 Requires:       libvorbis-devel
87 %{?with_nas:Requires:   nas-devel}
88
89 %description devel
90 Header files required to compile programs using arts.
91
92 %description devel -l pl
93 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
94 arts.
95
96 %description devel -l pt_BR
97 Arquivos para desenvolvimento com o o aRts.
98
99 # separate from arts-devel because they are mostly independent and have very
100 # different deps
101 # there is no artsc base - it would be small and would require arts - so
102 # there is no reason to separate
103 %package -n artsc-devel
104 Summary:        Development files for artsc libraries
105 Summary(pl):    Pliki programistyczne bibliotek artsc
106 Group:          Development/Libraries
107 Requires:       %{name} = %{epoch}:%{version}-%{release}
108 Requires:       glib2-devel >= 2.0.0
109 Conflicts:      arts-devel < 12:1.2.0.031126-2
110
111 %description -n artsc-devel
112 Development files for artsc libraries (C interface to aRts sound
113 system).
114
115 %description -n artsc-devel -l pl
116 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
117 d¼wiêku aRts).
118
119 %package X11
120 Summary:        X11 dependent part of aRts
121 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
122 Group:          X11/Libraries
123 Requires:       %{name} = %{epoch}:%{version}-%{release}
124
125 %description X11
126 X11 dependent part of aRts (x11globalcomm module).
127
128 %description X11 -l pl
129 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
130
131 %package qt
132 Summary:        Qt dependend part of aRts
133 Summary(pl):    Czê¶æ aRts wymagaj±ca Qt
134 Group:          X11/Libraries
135 Requires:       %{name} = %{epoch}:%{version}-%{release}
136 Requires:       qt >= 6:3.2.1-4
137
138 %description qt
139 Qt dependend part of aRts (qtmcop library).
140
141 %description qt -l pl
142 Czê¶æ aRts wymagaj±ca Qt (biblioteka qtmcop).
143
144 %package qt-devel
145 Summary:        Development files for qtmcop library
146 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
147 Group:          X11/Development/Libraries
148 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
149 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
150 Requires:       qt-devel >= 6:3.2.1-4
151
152 %description qt-devel
153 Development files for qtmcop library.
154
155 %description qt-devel -l pl
156 Pliki programistyczne dla biblioteki qtmcop.
157
158 %prep
159 %setup -q
160
161 %build
162 cp -f /usr/share/automake/config.sub admin
163
164 #export UNSERMAKE=/usr/share/unsermake/unsermake
165
166 %{__make} -f admin/Makefile.common cvs
167
168 %configure \
169         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
170 %if "%{_lib}" == "lib64"
171         --enable-libsuffix=64 \
172 %endif
173         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
174         %{!?debug:--disable-rpath} \
175         --enable-final \
176         --with-qt-libraries=%{_libdir} \
177         --with%{!?with_alsa:out}-alsa
178
179 %{__make}
180
181 %install
182 rm -rf $RPM_BUILD_ROOT
183
184 %{__make} install \
185         DESTDIR=$RPM_BUILD_ROOT
186
187 # Debian manpages
188 install -d $RPM_BUILD_ROOT%{_mandir}/man1
189 cd debian/man
190 for f in *.sgml ; do
191         base="$(basename $f .sgml)"
192         upper="$(echo ${base} | tr a-z A-Z)"
193         db2man $f
194         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
195 done
196
197 %clean
198 rm -rf $RPM_BUILD_ROOT
199
200 %post   -p /sbin/ldconfig
201 %postun -p /sbin/ldconfig
202
203 %post   X11 -p /sbin/ldconfig
204 %postun X11 -p /sbin/ldconfig
205
206 %post   qt -p /sbin/ldconfig
207 %postun qt -p /sbin/ldconfig
208
209 %files
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_bindir}/artscat
212 %attr(755,root,root) %{_bindir}/artsd
213 %attr(755,root,root) %{_bindir}/artsdsp
214 %attr(755,root,root) %{_bindir}/artsplay
215 %attr(755,root,root) %{_bindir}/artsrec
216 %attr(755,root,root) %{_bindir}/artsshell
217 %attr(755,root,root) %{_bindir}/artswrapper
218 # shared libraries
219 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
220 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
223 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
224 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
225 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
226 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
227 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
228 # lt_dlopened modules (*.la needed)
229 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
230 %{_libdir}/libartscbackend.la
231 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
232 %{_libdir}/libartsdsp.la
233 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
234 %{_libdir}/libartsdsp_st.la
235 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
236 %{_libdir}/libartsgslplayobject.la
237 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
238 %{_libdir}/libartswavplayobject.la
239 #
240 %{_libdir}/mcop
241 %{_mandir}/man1/artscat.1*
242 %{_mandir}/man1/artsd.1*
243 %{_mandir}/man1/artsdsp.1*
244 %{_mandir}/man1/artsplay.1*
245 %{_mandir}/man1/artsrec.1*
246 %{_mandir}/man1/artsshell.1*
247 %{_mandir}/man1/artswrapper.1*
248
249 %files devel
250 %defattr(644,root,root,755)
251 %attr(755,root,root) %{_bindir}/mcopidl
252 %attr(755,root,root) %{_libdir}/libartsflow.so
253 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
254 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
255 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
256 %attr(755,root,root) %{_libdir}/libgmcop.so
257 %attr(755,root,root) %{_libdir}/libkmedia2.so
258 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
259 %attr(755,root,root) %{_libdir}/libmcop.so
260 %attr(755,root,root) %{_libdir}/libmcop_mt.so
261 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
262 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
263 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
264 # shared libraries
265 %{_libdir}/libartsflow.la
266 %{_libdir}/libartsflow_idl.la
267 %{_libdir}/libgmcop.la
268 %{_libdir}/libkmedia2.la
269 %{_libdir}/libkmedia2_idl.la
270 %{_libdir}/libmcop.la
271 %{_libdir}/libmcop_mt.la
272 %{_libdir}/libsoundserver_idl.la
273 #
274 %{_includedir}/arts
275 %exclude %{_includedir}/arts/qiomanager.h
276 %{_mandir}/man1/mcopidl.1*
277
278 %files -n artsc-devel
279 %defattr(644,root,root,755)
280 %attr(755,root,root) %{_bindir}/artsc-config
281 %attr(755,root,root) %{_libdir}/libartsc.so
282 %attr(755,root,root) %{_libdir}/libartscbackend.so
283 %attr(755,root,root) %{_libdir}/libartsdsp.so
284 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
285 %{_libdir}/libartsc.la
286 %{_includedir}/artsc
287 %{_mandir}/man1/artsc-config.1*
288
289 %files X11
290 %defattr(644,root,root,755)
291 # lt_dlopened module (.la needed)
292 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
293 %{_libdir}/libx11globalcomm.la
294
295 %files qt
296 %defattr(644,root,root,755)
297 # shared library
298 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
299
300 %files qt-devel
301 %defattr(644,root,root,755)
302 %attr(755,root,root) %{_libdir}/libqtmcop.so
303 %{_libdir}/libqtmcop.la
304 %{_includedir}/arts/qiomanager.h
This page took 0.101991 seconds and 4 git commands to generate.