]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- final tarball
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #
7 %define         _state          stable
8 %define         _kdever         3.5
9 %define         _ver            1.5.0
10 #
11 Summary:        aRts sound server
12 Summary(pl):    Serwer d¼wiêku
13 Summary(pt_BR): Servidor de sons usado pelo KDE
14 Name:           arts
15 Version:        %{_ver}
16 Release:        0.2
17 Epoch:          13
18 License:        LGPL
19 Group:          Libraries
20 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
21 # Source0-md5:  e90a32ee47d5cdc51fe1b7f6f6c0df63
22 Patch100:       %{name}-branch.diff
23 URL:            http://www.arts-project.org/
24 %{?with_alsa:BuildRequires:     alsa-lib-devel}
25 BuildRequires:  audiofile-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  docbook-dtd41-sgml
29 BuildRequires:  docbook-utils >= 0.6.14
30 %{?with_esd:BuildRequires:      esound-devel}
31 BuildRequires:  glib2-devel >= 2.0.0
32 BuildRequires:  jack-audio-connection-kit-devel
33 BuildRequires:  libmad-devel
34 BuildRequires:  libtool >= 2:1.5-2
35 BuildRequires:  libvorbis-devel
36 %{?with_nas:BuildRequires:      nas-devel}
37 BuildRequires:  pkgconfig
38 BuildRequires:  qt-devel >= 6:3.2.1-4
39 #BuildRequires: unsermake >= 040805-1
40 Obsoletes:      arts-glib
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 The Analog Real-Time Synthesizer, or aRts, is a modular system for
45 synthesizing sound and music on a digital computer. Using small
46 building blocks called modules, the user can easily build complex
47 audio processing tools. Modules typically provide functions such as
48 sound waveform generators, filters, audio effects, mixing, and
49 playback of digital audio in different file formats. The artsd sound
50 server mixes audio from several sources in real time, allowing
51 multiple sound applications to transparently share access to sound
52 hardware.
53
54 %description -l pl
55 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
56 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
57 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
58 d¼wiêku. Modu³y umo¿liwiaj± generacjê kszta³tu fali, filtrowanie,
59 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
60 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
61 odtwarzanie d¼wiêku z wielu ¼róde³.
62
63 %description -l pt_BR
64 O aRts é um sintetizador analógico em tempo real que é completamente
65 modular. Você pode criar sons e músicas (síntese em tempo real de
66 midi) usando pequenos módulos como oscilador para criar waveforms,
67 vários filtros, mixers, faders, etc. Você pode configurar tudo através
68 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
69 design foi escolhido para permitir que outras aplicações usem o aRts
70 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
71 outros.
72
73 %package devel
74 Summary:        Sound server - header files
75 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
76 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
77 Group:          Development/Libraries
78 Requires:       %{name} = %{epoch}:%{version}-%{release}
79 # not necessary for all libs (e.g. mcop), but propagated by artsflow
80 %{?with_alsa:Requires:  alsa-lib-devel}
81 Requires:       audiofile-devel
82 Requires:       esound-devel
83 Requires:       glib2-devel >= 2.0.0
84 Requires:       jack-audio-connection-kit-devel
85 Requires:       libmad-devel
86 Requires:       libvorbis-devel
87 %{?with_nas:Requires:   nas-devel}
88
89 %description devel
90 Header files required to compile programs using arts.
91
92 %description devel -l pl
93 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
94 arts.
95
96 %description devel -l pt_BR
97 Arquivos para desenvolvimento com o o aRts.
98
99 # separate from arts-devel because they are mostly independent and have very
100 # different deps
101 # there is no artsc base - it would be small and would require arts - so
102 # there is no reason to separate
103 %package -n artsc-devel
104 Summary:        Development files for artsc libraries
105 Summary(pl):    Pliki programistyczne bibliotek artsc
106 Group:          Development/Libraries
107 Requires:       %{name} = %{epoch}:%{version}-%{release}
108 Requires:       glib2-devel >= 2.0.0
109 Conflicts:      arts-devel < 12:1.2.0.031126-2
110
111 %description -n artsc-devel
112 Development files for artsc libraries (C interface to aRts sound
113 system).
114
115 %description -n artsc-devel -l pl
116 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
117 d¼wiêku aRts).
118
119 %package X11
120 Summary:        X11 dependent part of aRts
121 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
122 Group:          X11/Libraries
123 Requires:       %{name} = %{epoch}:%{version}-%{release}
124
125 %description X11
126 X11 dependent part of aRts (x11globalcomm module).
127
128 %description X11 -l pl
129 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
130
131 %package qt
132 Summary:        Qt dependend part of aRts
133 Summary(pl):    Czê¶æ aRts wymagaj±ca Qt
134 Group:          X11/Libraries
135 Requires:       %{name} = %{epoch}:%{version}-%{release}
136 Requires:       qt >= 6:3.2.1-4
137
138 %description qt
139 Qt dependend part of aRts (qtmcop library).
140
141 %description qt -l pl
142 Czê¶æ aRts wymagaj±ca Qt (biblioteka qtmcop).
143
144 %package qt-devel
145 Summary:        Development files for qtmcop library
146 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
147 Group:          X11/Development/Libraries
148 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
149 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
150 Requires:       qt-devel >= 6:3.2.1-4
151
152 %description qt-devel
153 Development files for qtmcop library.
154
155 %description qt-devel -l pl
156 Pliki programistyczne dla biblioteki qtmcop.
157
158 %prep
159 %setup -q
160 #%patch100 -p1
161
162 %build
163 cp -f /usr/share/automake/config.sub admin
164
165 #export UNSERMAKE=/usr/share/unsermake/unsermake
166
167 %{__make} -f admin/Makefile.common cvs
168
169 %configure \
170         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
171 %if "%{_lib}" == "lib64"
172         --enable-libsuffix=64 \
173 %endif
174         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
175         %{!?debug:--disable-rpath} \
176         --enable-final \
177         --with-qt-libraries=%{_libdir} \
178         --with%{!?with_alsa:out}-alsa
179
180 %{__make} \
181         CXXLD=%{_host_cpu}-%{_vendor}-%{_os}-g++ \
182         CCLD=%{_host_cpu}-%{_vendor}-%{_os}-gcc
183
184 %install
185 rm -rf $RPM_BUILD_ROOT
186
187 %{__make} install \
188         DESTDIR=$RPM_BUILD_ROOT
189
190 # Debian manpages
191 install -d $RPM_BUILD_ROOT%{_mandir}/man1
192 cd debian/man
193 for f in *.sgml ; do
194         base="$(basename $f .sgml)"
195         upper="$(echo ${base} | tr a-z A-Z)"
196         db2man $f
197         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
198 done
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post   -p /sbin/ldconfig
204 %postun -p /sbin/ldconfig
205
206 %post   X11 -p /sbin/ldconfig
207 %postun X11 -p /sbin/ldconfig
208
209 %post   qt -p /sbin/ldconfig
210 %postun qt -p /sbin/ldconfig
211
212 %files
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_bindir}/artscat
215 %attr(755,root,root) %{_bindir}/artsd
216 %attr(755,root,root) %{_bindir}/artsdsp
217 %attr(755,root,root) %{_bindir}/artsplay
218 %attr(755,root,root) %{_bindir}/artsrec
219 %attr(755,root,root) %{_bindir}/artsshell
220 %attr(755,root,root) %{_bindir}/artswrapper
221 # shared libraries
222 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
223 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
224 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
225 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
226 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
227 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
228 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
229 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
230 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
231 # lt_dlopened modules (*.la needed)
232 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
233 %{_libdir}/libartscbackend.la
234 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
235 %{_libdir}/libartsdsp.la
236 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
237 %{_libdir}/libartsdsp_st.la
238 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
239 %{_libdir}/libartsgslplayobject.la
240 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
241 %{_libdir}/libartswavplayobject.la
242 #
243 %{_libdir}/mcop
244 %{_mandir}/man1/artscat.1*
245 %{_mandir}/man1/artsd.1*
246 %{_mandir}/man1/artsdsp.1*
247 %{_mandir}/man1/artsplay.1*
248 %{_mandir}/man1/artsrec.1*
249 %{_mandir}/man1/artsshell.1*
250 %{_mandir}/man1/artswrapper.1*
251
252 %files devel
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_bindir}/mcopidl
255 %attr(755,root,root) %{_libdir}/libartsflow.so
256 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
257 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
258 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
259 %attr(755,root,root) %{_libdir}/libgmcop.so
260 %attr(755,root,root) %{_libdir}/libkmedia2.so
261 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
262 %attr(755,root,root) %{_libdir}/libmcop.so
263 %attr(755,root,root) %{_libdir}/libmcop_mt.so
264 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
265 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
266 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
267 # shared libraries
268 %{_libdir}/libartsflow.la
269 %{_libdir}/libartsflow_idl.la
270 %{_libdir}/libgmcop.la
271 %{_libdir}/libkmedia2.la
272 %{_libdir}/libkmedia2_idl.la
273 %{_libdir}/libmcop.la
274 %{_libdir}/libmcop_mt.la
275 %{_libdir}/libsoundserver_idl.la
276 #
277 %{_includedir}/arts
278 %exclude %{_includedir}/arts/qiomanager.h
279 %{_mandir}/man1/mcopidl.1*
280
281 %files -n artsc-devel
282 %defattr(644,root,root,755)
283 %attr(755,root,root) %{_bindir}/artsc-config
284 %attr(755,root,root) %{_libdir}/libartsc.so
285 %attr(755,root,root) %{_libdir}/libartscbackend.so
286 %attr(755,root,root) %{_libdir}/libartsdsp.so
287 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
288 %{_libdir}/libartsc.la
289 %{_includedir}/artsc
290 %{_mandir}/man1/artsc-config.1*
291
292 %files X11
293 %defattr(644,root,root,755)
294 # lt_dlopened module (.la needed)
295 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
296 %{_libdir}/libx11globalcomm.la
297
298 %files qt
299 %defattr(644,root,root,755)
300 # shared library
301 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
302
303 %files qt-devel
304 %defattr(644,root,root,755)
305 %attr(755,root,root) %{_libdir}/libqtmcop.so
306 %{_libdir}/libqtmcop.la
307 %{_includedir}/arts/qiomanager.h
This page took 0.077316 seconds and 4 git commands to generate.