]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- rel 1
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #
7 %define         _state          stable
8 %define         _kdever         3.4.3
9 %define         _ver            1.4.3
10 #
11 Summary:        aRts sound server
12 Summary(pl):    Serwer d¼wiêku
13 Summary(pt_BR): Servidor de sons usado pelo KDE
14 Name:           arts
15 Version:        %{_ver}
16 Release:        1
17 Epoch:          13
18 License:        LGPL
19 Group:          Libraries
20 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
21 # Source0-md5:  58585969a9a33784601122c77bd15a1e
22 Patch100:       %{name}-branch.diff
23 URL:            http://www.arts-project.org/
24 %{?with_alsa:BuildRequires:     alsa-lib-devel}
25 BuildRequires:  audiofile-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  docbook-dtd41-sgml
29 BuildRequires:  docbook-utils >= 0.6.14
30 %{?with_esd:BuildRequires:      esound-devel}
31 BuildRequires:  glib2-devel >= 2.0.0
32 BuildRequires:  jack-audio-connection-kit-devel
33 BuildRequires:  libmad-devel
34 BuildRequires:  libtool >= 2:1.5-2
35 BuildRequires:  libvorbis-devel
36 %{?with_nas:BuildRequires:      nas-devel}
37 BuildRequires:  pkgconfig
38 BuildRequires:  qt-devel >= 6:3.2.1-4
39 #BuildRequires: unsermake >= 040805-1
40 Obsoletes:      arts-glib
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 The Analog Real-Time Synthesizer, or aRts, is a modular system for
45 synthesizing sound and music on a digital computer. Using small
46 building blocks called modules, the user can easily build complex
47 audio processing tools. Modules typically provide functions such as
48 sound waveform generators, filters, audio effects, mixing, and
49 playback of digital audio in different file formats. The artsd sound
50 server mixes audio from several sources in real time, allowing
51 multiple sound applications to transparently share access to sound
52 hardware.
53
54 %description -l pl
55 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
56 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
57 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
58 d¼wiêku. Modu³y umo¿liwiaj± generacjê kszta³tu fali, filtrowanie,
59 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
60 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
61 odtwarzanie d¼wiêku z wielu ¼róde³.
62
63 %description -l pt_BR
64 O aRts é um sintetizador analógico em tempo real que é completamente
65 modular. Você pode criar sons e músicas (síntese em tempo real de
66 midi) usando pequenos módulos como oscilador para criar waveforms,
67 vários filtros, mixers, faders, etc. Você pode configurar tudo através
68 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
69 design foi escolhido para permitir que outras aplicações usem o aRts
70 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
71 outros.
72
73 %package devel
74 Summary:        Sound server - header files
75 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
76 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
77 Group:          Development/Libraries
78 Requires:       %{name} = %{epoch}:%{version}-%{release}
79 # not necessary for all libs (e.g. mcop), but propagated by artsflow
80 %{?with_alsa:Requires:  alsa-lib-devel}
81 Requires:       audiofile-devel
82 Requires:       esound-devel
83 Requires:       glib2-devel >= 2.0.0
84 Requires:       jack-audio-connection-kit-devel
85 Requires:       libmad-devel
86 Requires:       libvorbis-devel
87 %{?with_nas:Requires:   nas-devel}
88
89 %description devel
90 Header files required to compile programs using arts.
91
92 %description devel -l pl
93 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
94 arts.
95
96 %description devel -l pt_BR
97 Arquivos para desenvolvimento com o o aRts.
98
99 # separate from arts-devel because they are mostly independent and have very
100 # different deps
101 # there is no artsc base - it would be small and would require arts - so
102 # there is no reason to separate
103 %package -n artsc-devel
104 Summary:        Development files for artsc libraries
105 Summary(pl):    Pliki programistyczne bibliotek artsc
106 Group:          Development/Libraries
107 Requires:       %{name} = %{epoch}:%{version}-%{release}
108 Requires:       glib2-devel >= 2.0.0
109 Conflicts:      arts-devel < 12:1.2.0.031126-2
110
111 %description -n artsc-devel
112 Development files for artsc libraries (C interface to aRts sound
113 system).
114
115 %description -n artsc-devel -l pl
116 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
117 d¼wiêku aRts).
118
119 %package X11
120 Summary:        X11 dependent part of aRts
121 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
122 Group:          X11/Libraries
123 Requires:       %{name} = %{epoch}:%{version}-%{release}
124
125 %description X11
126 X11 dependent part of aRts (x11globalcomm module).
127
128 %description X11 -l pl
129 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
130
131 %package qt
132 Summary:        Qt dependend part of aRts
133 Summary(pl):    Czê¶æ aRts wymagaj±ca Qt
134 Group:          X11/Libraries
135 Requires:       %{name} = %{epoch}:%{version}-%{release}
136 Requires:       qt >= 6:3.2.1-4
137
138 %description qt
139 Qt dependend part of aRts (qtmcop library).
140
141 %description qt -l pl
142 Czê¶æ aRts wymagaj±ca Qt (biblioteka qtmcop).
143
144 %package qt-devel
145 Summary:        Development files for qtmcop library
146 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
147 Group:          X11/Development/Libraries
148 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
149 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
150 Requires:       qt-devel >= 6:3.2.1-4
151
152 %description qt-devel
153 Development files for qtmcop library.
154
155 %description qt-devel -l pl
156 Pliki programistyczne dla biblioteki qtmcop.
157
158 %prep
159 %setup -q
160 #%patch100 -p1
161
162 %build
163 cp -f /usr/share/automake/config.sub admin
164
165 #export UNSERMAKE=/usr/share/unsermake/unsermake
166
167 %{__make} -f admin/Makefile.common cvs
168
169 %configure \
170         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
171 %if "%{_lib}" == "lib64"
172         --enable-libsuffix=64 \
173 %endif
174         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
175         %{!?debug:--disable-rpath} \
176         --enable-final \
177         --with-qt-libraries=%{_libdir} \
178         --with%{!?with_alsa:out}-alsa
179
180 %{__make}
181
182 %install
183 rm -rf $RPM_BUILD_ROOT
184
185 %{__make} install \
186         DESTDIR=$RPM_BUILD_ROOT
187
188 # Debian manpages
189 install -d $RPM_BUILD_ROOT%{_mandir}/man1
190 cd debian/man
191 for f in *.sgml ; do
192         base="$(basename $f .sgml)"
193         upper="$(echo ${base} | tr a-z A-Z)"
194         db2man $f
195         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
196 done
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %post   -p /sbin/ldconfig
202 %postun -p /sbin/ldconfig
203
204 %post   X11 -p /sbin/ldconfig
205 %postun X11 -p /sbin/ldconfig
206
207 %post   qt -p /sbin/ldconfig
208 %postun qt -p /sbin/ldconfig
209
210 %files
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_bindir}/artscat
213 %attr(755,root,root) %{_bindir}/artsd
214 %attr(755,root,root) %{_bindir}/artsdsp
215 %attr(755,root,root) %{_bindir}/artsplay
216 %attr(755,root,root) %{_bindir}/artsrec
217 %attr(755,root,root) %{_bindir}/artsshell
218 %attr(755,root,root) %{_bindir}/artswrapper
219 # shared libraries
220 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
223 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
224 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
225 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
226 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
227 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
228 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
229 # lt_dlopened modules (*.la needed)
230 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
231 %{_libdir}/libartscbackend.la
232 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
233 %{_libdir}/libartsdsp.la
234 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
235 %{_libdir}/libartsdsp_st.la
236 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
237 %{_libdir}/libartsgslplayobject.la
238 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
239 %{_libdir}/libartswavplayobject.la
240 #
241 %{_libdir}/mcop
242 %{_mandir}/man1/artscat.1*
243 %{_mandir}/man1/artsd.1*
244 %{_mandir}/man1/artsdsp.1*
245 %{_mandir}/man1/artsplay.1*
246 %{_mandir}/man1/artsrec.1*
247 %{_mandir}/man1/artsshell.1*
248 %{_mandir}/man1/artswrapper.1*
249
250 %files devel
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_bindir}/mcopidl
253 %attr(755,root,root) %{_libdir}/libartsflow.so
254 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
255 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
256 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
257 %attr(755,root,root) %{_libdir}/libgmcop.so
258 %attr(755,root,root) %{_libdir}/libkmedia2.so
259 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
260 %attr(755,root,root) %{_libdir}/libmcop.so
261 %attr(755,root,root) %{_libdir}/libmcop_mt.so
262 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
263 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
264 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
265 # shared libraries
266 %{_libdir}/libartsflow.la
267 %{_libdir}/libartsflow_idl.la
268 %{_libdir}/libgmcop.la
269 %{_libdir}/libkmedia2.la
270 %{_libdir}/libkmedia2_idl.la
271 %{_libdir}/libmcop.la
272 %{_libdir}/libmcop_mt.la
273 %{_libdir}/libsoundserver_idl.la
274 #
275 %{_includedir}/arts
276 %exclude %{_includedir}/arts/qiomanager.h
277 %{_mandir}/man1/mcopidl.1*
278
279 %files -n artsc-devel
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_bindir}/artsc-config
282 %attr(755,root,root) %{_libdir}/libartsc.so
283 %attr(755,root,root) %{_libdir}/libartscbackend.so
284 %attr(755,root,root) %{_libdir}/libartsdsp.so
285 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
286 %{_libdir}/libartsc.la
287 %{_includedir}/artsc
288 %{_mandir}/man1/artsc-config.1*
289
290 %files X11
291 %defattr(644,root,root,755)
292 # lt_dlopened module (.la needed)
293 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
294 %{_libdir}/libx11globalcomm.la
295
296 %files qt
297 %defattr(644,root,root,755)
298 # shared library
299 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
300
301 %files qt-devel
302 %defattr(644,root,root,755)
303 %attr(755,root,root) %{_libdir}/libqtmcop.so
304 %{_libdir}/libqtmcop.la
305 %{_includedir}/arts/qiomanager.h
This page took 0.06702 seconds and 4 git commands to generate.